Fix for Project Incompatibility Issues

(I posted this in another thread somewhere but I thought it might be helpful to have it in its own for anyone experiencing the problem of projects suddenly becoming “incompatible with this version of Scrivener.”)

After some playing around, I think I’ve figured out the problem (in a non-technical sense), and the solution makes sense of all the other user fixes I’ve seen in various threads, so I suspect this will be a comprehensive fix for everyone.

With the incompatible project closed, make a duplicate of the .scrivx file within the project, then delete the original (you can rename the duplicate just “project” if you like). Open Files\version.txt, select all and type “16” (no quotes) and save it. Bang, your project should work.

This should preserve not only all your writing but all the meta-data–the entire project, in fact, which some of the other fixes seem to be missing.

Something related to the version.txt file is presumably getting saved with the .xml file somewhere that’s not a part of the file itself (sort of–NTFS alternate data streams?) and gets lost when it’s copied, which is ideal here but I wonder if it’s part of what’s causing the version incompatibility? Although the real problem is that the .txt file is getting changed for whatever reason.

I can confirm that this fix worked for me.

I posted a month ago here: [url]]. I kept on using Scrivener, making separately renamed backup files after each spurt of writing, and pretty much figured the older file was history.

Did the fix, and the original file is back exactly as it was. :mrgreen: A++

Where’s the smiley for worship?

Glad it worked!