Getting images into Scapple

Admittedly, I only occasionally use Scapple so perhaps I am missing something, but I tried adding images to a document today (for the first time; only used text before) and have found it to be extremely unusual & confusing.

I’m on macOS 10.14.5 and Scapple 1.3.3 (404) and as far as I know all my preferences are defaults in Scapple.

When I drag/drop an image file (I’ve tried png & jpg so far) from Finder into an open Scapple document, it creates a new note which is a text link/URI pointing to the file’s location on my HDD. If I use Finder’s Copy and Scapple’s Paste on an image file, Scapple creates a new note with a full-resolution image of the OS’s default icon for images (i.e.: white page with curved corner, couple of beach photos and a loupe, and the file type in big letters). I did find that if I open the image in Preview, use Preview’s Copy and Scapple’s Paste, the image successfully appears in the Scapple document—so I have a workaround for now.

Trying to see whether images were even supported by Scapple, or what I might be doing wrong, was very challenging; it seems no one else has ever experienced this problem, or at least hasn’t mentioned it on the internet, and that images have been supported by Scapple without much trouble for years. Maybe the new version broke something, or maybe I have a setting wrong somewhere (though I can’t find anything in Scapple preferences). Hopefully this can be addressed; I’ll use the workaround for now, but it’s wildly inconvenient.

Seconding Teel’s question and comment: I’ve used Scapple to gather images for a long time, and I’m pretty sure I’d drag and drop them from the finder. In the current version, Scapple behaves as you describe, Teel: only Copy and Paste (from Preview, for instance) allows an image to appear in Scapple.

I rely on Scapple’s ability with images: has this changed in the newest version? The extra steps makes the process more cumbersome. I realize people want to be able to drag over file links (me too, sometimes)–is there a keyboard combination that can copy the image rather than the link? I haven’t found it yet.

Thanks for your info. :slight_smile:

Weird, I wonder if something changed with how Finder (or the system’s file drag and drop to be precise, as other file management tools do the same) drops images? I noticed that if I drag from a different program (like Firefox), I still get an image dropped into the board as pixels.

I found a workaround that works better than opening the image in Preview: simply copy from Finder and then paste into Scapple. That seems to be full resolution, but it wouldn’t surprise me if that’s only copying the preview or thumbnail of it. I only tried with images that are rather small to begin with.

Whatever the case, we’ll look into it.

Hi, I have same trouble like Teel commented above.
I’ve never have this problem but right after updating Scapple into recent version, there’s something wrong importing images from finder.

Had the same problem. Downloaded the previous version from: …

Works, done.

Same problem here. I tried dragging and dropping the same file in different types: .jpg, .jpeg, .pdf. I only see the url in Scapple.

I also tried copying the pdf file by selecting the icon and using the keyboard shortcuts (Control - C) and then pasting it in Scapple (Control - V). In this case, the icon of the .pdf file showed clearly in Scapple, but I could not see the image in the content of the file.

Teel’s workaround (“I did find that if I open the image in Preview, use Preview’s Copy and Scapple’s Paste, the image successfully appears in the Scapple document—so I have a workaround for now.”) works for me too.

This happens only sometimes for me. I’m using High Sierra 10.13.6, 2011 MacBook Pro.

Same thing here on macOS 10.14.5 and Scapple 1.3.3 (404).
– Drag and drop doesn’t work;
– Copy and Paste from the finder results in a generic icon (JPEG for instance);
– Open in Preview, then Copy/Paste works fine.

Have a nice day.


For those that use LaunchBar, there is a super handy command to Copy File Contents (⌥⌘C), and an even more handy command to Copy and Paste File Contents (⇧⌥⌘C), which dumps the pixels of the selected file directly into Scapple (or whatever program is in the foreground).

I am a new user of scapple, too, and have the same issue.

Hi @all, I just reported this as a bug report and linked to this thread. Lets hope for a quick fix!

Just in case it isn’t clear, I’m with L&L, and so we are in fact already well aware of this. We do not need any more confirmations or bug reports sent in. :smiley: Thanks for the helpfulness though, it is appreciated, I just don’t want anyone else to waste their time testing this or filing reports.

Workaround with “Preview copy” does not work for me, the only thing that works is making a screenshot with Shift+Option+Command+4 and then pasting it.

It would help to know a little more about what you’re trying, and what result you get. The type of image you are loading in Preview may make a difference (use ⌘I in Preview and examine the first tab, if you’re unsure), and what sort of result you see in Scapple. Is the Edit ▸ Paste menu command available?

A quick look at 1.3.3 says the same image posting problem remains.

I should hope so. :slight_smile: 1.3.3 is where the bug was introduced, so of course it will remain in that version so long as it exists. It is 1.3.4 where you should see things fixed.

I was wondering if there was an update to this? Thanks, Simon

Same here. I stumbled upon Scapple today, tested it for an hour and then bought it because I think it is really great and excactly what I was looking for. I did notice the bug that makes dragging images from the finder not work, but I also found that dragging from any other source works fine. So i’m confident this will be sorted out.

Found a workaround:

Drag & drop an image to Chrome, then drag it back to Scapple

^^ Firefox works too. A bit messy but gets the job done for now.