Help! Binder Text Goes Invisible When Editing

Version: (1274647) 64-bit - 28 Apr 2021

I’m not blaming this on Scrivener, I’m sure I’ve done it somehow myself. It’s been this way for a while now, but I would like to figure out what I did and set it back correctly…

As you can see from the screenshot, I have a colorful binder. When I click on an item to edit it, I initially see it highlighted in blue (selected) and see the title. When I start typing, it goes blank and I just have to type “by feel” until I hit return, whereupon it shows up.

(UPDATE: I see in the forum search there’s a “bug report”, but for me it happens anytime, not just when I have a dark background-- and it used to work correctly all the time, so far as I recall… though it could be a bug, I suppose.)

It used to work correctly. I’m pretty sure I’m the one who messed it up somewhere, but I don’t know offhand where to go and fix it.

Can someone assist me?




Hey there John,

I can’t find a setting for binder text color in File > Options, so my assumption is that the various text colors are being derived based on the binder background color.

I think I was able to prove this through testing. When I changed the setting Appearance > Binder > Binder Background, Scrivener automatically changed the binder Text Color to something it thought appropriate to the new background.

A complication is that when I changed the Binder Background color back to what it originally was, Scrivener did NOT correspondingly change the Binder Text color back to what it originally was. Instead, it took a guess at what an appropriate text color would be.

I’m guessing what’s happening in your case is that the Binder Text Entry color is set to be the same color as the Binder background. The Binder Text Entry color seems to be a different color setting internally than the Binder Text Color, as you can see in the screenshot below. Based on my mods to the Binder Background color, Scrivener left me with a Binder Text color of white, but the Binder Text Entry color is still the original theme color yellow!


I consider this a likely bug. If Scriv adjusts the Binder Text color to the background color, it should also adjust the Binder Entry Text color too.

Based on all that, my suggestion is to experiment with different Appearance > Binder > Binder Background settings and see if you can trick Scrivener to give you something workable. Remember that Scrivener will automatically adjust the Binder Text color to match the Background, but the Binder Entry Text color seems to be stuck to whatever it was originally set to in the theme.

If that doesn’t work, if it were me, I’d start from scratch. Take a few screen shots of your Scriv environment, capture key settings, save your .prefs and .scrtheme files. Then reload whatever Theme you started with, and start making changes from there. :man_shrugging:

Unless someone comes along with a better idea. :metal:

(If you are so inclined, you could start creating your own theme as was done in the pinned themes thread, but you’ll need to edit CSS files to accomplish that. That pinned thread has links to other threads that discuss which internal files need to be modified. Perhaps you’ll be able to find and fix the Binder Text Entry color value. )


Thanks for checking. I know it used to work, and then it wasn’t working.

It’s not the worst problem in the world as I can type it in in the editor, and I’m reasonably good at typing without looking, so I can live with it.


I think you are on to something there, Jim…

This feels very much like what I did. But you’re right, I don’t think there’s any explicit setting for the binder editbox color, for while editing.

I know of a couple other bugs that are similar in type, though not font-related, that are in the compiler settings (or maybe it’s the project style settings). Stuff that I could only fix by using VIM to open the file and editing the settings directly (don’t recall if it was in XML or RTF/RTX, but one or the other). I suppose I should open some bug reports on those.

Thank you for your help, Jim. I am pretty sure you’ve hit upon the problem and the solution is to open the file directly, look for the setting, and make the changes directly.


1 Like