Help! I've found two major bugs since updating to the most recent Windows version of Scrivener 3 (3.1.2)

Hello writers and L&L staff,

Would like to report (and hopefully get a solution for) two bugs I’ve noticed since the update.

  1. When I open any file in a Quick Reference window, then try to open an attached bookmark from the bookmark panel… NOTHING OPENS. I try to double click on them, but it doesn’t work anymore. I try to click “Open As Quick Reference”. Nada. Please fix this bug ASAP! I have SO MANY FILES that I need to quickly access as I cross-reference everything, and now it seems like I can’t open more than one quick reference window at a time or the bookmarks in the Quick Reference panel won’t work at all?? I just???

2. Scrivenings mode no longer lets me view multiple texts as one document??? At least when the texts are nested under a single text file. Viewing multiple texts as one will work fine for folders, but not for files nested under a text file. I tried doing everything I normally did to get it to work and nothing! Once again… this is CONFOUNDING as I’m in the painstaking process of cross-referencing files all over the place and, I really need to be able to see multiple nested files at once.RESOLVED! Make sure “Treat all documents with subdocuments as folders” is checked in Options > Behaviors > Folders & Files

2022-10-25 10_12_09-DUMMY Screenshot forum project - Scrivener

2022-10-25 10_13_28-2022-10-25 10_12_47-DUMMY Screenshot forum project - Scrivener.png_ ‎- Paint 3D

You might have locked the view mode and just forgot about it…

image

1 Like

Actually just found someone else posted the same bookmarks problem a few days ago:

It doesn’t do that on mine anymore. It USED TO. That’s what I’m saying.

Also, it’s not locked.

Then, what happens if you click this ?

image

It doesn’t show the two pages. That’s what I’m saying. :sweat_smile:

image

2 Likes

Not sure why that worked, but it did. Thanks a lot!

1 Like

It worked because only “folders” can display their content as a Scrivening without it being specifically selected in the binder.

It allows, by unchecking the option, and choosing whether a folder is a real folder or a file with other files nested in it, to have two automatic display settings for them.
Or so I would think. Though a bit in conflict with section type by binder structure…

Huh. That’s odd. I’ve never had that option clicked before. In fact, I had it purposefully off because it used to mess up the binder by making everything bold instead of just the folders.

Well, I can’t really say since I’ve always had this option checked, but I tested it before replying, and that is how it behaves at the moment.
Perhaps indeed something changed with the last update. I don’t know.

The way I recall it, nesting files vs folders would remember their respective view settings. Which they seem not to do anymore.
I don’t use that enough to be certain it really used to be like that, though. (Would have to check in the manual.)

1 Like

It actually doesn’t.

Have you checked this (Mac Screenshot, but you should have something similar under Options)?

:slight_smile:

Yep. That is what would have made one’s files nesting other files’ title bold.
(Document groups checkbox – Windows screenshot this time.)

image

This is what I have it set for. However, prior to this last update, if I also had “Treat all documents with subdocuments as folders” is checked it would bold everything.

It did since I have it set to bold folders.

I don’t know what to add…
I just looked in the manual, searching for “use bold font” and couldn’t really find anything susceptible to clarify the situation.
All I can say, is that I’ve been running Scrivener with
image
and
image
as my settings since I moved from V1 to the V3’s beta, without anything but folders having their title bold in the binder, that I ever noticed. (I use Scrivener daily, almost 365/365)
:person_shrugging:

Given how much I split my chapters in smaller bits (for print) while keeping the root document as a file (not a folder), I sure would have noticed. Something else must be at play.
(Especially since if it was actually intended as such, the second option, “Use bold font for: Document Groups”, would have no reason to be.)