HELP with themes!

Window > Themes > Save Theme to File, Combined with File > Info > Manage > Save Personal Settings, will save your current setup.

Changing the Toolbar colors can’t be done using Options, but it can be done Creating a new Theme and editing the content of that Zip-file.

Here are some examples:

HTH

1 Like

I do know how to save the theme, but the problem is that it’s greyed out when I try to click it in the default theme. That’s fine, though, if I can change the toolbar color. I’d been looking all over the forums to find some way to do that as well.
Thank you! This has saved me a whole lot of frustration.

1 Like

I changed to the Ocean theme, loaded my preferences, and successfully saved it as a theme, but when I tried to “Edit the content of that Zip-file,” it wouldn’t work. It isn’t even a zip file. So… how exactly do I do this again?

It’s a Zip. Rename it to. Zip. :wink:
It contains four files.

Alright. I was getting pretty confused there for a second. :wink: So, I’ve got PAL, PREFS, QSS, and an XML doc. Which file am I supposed to change, and how do I open it up to change it? Sorry, having a bit of trouble here.
Thanks a bunch. :slight_smile:

Right. In my upcoming book Mastering Scrivener, the steps list of implementing your own Theme has 30 steps.
Where to begin? Well, here’s where I learned it from. And I’ve learned from the best. :wink: @BadScribbler

Or, if you are a patient, I’ll have a 30 step process on 5 ‘pages’ in one e-book for you in a few week time, I hope…

Hope this helps.

1 Like

Alright. I’ve figured most of it out, thanks to you, and I just need to know how to change the zip file into a .scrtheme file again. Thanks so much for your help.

*Those last two deleted posts were me asking questions right before I figured them out. :expressionless:

1 Like

You are way more ambitious than I am!

You just need to change the file extension from .zip back to .scrtheme. Similar to the start of this process, where you changed the file extensions from .scrtheme to .zip.

Depending on your Windows settings, before you do this, you may need to disable (uncheck) the File Explorer option Hide extensions for known file types. On my system, that option is found in File Explorer, under View > Options > Change Folder & search Options > View.

Best,
Jim

THANK YOU!
This has been a long day of staring at a computer totally frustrated. I can’t decide whether to go make up a few of my dream Scrivener themes or just go flop in a chair and rest my eyes.
Actually, I think I choose the former. I’m a writer, am I not? Starving ourselves of light, sleep, any liquid other than caffeine, etc… this is what we do! :wink:
Anyway. Thank you both for putting up with my constant questions. Thank you a lot.

1 Like

Mind pinging me when the book happens?

1 Like

. scrtheme.

Zet je het resultaat erbij op:
Scrivener 3 Themes for Windows?

Hi, just butting in on this thread since I’ve also been fiddling around with creating my dream theme for Scrivener. But somehow I’m unable to rename the .zip file back to a .scrtheme file without something going wrong. When I try to load my new theme and reopen Scrivener a message pops up: “Theme Manager: Scrivener failed loading a theme. Couldn not find thme files within the theme package.”
This also happens when I save a pre-existing theme as a “new” theme, rename the .scrtheme to .zip, extract the files to make them writeable, make it a zip again and back to .scrtheme without making any adjustments to the files within the .zip.
If someone could point me to my moment of error, that would be really nice since I can’t seem to be able to figure this out for the life of me! :sweat_smile:

I hope you’re on the Windows platform, because these instructions are for .scrtheme files only. macOS users have a different file type.

When you zip, make sure you add a .pal, .qss, .xml and a .prefs file, each with the same file name. No more, no less.

The xml-file is the manifest, keeping the package together. Verify that the names inside the .xml-file are consistent with the filenames themselves, so when your Theme is called DarkForest, the xml-file should be:
<?xml version="1.0" encoding="UTF-8"?> <ScrivenerThemes> <ScrivenerTheme name="DarkForest" style="Dark"> <qtstylesheet>DarkForest.qss</qtstylesheet> <palette>DarkForest.pal</palette> <preferences load="Colors">DarkForest.prefs</preferences> </ScrivenerTheme> </ScrivenerThemes>
When all is correct, you’re doing something weird that I can’t guess and we’ll need more information on what your doing exactly. Maybe one of the files isn’t correct?

HTH

Yes, I’m on Windows. The issue also occurs when I don’t fiddle with the .pal, .qss, .xml and .pref file from the theme. Just for trial and error puroses I’ve downloaded the DarkForest theme and it works without a hitch. Then I deleted the theme from Scrivener’s Imported Themes Folder for a “clean slate” and took the originally downloaded DarkForest.scrtheme file, changed it to .zip, unpacked the .zip into a regular folder, repacked the .zip with the same name and changed it back to DarkForest.scrtheme. I haven’t done anything with the .pal, .qss, .xml and .pref files yet just to make sure my workflow in itself is sound. But when I now try to load this “new” but unedited DarkForest.scrtheme file into Scrivener, the error message pops up. I didn’t edit or change out any of the files, so I’m not sure why it won’t recognise the files inside the .scrtheme file…

Edit: I just ran another test and this time only changed the .scrtheme to .zip and right back to .scr without unpacking the .zip as I’d previously been doing and Scrivener accepts the .scrtheme as usual without the error message. Do I need to work right out of the .zip folder then? Because there I ran into the issue that the .pal, .qss, .xml and .pref files aren’t writeable which is why I unpacked the .zip in the first place.

Everything else being equal, I think the issue is with the way you zip the files.
I do it like this and that works. I get a new Zip-file and change the extension to .scrtheme.
image

Maybe you can tweak the settings in your Zip-application? Perhaps it has some special setting active that shouldn’t be active in this case.

Alright, maybe that’s it. Until now I’ve always just zipped files without any special application, just via the zip option windows provides right off the bat. I’ll try with a separate zip application, maybe that solves the issue. Do you have any recommendations here? I’m really quite new to all… this but I’ll be damned if I’m not too stubborn to still make it work somehow😅

Love your perseverance.
WinZip or the one I use, 7-zip will do fine.

1 Like

IT WORKED!!! :scream: :laughing:
Thank you so much! I’m giddily happy right now and I’m sure I’ll spend all night now fooling around with my custom themes now!

You can add your result at:
Scrivener 3 Themes for Windows
If you want to share your Theme to others…

Have fun!

In the Palette replace the button text color: ButtonText(14,44,72)

The QSS-file is a stylesheet referencing Palette colors.
But it’s possible to replace those with CSS-style RGBA colors. The A is for Alpha-channel or transparency and ranges in QSS from 0 to 255.
So, replace the next styles in the QSS and adapt the primary colors to your preference:

QMenuBar::item {
spacing: 2px;
padding: 3px 4px;
background: transparent;
color: rgba(0,255,0,255); /*Green*/
}

QMenuBar::item:selected {
background-color: rgba(255,0,0,255); /* Red, was palette(midlight); */
border-left: 1px solid palette(midlight);
border-right: 1px solid palette(midlight);
}

QMenuBar::item:pressed {
background-color: rgba(0,255,255,255); /*Cyan, was palette(midlight);*/
border-left: 1px solid palette(dark);
border-right: 1px solid palette(dark);
color: rgba(255,0,255,255); /*Magenta*/
}

Still, the menu text is illegible blue on blue. So, replace:

QMenu::item {
min-width: 120px !important;
/*horrid workaround qt bug where shortcuts overlap menu text*/
border: 1px solid transparent;
padding: 1px 20px 1px 26px !important;
margin: 1px !important;
color: rgba(255,0,255,255); /*Magenta*/

NavyGoldMenuColors

Don’t make it too late :wink:

2 Likes