High DPI - display issues (blurry text / tiny interface)


I am considering getting Scrivener, and currently getting very frustrated with this issue.
I have looked through the forums, and found several topics about this, but nothing fixed the problem for me. If I open Scrivener, the text is blurry/pixellated.

The only way I’ve found to fix this is through the properties > compatibility > DPI settings (solution here: [url]https://forum.literatureandlatte.com/t/blurry-and-not-crisp-is-this-how-it-is-for-others/45976/4]) but when I do that, the interface is tiny, the “post-it” notes are much too small, etc. I cannot possibly consider buying the software at this price with such a big issue… but I’d really like to use it.

Has anyone managed to fix it? Seems like this issue has been around for years and it’s still not solved. I know Windows users are a minority but this should still be important.

Thank you to anyone who can help :slight_smile:

Screencaps of how the software looks to me:

with normal settings:

with DPI settings changed:

I have a similar problem. In a 4K display everything is tiny. Zooming in a editor works fine , but everything example in a binder is way too small. Every attempt to zoom via windows settings/ display settings/ scrivener settings (via icon) leads to blurry text.
Also Finnish spell checker would be nice.

They aren’t a minority, and the lack of a fix really has nothing to do with how important it is. The old version you are testing was created using a programming system that existed long before screens had high resolution. There is no good way to solve all of the problems with it.

I’m not sure if the thread you found was mirroring this information, but these are the best tips we can provide.

Now if you’d like to see what we’ve been working on for the past few years, with modern technology, then have a look at the soon to be released beta version. If you find that works better for you, you may just want to consider that you base to start from, rather than learning the old version. Like I say, it’s almost done, and it would be a free upgrade for you anyway.

The beta still has issues for a Windows Surface tablet and external monitor combo, where Scrivener windows are shared across both.

It’s improved since the Qt High dpi runtime was merged but still has quirks. E.g. whenever an Explorer window is triggered for file save/open etc it shows a high dpi resolution configured Explorer window on the lower dpi screen. So it looks more like Windows 3.1 on a 640x480 CRT… see screenshot. There are also quirks with remembered settings of Scratchpad etc window locations making dpi assumptions when re-rendered, so they changed size/position on re-displaying. It’s annoying and quirky rather than damaging. So I’m still in on the Win v3.0 prod release.

(NB Scriv and Plottr are the only apps that do this on my system - code port issue in the source tool?)

I’m pretty sure that explorer interface is a stock Windows component. I know that when I run Scrivener through Wine anyway, I get a completely different file selection/save dialogue than I do on Windows itself. It is rather quite simple, and I would imagine something the Wine developers have put together.

So if I had to wager a guess, it may be that the Qt interface for calling on this window lacks a resolution declaration, or maybe isn’t handling it correctly. I have no idea though.

Thank you, and I am sorry if I sounded passive-aggressive in my first message because I was frustrated. I understand better now :slight_smile:
I downloaded the beta version and it looks amazing, I’m going through the tutorial have no issues with it. Thanks for your help!

Great! Glad to hear that’s working better for you. As noted above, it’s not perfect still, but certainly better than trying to use the old version on a high-res screen.

Just a tip for anyone who still has blurry scaled text in any Windows app. One solution that might work is to go into your video driver’s control panel and force Anti Aliasing (AA) to be disabled for that specific app.

For example, in the Nvidia Control Panel, go to Manage 3D Settings, Program Settings tab, select the app, then go down to “Antialiasing - Mode” and turn it to Off. You’ll have to restart the app to see if it worked. I presume AMD graphics drivers have a similar setting, but I’m not sure about that, or any other GPU drivers.