How do you Keep Formatting Different while Compiling?

Hey,

New Scrivener user here for MacOS. Have a few manuscripts from word/pages that I’ve imported into Scrivener and have different formatting/fonts for texts/letters/etc… I know Scrivener has Styles, but whenever I try to compile into Manuscript Times, for example, it automatically forces the formatting to take on Times when I really want the texts messages or letters to have the different format and font. I’ve tried to have these sections just formatted differently without creating a Style, and then tried again by formatting them with a Style, but both have the same result.

I also want to have an extra line of space between the regular text and the “special” text without compile automatically deleting it or putting a hashtag thinking it’s a new scene. Cause it looks jarring going from the regular scene to two characters texting with no spaces to separate it. Might be tricks I just don’t know being new to the software.

Thank you :slight_smile:

You have to set up the fonts you want in the compiler. See if this makes any sense: https://forum.literatureandlatte.com/t/change-compile-font/10087/1

I would note that this link points to an extremely old version of Scrivener, and the method described there is out of date.

It sounds to me as though you want to add a new capability to your compile format (the “Manuscript Times” format to be precise). But before you go too far down that road, I’d try something simpler:

  1. Open up Project ▸ Project Settings…
  2. In the Section Types pane, add a new entry to the list, maybe calling it “Letters”. And maybe you want “Text Messages” in there as well. That should be all you need to do here, just save the settings.
  3. To use these, go to one of the sections you created in the binder for printing a letter, and right-click on it. You’ll see a “Section Type” submenu where you can pick the right kind. It’s worth noting you can do this from the Inspector as well (I like having that information readily available, too).
  4. To test the theory, back in the compiler, click the Assign Section Layouts… button below the preview column.
  5. You’ll find your new types in the left list (so long as you used one, if you haven’t gone that far yet, click the button at the bottom to show all types).
  6. Select all of the special types in the sidebar, and then click on “As-Is” at the very bottom.

That should be it. These sections will print exactly how you typed them up in the editor, no more and no less. And consider that if you want to go even further down that rode, the “Default” compile format may be a better fit for you, than something that is as opinionated as Manuscript-Times.

If you do like Times but want to go a little further than just printing what you type, you can make your own Layouts and add them to the list of choices here. That’s probably something worth looking further into on your own. I’d start with the tutorial (found in the help menu).

But know that in general you can harmonise the formatting for all letters / text messages, just like it does to make all scene text Times. You can also change the separators around them to add extra space above and below (and get rid of the scene break hash between them). There is a lot of customisation available here—basically everything you see the Times format currently doing to your text is a matter of configuration, not programmed features. So it can be undone, modified and built on to.

My bad. :mrgreen: