How to add pdfs without converting to text?

Hello , It’s been a year since I used Scrivener and I can’t figure out how to import pdfs without getting this message:

“Please note that text files that are imported will be converted to RTF for editing.”

It seems like I should just be able to drag and drop?

I’m sure I had lots of pdfs last year, appreciate any pointers!

Drag and Drop PDF’s into the Research folder and they will drop in unchanged. The Draft Folder is where you compose/write and Scrivener works in “RTF for editing” which is the purpose of the software.

1 Like

Thanks, I tried it again:

What am I doing wrong?

Well, I am stumped. You are using Windows. Others can comment.

1 Like

Appreciate your efforts :slight_smile:

Just hit OK.
It should be fine.

That is just a general warning to let you know how the file would be handled should you drop it in the draft folder. (You can even tell it not to show up in the future.)
I just tested with two PDFs (dropped in my Research folder) without any loss.


So I tried that and the pdf is barely readable anymore, severely degraded, like copied 15 times, however, still searchable. Very strange.

Why would I NOT want to see this warning in the future?

Don’t have the time to inspect and compare each file to see whether it was imported correctly.

Because once you know you know ?

There are PDF’s anti aliasing etc in the options.

Options / Editing / Options

Not everybody is as gifted as you are :slight_smile:

I have stress-induced brain damage (working memory), work 10 - 14 hrs every day, am 64 years old and had a very busy life.

But it’s not only my memory that’s impacted. My logic must be impaired too.

I actually thought the warning DOES apply to other files and in other locations.

I don’t understand why I should assume that all files are treated the same, nor do I know that there won’t be updates changing the behavior.

I just installed Scrivener again, so I don’t have a clue.

“Because once you know you know ?”

I know nothing. Humor me and explain what I should know. Thanks!

Darn, I was going to edit my post because I saw you edited yours, accidentally deleted it and the “undelete” gave me an error.

Oh, undelete finally worked. So thanks for those pointers on the pdf display!

I mean, once you know that a file that is dropped in the draft folder gets converted to RTF unlike a file that remains as is if rather dropped in the research folder, you can get rid of the warning saying just that, if you want.
I wasn’t saying you should, I was saying that you could.

Just to confirm, no worries, it won’t.

Ok, that’s good, so presumably it won’t be hard to remove the notice since it’s never needed.

So what are my options supposed to be set to?

I tried this:


If anything, it’s worse:


Deleted the old files and even restarted my notebook.

And there sure are a lot of options!

Hard to tell, but I get very good results set up like in my screenshot…

I can’t actually mess it up. So I don’t know.

You should test other PDFs to see.

The one you actually have looks more like a scan.
The numbers on the left don’t even line up right.
You sure it is searchable?
Are the links clickable? Or just blue letters?

I’m so confused now, had no idea what hinting is and did some reading earlier. I thought less hinting was higher quality? Must have misread.

My option settings were the same as yours before I made any changes.

So I’ve gone back to your settings, tried different things, NADA. These settings have no effect on my pdf displays at all.

Ok, I was able to reproduce the issue and make my PDF look just as bad as yours.
For some weird reason, even tho Scrivener says that you have to restart the software for changes to take effect (for display font hinting - which I’d expect to be unrelated tho), it would appear that they only do after a complete reboot of the computer… (Don’t ask me why, that’s way above my knowledge of computers’ intricacies .) @AmberV @kewms

Use these settings :
Then reboot your computer.

Better ?

[EDIT] And yet, I can’t successfully mess it up again. Clearly, something else is going on. But when my test PDF got messed up, I was only able to get it back to look the way it should by rebooting my computer after tweaking the PDF display options. Hopefully that’ll fix it for you too.

And by the way, there are a few other display options here:

1 Like

Had the exact settings in your screenshots, restarted, but no joy.

Very strange. I sure appreciate your taking the time to recreate the issue, thanks!

Something’s just not right.

This morning when I loaded my test project, the two PDFs were blurry again.
I rebooted my computer and that fixed it.
Then I figured it might have something to do with the computer being put to sleep.
So I put my computer to sleep : blurry PDFs after logging back in.
(I did it a bunch of time with the same result each time.)

I went to windows’ display settings, and noticed the scaling was set to 125% (although what I was seeing was at 100%) so I set it to 100% (without any visual change).

Then I noticed this was turned on :
and so I turned it off.

I’ve just put my computer to sleep 4 times without the PDF display issue reappearing, where just before that every time I did put my computer to sleep the issue would manifest itself (had to reboot between each test run to fix the issue).

I don’t know why my computer decided to say my scaling was at 125% when clearly it was not.
Could be related, although I more strongly suspect this: image to be the source of the issue.
(It says it only affects the main display but, hey, go figure why, I have trust issues as regard to Microsoft…)

Else, it is a random thing (?), I will check on those test PDFs now and then during the next few days.

@christine1234 How are your Windows’ display settings ?

Ok, so here are my settings:


And did a little reading:

Edition Windows 10 Pro
Version 21H2
Installed on ‎5/‎22/‎2022
OS build 19044.1826
Experience Windows Feature Experience Pack 120.2212.4170.0

The monitor settings:

I decided to move Scrivener to the notebook display and it looked FINE! It’s been the other way around, when I first got this machine many of my utility apps displayed TINY on the native screen, but that’s been fixed. Never had a problem with the external monitor.

So I turned the Windows fix OFF, restarted (NICE that this forum saved this post with the screenshots).

And nothing changed. It looks good on the native display, as I move Scrivener between displays the pdf resolution sucks on the external display only.

Very weird.

That at least confirms that the issue originates from outside Scrivener.

I think you shouldn’t have your display set to magnify at 250%, but rather have it at 100%, and set each of your screen’s resolution properly.
(Note that I am not an expert. It is what I would do or try, I can’t tell how that’d affect your system and other softwares.)