How to Install and Activate Scrivener v using Wine

You may not have the correct version of the .NET framework installed via winetricks. The Paddle registration code requires a fairly recent version of .NET (4.6 or greater) and in the newer .NET frameworks, they automatically force software to use TLS 1.2.

See this thread on the Wine HQ forums for more info:
TLS 1.2 for activate license of software Scrivener - WineHQ Forums

I have .NET 4.8 installed, but it still gives me the error.

I installed Manjaro in a dual boot setup (mostly because I want to try using it more), and I followed the steps above. Got .NET 4.8 installed, Scrivener installed and runs fine, but it still gives the TLS 1.2 error. Though, I noticed that it takes more time after pressing “Activate License” for the message to pop up compared to the virtual machine. Not sure if that’s any sort of indication.

Dumb question, but are you sure you have the right architecture (32-bit or 64-bit) that matches the architecture of Scrivener you have installed?

Following the guide, yes, I should have a 32-bit architecture with the 32-bit version of Scrivener installed. I also tried using the 64-bit version of Scrivener in the default wine prefix with .NET 4.8 installed, but the TLS 1.2 error pops up still. Trying a different version of .NET (4.6.2) doesn’t work either.

What version of WINE are you using? There are some that are known not to work due to regression.

1 Like

I’m using wine 6.16.

Thank you for the guide! Only other thing I need to figure out is Dropbox. Hurdle number 1 is clear, now for hurdle number 2.

I’m so glad that you’ve got Scrivener working. I’m afraid that I don’t know anything about Dropbox. I hope you find help elsewhere. But congratulations on Scrivener on Linux, good luck, and happy writing!

An update on my situation: I finally got it working! It turns out to be a weird problem with my internet connection. Using a VPN fixed it and finally got my Scrivener activated in Manjaro.

Thank you again for this guide!

1 Like

Glad everything finally worked out. Happy Writing!

Hello everyone,

I’ve scoured these forums and elsewhere and I still can’t get Scrivener to activate. I’ve even purchased a new windows license because I couldn’t get the upgrade coupon using Manjaro Linux.

I’ve been through the above instructions and tried to install on both 32 and 64 architectures and I still can’t get the activation working. I’ve installed dotnet 46 and also forced 48 and nothing is working. I purged wine from my system and reinstalled everything but now the shortcuts don’t appear in my menu. I’ve had some success installing and activating ProWritingAid and I’ve created a commandline shortcut in the menu to see that.

Can someone please explain what it is I’m doing wrong here? I don’t want to have to cancel my new license and Scrivener 3 seems much better than the Beta which runs fine.

Thre is a problem with deadkeys, described here:

I also noticed problems with dead keys. If you don’t type accents, you may not use them much, but in French, circumflex accent is quite common and relies on a dead key modifier. The idea is that you first type ^, then e and you get **ê**. In this Wine-installed Scrivener, though, you don’t always get what you expect.

Actually, the first time you use it (let’s say you go for ^+o), you do get **ô**. The next time you try a combo with a dead key, though (say, ^+a or even "+e), you keep getting **ô**, just as if Scrivener kept stuck on the first combo it registered

Someone know a solution for it?

Do they work in other Windows applications running in the same WINE prefix? If so, but not in Scrivener, then there’s likely a missing dependency for the various Qt library versions that Scrivener depends on. If not, then there’s something amiss with that WINE prefix.

About deadjkeys, I think the problem is some Qt library, but is something out of league. I tried a few wine installs, but all of them have the deadkey issue on Scrivener, and only on Scrivener. Notepad, notepad++, all works with deadkeys.

Another thing to try is to look at which specific version of WINE you are running. Various threads here in the forum have talked about known issues with specific versions of WINE — you may be hitting another bug.

Hi All,

I’ve spent months on and off trying to get Scrivener working in my Ubuntu 20.04.3. I’ve followed the instructions here to the letter and initially it looked promising but when I got to step 6 I couldn’t find any wine glass icon and nothing to do with Scrivener. It’s like it never installed onto my system, yet all the wine (V6.0.2), dotnet and scrivener installation processes seemed to run perfectly.

As I said before finding this post I’ve been trying for months to install Scrivener and it always seems to get to the same point where it looks like everything has worked but when I go to launch Scrivener there seems to be no trace of it.

Not sure what’s going on but it probably doesn’t help that I’m not an expert Linux user.

Any advice for what I can do to see if Scrivener has installed at all or just disappeared into the aether? Many thanks.


I’ve been using Linux since the Mandrake/Mandriva days, and I played around with Scivener and Wine, then Scrivener and Crossover, and there were always problems. For me, the solution is VirtualBox; it works wonderfully, and for those that refuse to send MS a dollar, windows works fine unregistered with only a minimal amount of nags.

1 Like

Thank you so much, this worked for me on OpenSuse Tumbleweed (snapshot 20220215).
CookDaddy you are a star!

Bobblehob, check to see if Scrivener is in ~/.local/share/applications/wine/Programs/
If is there then you just need to create a desktop entry as per:

If it not there then it has not installed and I guess you will have to try to discover where it went wrong.
Good luck

Which menu are you talking about here: Go to Menu>Wine and click the wine glass icon for “Scrivener.” ?
I don’t seem to be able to open Wine itself as an app, only Winetricks, which doesn’t have a menu.

Also, do I need to install a special 32 bit version of Wine? I just used sudo apt install winehq-staging --install-recommends -y which gave me 7.7

I did steps 1-5 but just double-clicking on the .exe file doesn’t run it.

I’m using Pop!OS 22.04.