How to Install and Activate Scrivener v using Wine

Hi @zizajaun
I would certainly suggest reinstalling wine using stable in place of staging. That should give you wine 7.0 which is more likely to work (particularly with dotnet). My installation used Wine 7.0 not 7.7 and worked without problems.

I tried but it says

The following packages have unmet dependencies.
 winehq-stable : Depends: wine-stable (=
E: Unable to correct problems, you have held broken packages.

I think this could be because before I accidentally installed the repository for Focal Fossa instead of Jammy Jellyfish. But I’ve checked in etc/apt and only Jammy files are there now. When I run apt policy it lists the repositories, including some Focal ones, but I’m not sure how to remove them. This page says to do sudo add-apt-repository --remove ppa:<PPA_NAME> but I’m not sure what part of the apt info is the name.

500 focal/main all Packages release,a=focal,n=focal,l=winehq,c=main,b=all origin
500 focal/main i386 Packages release,a=focal,n=focal,l=winehq,c=main,b=i386 origin
500 focal/main amd64 Packages release,a=focal,n=focal,l=winehq,c=main,b=amd64 origin

I have tried the full URL, just wine-builds/ubuntu, just focal/main and various others but no joy.

Also, not that I installed the staging version because this page said the stable one isn’t compatible with 22.04 Jammy Jellyfish.

I am afraid that I can’t help very much here except with some general advice. The problem is probably that you upgraded to Jammy too soon (it only came out a week ago). I am still using Fossa, and will do so until the direct upgrade is possible in August. From what I have read, in the version that will be released in August (22.04.1), many of the problems of dependencies and repositories have been resolved.

My guess is that in August (maybe before) the stable version of Wine will become compatible with Jammy. If you can wait, then that is one solution. The other, would be to reinstall your whole system with Focal and wait till August to upgrade properly. Depending on what else you are doing, that might be too drastic. Please note that I am not an expert in Linux (or even Ubuntu).

It might be that someone in the forum who knows more could suggest a better solution, but I am afraid that I cannot.

Thank you, CookDaddy, for your straightforward guide. Installed and activated x64 version successfully on Fedora 35. Even scrivx files are opened directly in Scrivener upon double click right from where they are stored, which I didn’t expect, tbh.

One question, though. I’m not familiar with Wine. I realise that Windows applications under Linux are a foreign concept, but is it supposed to look this ugly? :slight_smile: Is there maybe a way to make at least font in the editor look smooth?

Hello, @Jaaaarne !
I’ve just posted some tips in the other topic regarding the installation of the version 3.1.1.
The font is looking ugly in the editor because the default font in Scrivener for Windows is the “Sitka”, a font that comes with windows and is probably missing in your OS and Wine. This can be changed for a native font of your OS and it’ll look smooth (change in the project preferences, so all new documents will have the same look).
You can also change all the fonts on the Scrivener Options to the same fonts of the operational system and it will look like a native Linux software, totally and perfectly integrated with your desktop. Smooth and flawless.


Thank you for your recs, but changing fonts didn’t help. However, turning subpixel antialiasing on did the trick, at least when running Scrivener under Wine (I don’t see any difference on native applications).

Yes, you’re right. I first installed it in a Manjaro Linux, that I believe already installs wine with subpixel antialiasing on and everything was perfect. My texts were looking strange and a font change did the job.
Later I tested it on another machine with Ubuntu 22.04 and indeed the fonts look ugly. How do you turn on this feature?

I’m using GNOME, so it’s just a checkbox in GNOME Tweaks under “Fonts”.

@CookDaddy Thank you. I have a 32 bit version of Scrivener up and running in Mint. Couldn’t have done it without your walk through so thanks again.
It looks like an older version of Scrivener but I’ve opened the files I’ve just written on my Windows 64 bit version and so far all seems okay. I saved them in Dropbox so they can be accessed by both devices. No issues noted. :slightly_smiling_face:

Great thread. Thanks.

Anyone having trouble getting the new Scrivener Beta to work? Seems a whole different kettle of fish.

I’m going to open new thread for that discussion. Are we back to square one? Running the 3.1.5 Beta with Wine or Bottles