How to Install and Activate Scrivener v using Wine

I finally discovered the method to install and activate Scrivener 3 in Linux using Wine.

  1. If you haven’t, buy Scrivener 3 32-bit or download the 32-bit version for Windows trial from the Literature and Latte website. I download to ~/Downloads, your system may be different. You’ll get an email with a License key.
  2. Download the following packages with your package manager:
    1. wine-staging or wine
    2. winetricks
  3. Open a terminal. Create a 32-bit prefix with this command:
    1. WINEPREFIX=~/.wine32 WINEARCH=win32 wineboot.
  4. Set up Windows components with these commands in this order:
    1. WINEPREFIX=~/.wine32 winetricks speechsdk.
      1- Complete “InstallShield Wizard for Microsoft Speech SDK 5.1.”
    2. WINEPREFIX=~/.wine32 winetricks --force dotnet48. (wait a bit)
      1- Install “.NET Framework 4 Setup.” (wait a long time, be patient)
      2- Click “Finish.” (wait a bit)
      3- Click “Continue.” (wait some more)
      4- Install “.NET Framework 4.8 Setup.” (wait again)
      5- Click “Finish.”
      6- Click “Restart Now” and the processing ends. (Don’t actually restart your system.)
    3. WINEPREFIX=~/.wine32 winetricks win7.
  5. Locate Scrivener-installer-x86.exe and install “Scrivener v3.0.1.0.”
    1. WINEPREFIX=~/.wine32 wine ~/Downloads/Scrivener-installer-x86.exe. (Or wherever you downloaded the .exe.)
    2. When the wizard ends, uncheck “Do you want to create a Desktop shortcut?”
    3. Click “Finish.” The installer will set up a menu shortcut labeled “Scrivener” in a Wine sub-menu. The sub-menu will contain several menu shortcuts for Microsoft Speech SDK 5.1 that you can disregard. (But don’t delete.)
  6. Go to Menu>Wine and click the wine glass icon for “Scrivener.”
    1. Click “Next” on two dialog windows that come up.
    2. Click “Start Using Scrivener.”
  7. Another dialog window, “Scrivener Trial” will appear over another dialog, “Project Templates.”
    1. Click “Enter License…"
    2. Enter the email address you used when you bought Scrivener 3
    3. Copy the License Key in the email sent to you, paste in “License Code:.”
    4. Click “Activate License.”
    5. Wait a bit and a dialog will appear, “Activation was successful.”
  8. Happy writing!

Download packages:

  1. wine-staging 6.12.1-1
  2. winetricks (current version)

Many thanks @CookDaddy that worked! I wonder if my previous fails were due to using Scrivener 64-bit. My Scriv 3 is now activated in Manjaro linux and I will give it a test run asap.

Yeah, one of the components, MS Speech SDK, requires a 32-bit prefix. Glad it worked out for you! And I like your pic, so debonair.

Everything working well so far. The only thing I needed to do was to add some MS ttf fonts.
WINEPREFIX=~/.wine32 winetricks corefonts

Thanks again. :clap: :+1:

1 Like

Good catch! Thank you!

I did something stupid and crashed my desktop, Cinnamon. I was able to reinstall Manjaro/Cinnamon without any trouble, but my shortcut wouldn’t load Scriverner. After much consternation, I realized that wine-staging and winetricks needed to installed. Whew! Success!

1 Like

Thanks for this! Works on Debian 11. I took my time trying to get stuff working, but my mistake was trying to use the 64-bit version of Scrivener. Turns out we still need to do things the 32-bit way in 2021…

Glad everything worked out for you! As my late father used to say, “Sometimes the old ways are the best ways.” Good luck in all your Linux endeavors!

Hello friends.
Does anyone know if this installation method would work with the trial version?

An update on Debian 11: I just successfully set up and installed Scrivener on a 64-bit prefix. The checklist is pretty much as described above, with only two exceptions:

  • Do not install speechsdk. It is not necessary for installation, but if you do want text-to-speech, 64-bit probably isn’t for you at this time. Instead, follow the advice given by @garpu in this thread.
  • Installed up to dotnet462. I did not test further, and that is the minimum Scrivener requires to run.

For further info, I did still have the i386 apt repositories enabled, and wine32 installed. I do not think it would make a difference to have it off, but if you run into dotnet installation issues without it, that may be something to look into doing.

There is are no separate versions, if you choose to purchase it you’ll unlock the copy you already have installed.

1 Like

The speechsdk thing is a WINE bug. It was fixed, and then it wasn’t, and I’m not sure if it were fixed again. I had it linked to the Scrivener wineappdb page, but it disappeared, which happens when something is allegedly fixed. (Rather, I haven’t tried Scrivener in a wineprefix without it.)

1 Like

Good to know. I’ll try again with the 64-bit prefix, following your directions. Thanks!

Thank you for sharing your knowledge.
I just performed the detailed procedure here and am already using Scrivener (1274151).
My distribution is ‘Linux Mint 20.2 Uma’
Kernel: Linux 5.4.0-68-generic
Architecture: x86-64

You’re Welcome, Felipe! Glad it worked out for you. If I may ask, what project are you working on?

I thank my friend.
I’m creating few drafts, maybe a book is coming. Still in the process of literary study.

Great! Go for it. Good Luck!

My friend Daddy,
I’m noticing some problems with accented words. My mother tongue (Brazilian Portuguese) has many words with accents.
I have already put the Portuguese Brazil dictionary, and it helps me by pointing out the ‘wrong’ words.
Do I have to do some configuration in WINE to fix this? Can you tell?

– EDIT –

So I posted the question here on the forum. I did a search and found a forum of some Brazilians with WORD accent difficulties using WINE.

In summary what I did was:
Access the ‘Language Support’ menu
Keyboard input method system option: name was marked, I changed it and put IBus

I restarted the operating system and that’s it. Scrivener accepted accents normally.

I’m glad you fixed your problem. I’m afraid I wouldn’t have been much help, I’m in the US. Of course English doesn’t use accents.

Thank you for the guide! I’m able to install Scrivener on Manjaro, but I’m having trouble with the activation. It fails to activate and it gives the error “Please enable TLS 1.2 on this machine.”
I’m also doing this in a virtual machine, so I’m not sure if that’s the cause of this issue.