Import of Mac files makes folders.[NOTED]

So, I zipped my Scrivener files on a virtual Mac, put the zip file into a dropbox folder, closed the virtual mac and unzipped the archive using WinRar into a folder. I’m running Win 7 on an Asus x71 laptop.

Since this happens outside of Scrivener, I’m not sure I should report it here, but now I have as it might be a filetype problem.

The .scriv files all became folders, not files.

This is what Scrivener projects are going to look like on Windows, there is just no way around that since Windows does not have an equivalent feature like the Mac’s bundle package format. To open them you’ll need to navigate into the folder and double-click on the correspondingly named .scrivx file. If these projects are from 1.54, they won’t have one of those, and will need to be updated using 2.0. To my knowledge the Windows version won’t be able to handle Scriv 1 projects since its release date will be months after 2.0 has been out officially. I could be wrong about that one though.

So in other words, if you have a 1.x version of Scrivener for Mac, there is no way to port the project to ScrivWin without first buying 2.x of Scrivener for Mac?

Or maybe trialing it :wink:

Only problem with trialing it is that I anticipate it would essentially kill my 1.x license.

The other only problem is that the 2.0 preview doesn’t appear to be out yet :frowning: But that’s just my impatience.

kdbertel, at the moment that is the case. Part of the problem is that the 1.x format uses a bunch of binary proprietary control files that the Mac has built-in libraries for accessing, but Windows does not. So it isn’t a simple matter of just saying “load scrivproj instead of scrivx”. As StarTigress points out, for now there is a free trial of 2.0 which will run until December.

The NaNoWriMo 2010 preview edition is indeed out—and it won’t kill your 1.x licence. I’ve been running both versions for ages now. They even use separate preference files.

Ah, that makes sense.

I understand how the change in file formats would cause an issue–I’m just vaguely surprised there’s no easy way to export from 1.x to 2.x. But on the other hand, time and effort and diminishing returns.

I totally missed the 2.x preview version. Thanks a bunch; that should help get me going.

Exactly, diminishing returns. It wouldn’t surprise me if, by the time Windows is on sale next year, hardly anyone is using 1.x any longer. Of course it is impossible to say that for certain, but it isn’t exactly like Windows XP or something. If it is an issue, perhaps something could be explored from the Mac side—a little downloadable utility or something.

Honestly, I don’t think it’s particularly unreasonable, once Mac 2.x is out and Win 1.x is out, to basically say “You cannot use Mac 1.x with anything but Mac 1.x. If you want cross-platform compatibility, you have to get Mac 2.x”.

Certainly, there will be some gnashing of teeth, but as you said, most people will upgrade to 2.x pretty quickly.

I do, however, also think that being clear about that is good. Thus why my question was more clarification than complaint :smiley:

That said, I’m having problems still getting my Scriv files from my Mac to Windows. I am using the NaNoWriMo 2.x preview on OS X 10.6. I open up the 1.x .scriv, have it convert, fiddle a bit, then close Scrivener. I copy the new .scriv to Dropbox, wait several minutes to make absolute sure everything’s copied over, and then attempt to open the .scrivx on Windows 7 (I have the Tutorial open so I have an instance of the app running). Then nothing happens: no error message, no hourglass, no nothing. This happens regardless of whether I double-click on the file, or run ScrivWin and select open project (and select the .scrivx file). When I close the Tutorial after this, and get the “create a new file” box, and close that, I have no Scrivener processes running, according to Task Manager. So it’s almost like it’s not actually opening the file? And not giving me an error?

If I should move this to a different thread (or if someone else has this issue), please let me know. I will keep fiddling with it to see what I can do. Once I find my flash drive, I’ll do that next, in case it’s Dropbox that’s causing an issue.

Further data point:

Copying the files(/folders) over via Flash Drive has no impact.

If I run ScrivWin, and all I have is the ‘Create New Scrivener Project’ dialog open, and I select ‘Open Existing Project’, and then select one of the Mac 2.x files, Scrivener simply closes, and kills the process. No error message or anything to indicate something went wrong, aside from nothing loading at all.

However, it works for a project I created with ScrivWin.

Am I potentially doing the conversion/export wrong on the Mac side?

This is an area that hasn’t been extensively tested yet, so at this stage all data is good data. What I would try first is to keep it simple and see if you can replicate the problem with a blank project created on the Mac. Just leave it untitled and put a single word into the file. See if that opens for you in Windows.

If it does, then you can analyse the project that isn’t opening by dragging the entire binder from the old project to the empty one. Try again. Failure? Then try isolating individual files until it breaks again. Success? Could be something strange with the project format then—we’d have to approach the problem from another angle.

I’ll see what I can do about working on that, then. It’ll (obviously) take me a little bit of time to see what I can narrow down.

Okay, I’ve done some various testing and such.

Scrivener Mac 1.54 -> 2.0 -> Windows: Works
Scrivener Mac 2.0 -> Windows: Works

Curious. So I tried what you suggested, copying.

I actually have two older Scriv files. One was a fairly byzantine thing with a bunch of embedded HTML files and pdf documents and such (an old decade-long writing project I compiled together). The other was a fairly new thing, but with an embedded pdf or two. Neither had worked when I converted using Mac 2.0, and brought over to Windows.

However, I created a new Scriv file in 2.0, copied everything from old project to new project, bring over to Windows…and it works. For both of them.

So: weird. At least there’s a pretty good workaround (just copy everything from the old and put in a new). Not the zestiest, but hey, livable. I vaguely suspect there aren’t many people who are going to be in this boat, but providing info on the workaround would be good for them.

Just a quick clarifying question: is there anything I might have missed on the copy-paste? I’ve noticed the Keywords and Labels didn’t carry over. Anything else?

(Sidenote: if you want me to send you the scriv files so you can see what might be going on, let me know a good way to get them to you. I’d rather not post them publicly given that various things I’ve written are in them, and while I trust your team to only analyze it for fixing bugs, I don’t necessarily trust everyone who anonymously visits these fora)

I downloaded the Windows beta onto my net book and the Nano version of Scrivener for Mac on my iMac and so far everything is working well with Dropbox. I’m very happy as I’m about to go off to a writing retreat, so I can take my netbook and use Scrivener!

I encountered the same problem. Windows XP wouldn’t open an upgraded Scrivener 2 project: no error message, just nothing happens.
But when I created on the Mac a new blank Scrivener 2 project and dragged everything from the original project’s binder to the new project’s binder, then brought over the new project to Windows, the Windows version of Scrivener did manage to open it.

The problem with this method: when I dragged my files/documents in Scrivener 2 from one project’s binder to another, I lost all my internal Scrivener links in the newly created project. They were converted into simple text.

Just to clarify, I meant this method to be used mainly as a method for isolating where the failure happened, not so much as a work-around. I wanted to make sure there was nothing in the files that was causing the glitch. Well it does work for a work-around, but a better work-around would be use the File/Import/Scrivener Project command into a new project as that will also copy your meta-data. It would still bomb your links though.

What this indicates, since we now have two individual cases, is that there is something in your project format itself that isn’t getting parsed correctly by the Windows version. It’s probably either a missing feature, or a bug in an esoteric one.

A second-stage test would be to use the import method and see if that works. If it fails, then it might be something in the meta-data which wasn’t copying over with simple Binder drags. Could be as simple as exotic Unicode characters in your keywords.

At that point, either way, I would suggest sending the .scriv file to windows AT literatureandlatte DOT com, along with this conversation so Lee knows what is going on with them and what isn’t suspect (files/meta-data).

But no, we don’t want to have cases where projects don’t load, and the user has to go through contortions that should only be done in the case of corrupted projects and recovery—just to use dual-platforms.

I created another blank project and this time used the File/Import/Scrivener Project command.
It worked as well – the resulting project could be opened in Windows.

In another thread, someone found that Windows and Mac start from different index values when writing out keywords (Windows starts at 1, Mac at 0, I believe), and this may be related.

When I get home tonight, I’ll get some files sent the way of that e-mail address.

Thanks to both of you for your further testing on this.

I have sent (links to) files to that e-mail address, so that should help some.

I forgot to mention that I hope y’all don’t keep these files or use any of the scrivenings in them or anything against us in the future. :slight_smile: Since a bunch of people have sent you files, I assume you’re just using them to track down problems, then deleting the problem files once the bug is fixed. Just wanted to make sure it’s on the table.