Inside and Outside margins swapped

when I set different margins for a mirrored setting the Inside and Outside measurements are swapped. I am attaching two screenshots: one of the margin settings, the other of Preview of the Recto page—when I Compile and Export to Word this error in the margins is there too. Thanks


That’s by design, not an error: it puts the larger margin on the inside of each printed page to create a gutter. The gutter shifts text away from the spine of any bound book so that the words don’t disappear into the binding and become unreadable.

Slàinte mhòr.

hmmm… I’m not convinced. There are clearly book designs where there is a much greater outside margin than inside margin. http://theworldsgreatestbook.com/book-design-part-1/ shows this. I’m surprised that Scrivener does this automatically. I’ve wasted a lot of time trying to find out where this ‘error’ was occurring.

I can confirm the initially reported phenomenon.*

In a Word doc for which you set uneven mirror margins, Word formats the first page as a recto page.

When Scriv’s compile format has uneven mirror margins set, it generates a Word doc with margins set so that in the resulting document the first page is set as a verso page. (Which does require that the “inside margin” setting in Sciv is made into the outside margin setting in Word.)

So that looks bad. Starting on a verso page messes things up, as two sided printing shows: the second page would in effect be printed on what will become the page before the first!

So far this looks like a genuine bug to me.

gr

Hmm. Let me put it this way:

If I was reading a book with only a ½" gutter, I would be annoyed, as I would have treat it very carefully unless it was a very slim volume, because I would expect the bend on the page to increase the chance of the spine breaking; a book with a 1" gutter would be more robust.

On the other hand I do like traditional typography with a wider front margin, especially good if you’re into annotating your books.

You need to consider what type of book you’re publishing in what format. If I was thinking of a work of fiction to be published in paperback, I’d use the wide gutter with the narrow front margin, as that would minimise the strain on the spine. If I was thinking of a large format, particularly a coffee-table book, I’d go the other way, because the much larger page-size would allow me to have a good gutter, but still a wide front margin.

I’ve just checked a 1994 Penguin Classics version of The Woman in White by Wilkie Collins. It’s about 1¼" thick and printed with equal gutter and front margin of ½". It is very difficult to read because of the very tight gutter, and I wouldn’t dare to as it belongs to my daughter and I’m sure I’d have broken the back before I’d finished it.

Mark

For printing and standard binding, the minimum inside margin is always bigger than the minimum outside margin. The outside margin can be bigger if the designer wants, but the minimum can’t be if the text is to be readable. The physics of the bound page.

kdp.amazon.com/en_US/help/topic … 950#margin

In the linked page referenced, the writer actually says that they add extra space to widen the gutter.

And in the compiler, you can choose if sections start on recto pages or not. The title page customarily starts on a recto page.

libguides.lib.msu.edu/c.php?g=97090&p=908734

Users can customise the compiled output. You can increase the outside margin if you want to. You can add blank pages to Scrivener or Word to modify designs.

Slàinte mhòr.

That depends on how the compiled document has been configured. Scrivener can compile the first page as recto or verso.

Scrivener compiling to DOCX with first page recto.jpg

Slàinte mhòr.

I’m a bit confused. Section layouts for .docx compile do not include the ability to specify recto or verso. Only .pdf and print section layouts permit this. How then is this being done?

Apologies. Actually, I didn’t even realise I had switched formats. Silverdragon is right, DOCX compile doesn’t include recto / verso options, but the compiled DOCX defaults to recto for the first page, at least when it is opened in Pages on my MBP (I no longer have Word).

I assume that is by design, given that title pages usually start on a recto page, and any English-language text starts on a de facto recto page as the cover of an unopened book is essentially a recto page, with the inside cover being the first verso page.

And you can, of course, just use <$BLANK_PAGE> to insert a blank page if you need to force the layout in some way.

Come what may, if the text has been exported to Word (or any other word processor or layout program) the margins can then be set in that program. And the gutter needs to accommodate the number of pages to be bound, if the publisher wants the book to be readable.

Slàinte mhòr.

I’m afraid the OP is not really being all that well served by the discussion so far.

First, the issue has nothing whatever to do with good practices in setting values for inside and outside margins. Some folks got distracted by the actual values in the example screenshot – which have nothing to do with the problem being demonstrated.

Second, the screenshots the OP provided show very clearly how the problem can be seen right inside scrivener. For compile setting targetting docx, use Page Settings to set uneven mirrored margins. Then use the preview button to see the result. By any account, on a recto page the inside margin is on the left and the outside margin is on the right. BUT that is not what Scrivener shows, it assigns those margins oppositely. And the same prblem (duly reversed) can be seen on the verso preview. (Ignoring the Frntmatter preview here.)

MOREOVER, this is not just a previewing/presentational problem. If you actually compile to Word from there, you will see the reversal is in fact made in the resulting document. You can see it explicitly by opening Document Settings and looking at the insude and outside margin values. They will be the opposite from what you set in your compile settings.

Real bug easily reproduced following screenshot. Yes, it is easy to see how one could work around it, but it is certainly a real bug. This thread probably belongs in Bug Hunt.

gr

I agree. The margin fields are mislabeled. In order to get what I want in my print output, I have always had to put the outside inside.

Apologies, if I misunderstood and went off on a tangent.

Slàinte mhòr.

Hi, gr.

I see. The manual says left margin, inner; right margin, outer. But the labels in compile have left margin, outside; right margin, inside. Easily resolved, but a glitch all the same.

The dialogue window for setting the margins is spatially accurate (top, bottom, left, right), and with a recto page coming first in most designs, the labels are almost immaterial if logic can prevail.

But the labels as they are, are misleading…to anyone smart enough to stop to read them, which is obviously not me.

[Facepalm emoji, and acute embarrassment on my part]

And the OP’s first image does show the left / inner margin as 1” and the right / outer margin as 0.5”, so at least that dialogue window and the preview are correct (I think).

Slàinte mhòr.

this is my original point—though I do acknowledge points made about the guttering: I was following Eric Gill’s advice a little too closely; it’s my first time designing a book—and simply reversing the margin settings in Word seems to cause weird losses of paragraph indents. There are always workarounds, but what I’m trying to do it produce a workflow and the less specific fiddling required at stages ‘down river’ the better.

thanks for all the feedback… and may I ask: what does “OP” stand for?

Hi

Apologies for any confusion I have caused.

The letters OP stand for original poster.

Slàinte mhòr.

The non-fidgety workaround is not to correct for this in Word, but just to, in your compile format set Inside and Outside margins to the opposite of what those labels say. Then all should be well and with no extra fussing later.

The above isn’t even really just a workaround, as JoRo has indicated – it is just a matter of “doing the right thing” when labels are misdirecting you. Because, in truth, the problem just boils down to the fact that those two fields in the margins dialog (when mirror margins are turned on) are currently mislabeled. As JoRo showed, even the Scrivener manual knows better!

Fixed in the next update:

https://forum.literatureandlatte.com/t/facing-page-margins/45171/2

Slàinte mhòr.

I’m having same problem. Amazon gives you value for inner and outer, but when I put them into Scrivener, they were reversed in the compiled PDF

When I swapped them (Amazon inner = Scrivener outer, etc. ) it was fine and preview fine in KDP previewer.

One thing I did do in my compile settings was set my Chapter layout to always start on a recto page. Maybe that caused it? Shouldn’t all chapters start on a recto?

I had the same problem with a recent upload. To resolve it, (at least for KDP), I added a blank page to the PDF, then deleted it in Preview after the PDF had been created. I was not using Recto page starts on chapters. I had tried that and it didn’t seem to make a difference.