"Invalid Project" | Scrivener3 and iOS problem

I have Scrivener3 (Mac) and the project located in App>Scrivener but when I attempt to sync it with my iOS version (iPad) I get a message

“The project cannot be opened because it does not contain a valid binder structure file. Please ensure that the project has been fully uploaded from other devices and then try syncing with Dropbox again”

It appears to sync fine, and can detect the right number of changes. Could it be because I have PDFs in the Project?

Have you checked from your Mac that you Save the project in the given folder? You’re not using Sync with external folder?

Also ensure that the project finished syncing on your Mac (check the Dropbox icon in the menu bar) - that is usually the cause of errors like this. A Scrivener project is really a folder of many files, so if your Mac hasn’t finished uploading the files to Dropbox before you try syncing on iOS, then not all of the project will be available and you’ll see an error such as this one.

All the best,

Yes - I am using the correct folder (Apps>Scrivener)
Yes- the project has finished syncing on the mac and is closed.

Scrivener iOS can clearly detect the changes. I tested yesterday by making a change in the project on the mac, closing, syncing, then opening on iOS. I sync, and Scrivener tells me “2 changes detected” and then it syncs, and goes towards the binder page, but then the error message appears.

I will test with a new Scrivener project (blank) to see if I have the same problem.

And you are NOT using ”Sync with external folder”?

Could you show a screenshot of the Dropbox folder where you have saved the project?

Here is the screenshot of where the Scrivener Project is saved on my Mac (attached)

Here are the screenshots from my iPad

Well, if iOS Scriv says something is wrong with the project, something is wrong.
Have you tested to actually Save As under a new name, to get a fresh copy of the project and see if that changes anything?

What happens when you double-click on the file in the Dropbox/Apps/Scrivener folder on your Mac? Does it open fine in Scrivener on the Mac then?

Could you zip up a copy of the project and send it to us at mac.support AT literatureandlatte.com for testing, please?

Thanks. The project open fines in Scrivner for Mac. I’ve tried renaming it, removing the PDF but have the same issue. I tried a new project from a Scrivner template, and it worked perfectly. so something wrong with my file. I’ve zipped it and sent to support. Thanks for the suggestions everyone.

Thanks for sending the project. I have found the problem, which is fortunately easy to fix on your end. Before I provide the fix, a quick explanation of the problem:

A Scrivener file is really a folder that just looks like a single file on a Mac. Inside the .scriv package though, there are many folders and files representing your project’s data. For instance, inside the .scriv package there is a folder called “Files”, another called “Settings” and so on. You don’t normally see these and shouldn’t normally mess with the .scriv package or touch them outside of Scrivener.

On top of this, there is a key difference between the Mac and iOS file systems. The macOS file system is case-insensitive. This means that a file called “Bob” is no different from a file called “bob” or “boB”. The iOS file system, however, is case-sensitive: if there’s a file called “Bob” on disk but an app tries to open it by calling it “bob”, it won’t work.

And here’s the problem: some of the folders inside your project’s .scriv file have had the case of their file names changed. “Files” is now “files” and “Settings” is now “settings”. The macOS version, running on the case-insensitive macOS file system, won’t care about this, but the iOS version is looking for “Files” and “Settings” but cannot find them because the iOS file system is case-sensitive and so does not recognise “files” and “settings” as being “Files” and “Settings”.

Scrivener itself never changes the case of files, so presumably you must have put your project somewhere or done something to it at some point (another file system, another syncing solution, perhaps) that has altered the case of the file names inside the package, thus breaking the project on iOS.

So, that’s the reason for the problem. Fortunately, as I say, the fix is easy:

  1. Ctrl-click on your .scriv project in the Finder on the Mac.

  2. Select “Show Package Contents”. This will show you the internals of the Scrivener package, and you’ll see the problem.

  3. Rename “files”, “settings” and “snapshots” to “Files”, “Settings” and “Snapshots” (i.e. just uppercase the first letter of each).

Fortunately no other files have been affected, so that’s all you should need to do. Once you’ve done that, let Dropbox sync your changes, re-sync the iOS version, and the project should open fine (it did in my testing).

(In an ideal world I’d be able to force the iOS version’s reading methods to be case-insensitive, but unfortunately there is no way of doing this.)

All the best,

Hi Keith,
Thanks for responding so quickly and figuring this out. So weird - I’ve got no idea how this happened. I’ll follow your steps and let you know the results.


Thanks for the kind words (or hashtag)! I hope you were able to get things up and running again.

All the best,

Hi all,
Unfortunately that solution didn’t work.
I have sent the updated file back to Literature and Latte to figure out what is going on.

Yes- it opens fine on the Mac.
Yes- it syncs and I wait for the sync to end
iPad can ‘see’ the changes, syncs but then can’t open the file.


I replied to your email yesterday, so please check your mail, but I did not see an updated project that has been sent to us yet - I’ve just checked our support queue and it’s not there. Could you please zip it up and send it again? I’ll fix it myself this time and send the fixed version back to you.

Many thanks,

Regarding the change in case… I’ve encountered this with a couple of projects synced to iOScrivener via Dropbox. When I investigated, I found that on my Mac, the folders & files were all capitalized as normal within the project, but on Dropbox.com, when browsing the website, I found they were all lowercase, including the .scriv project folder name. Since I’ve moved some of my larger projects out of the Apps/Scrivener dropbox folder to speed up syncing, I haven’t experienced this issue.

I never did figure out if it was a Dropbox problem, an iOS Scrivener problem, or some other thing I was doing causing the problem. I’m not sure if it’s a viable solution to this kind of thing, but does it make sense to change Scrivener for Mac/Win to use all lowercase letters for its files and folders to avoid this kind of glitch?

That assumes that nothing can ever result in them ending up with all uppercase letters, though - and besides, I hate all lowercase names. :slight_smile:

Thank you for posting this! Your solution helped me fix my problem.

Post to Scrivener Users FB group:

Help! I’m getting this “Invalid Project” error on my iPad (Scrivener 1.1.5) when trying to open certain Scrivener projects that I have been working on on my MacBook Pro. 

They open just fine on the Scrivener apps on my MacBookPro and my iPhone, but I get this error when I try to open them on my iPad.

Tried searching this group for assistance but still not figuring it out. 

Anybody know how to solve this (syncing?) problem?


SOLVED. UPDATE: Solved via this solution! Dropbox had a faulty sync at some point and changed the lettercase on just those certain files. Had to change cases via Dropbox on web browser (not just Dropbox Desktop), and conduct a couple syncs/re-syncs, and voila... 7 hours later, headache (and errors) gone! https://forum.literatureandlatte.com/t/invalid-project-scrivener3-and-ios-problem/40932/1

Be aware, everyone, I believe we have the OPTION of making a macOS disk case-sensitive. It’s not the usual, but the disk can be formatted that way.