Justify not working as expected

Hello,
I am working in Mac version. Pretty straightforward: in Novel Format.
For the majority of passages I am using (center) justify. When I compile (into PDF) however the justification only partially works. A majority of passages are not center-justified.

I have not made that many changes: from the default 16 font to 12 font, 2.0 double-spacing and into Times font type.

I tried going through and re-setting the justify for all pages/ specific passages.

I assume there is an advanced setting that I am missing. Any suggestions appreciated obviously.

Did you use styles? (Styles override the formatting at compile.)
Also, see that it is all the layouts from your compile format that are formatted according to your desired output.

Hello Vincent.
Thank you. I did not select any style(s).
The interface displays “No Style” in the drop-down.

Can you please explain this in a different way? I don’t exactly understand your point. tx

A compile format can override the paragraph formatting of your regular body text. This is not an uncommon set up.

However, this would not yet explain why only some of your centered paragraphs are failing.

Something that might explain that difference is the assignment of different Section Types to the documents in your project. You might check to see if the passages that come out properly centered and those that don’t are associated with different docs in the project. Then, if so, check in the inspector to see if there is a difference in the section type being assigned to those diff docs.

1 Like

hi gr,
Thank you also.
I have made an inspection of every page. The pages that appeared to be justifying correctly were simply paragraphs that did not wrap. In other words - there is no justification, or rather there is only default left-hand justification. Therefore, I conclude that the justification is lost on the Compile step. As you write: ‘A compile format can override the paragraph formatting’
I guess I need to learn about compile formats? Where are they set.

I have gone through the whole document in the Inspector mode as you instruct - you mean the setting General Metadata ? I note that all the pages display: Section type: Scene.
Does that give a clue?

update: I went into Compile and changed the Format from ‘Manuscript (Times)’ to ‘Default’.

This resulted in the justification being implemented. In other words 'Manuscript (Times) overrides justification. I was under the impression that Manuscript (Times) only referred to the font type. Apparently this not the case.

Thank you both for helping me understand where to look.

1 Like

If you want to understand why the two compile formats behave differently, and have a glimpse of what is going on, do as follow:

Double click the “default” compile format.
Duplicate and edit as prompted. (Click “Duplicate and edit”.)

You’ll then see this :


This is where the (re)formatting is handled.

That is far from being the whole of it, but it should get you started in the right direction. :wink:

Ha. Excellent - I was about to ask…tx

I do not see anything in there referring to ‘justification’ but I am not familiar with all the terminology.

Justified text is not centered text by the way.
It is when lines are made full, without splitting words, by playing with the width of spaces.

image

1 Like

Oh - is it not also referred to as justification if you select, for example, the left most icon - as lefthand justification? In other words I understand by justified / centered text for the text to be visually aligned as a single block of text (as you describe).

My bad :
I said “justification”, I meant “Justified”.
(I will fix my previous post.)

ah, i think i was not being accurate - I did not mean center justify. I meant justifying in the center (full lines of text across the whole page), as opposed to the left or right hand. ha

Ok, one last question.
Supposing that I want to use Format name: Manuscript (Times)
because the rest of the titles and page breaks are correctly formatted.
How would I go about figuring out where the justify / justification setting is in Compile?

I clicked the icon for jusitification under Formatting, see below, and this does not seem to have an effect.

First, it’ll be a section layout for which “text” is checked.

Earlier you said your section type was “scene”.

See at the bottom of the top list where it says “Assigned to” ?
Locate the one that says “Scene”.

Then click in the demo text at the bottom, and format it to your taste.

Note that this will only work if all of your document is formatted the same.
If you have left aligned text and centered text in the same document, that won’t work.
In that case you have to either use a style for centered text (a style overrides the formatting of the section layout), uncheck “Override text and notes formatting”, or compile “as is”.

Vincent_Vincent
You genius, thank you for your patience.
It was an untitled Section called Section Text

1 Like

It’s actually Keith who is the genius.
(*and whoever contributed the idea, should it be.)

That is known as ‘full justification’ (b/c it is justified on the left and the right).

Glad you got things sorted.

Sure, but with all due respect - and having worked in software - I would raise the point that having two places with the same function (icon) in which one overrides the other - whereby the end user may struggle, is not considered genius from an interface-design perspective. No, I was referring to you, Vincent, because helping someone resolve a relatively complex blocker, with patience, until they are sorted out, is a form of patience-genius.

Ok then. Thanks for the compliment.

As for the compiler overriding the formatting (I’ll assume that this is what you mean by “two places with the same function (icon) in which one overrides the other”), give it time and you will come to find that it actually not only makes sense, but that it is of indisputable logic.
And very, very very convenient. :wink:

1 Like

Styles are predefined (by you) ways to describe how a document is organized. They work pretty much the same way in HTML, Scriv (ymmv), Word, and other text manglers.

You assign your formatting (heading, body, font, size, alignment, spacing, indents, lists, bold, itals, indents, colors, whatever) to the style, not the text.

Any text tagged with that style inherits the style’s formatting. Change something in the style, and all text with that style picks up the change.

Say you rethink your life choices and change 6 point Comic Sans to 10 point Garamond, and centered to justified. Your document is 1600 pages long.

If you planned ahead and applied styles to text that should be formatted a certain way, you modify the style and you’re done. All the text with that style gets an automatic makeover.

That’s why style tags are a good thing. They’re not as perfectly implemented in Scriv 3 as they are in Word, but having styles at all is a huge improvement in Scriv 3 over previous versions.

Yes, you’re going to have to learn something slightly technical, like driving a stick shift, but once you grok styles, you’ll have more time for writing.

As for output, unfortunately Scriv styles don’t get converted into Word styles. You still have to be all technical fixing output settings as my superiors have described up-thread.