Lagging writing with Mac Ventura

I just upgraded to a macbook M2 airbook, much more powerful than my previous computer. I have both the latest OS and Scrivener updates.
However, Scrivener, which worked flawlessly with the old computer is now lagging when I write to the point of being unusable.
The only way to make it work (that is, typing not lagging) is to switch to composition mode but this is not really helpful given my use of Scrivener (PhD writing/split mode/accessing folders constantly).
Has anyone encountered a similar problem and know how to fix it?
Best regards,

I am using a Mac with a little less powerful M1 and the processor is, as expected, practically always bored to death waiting for me to hit a key or do anything else. So no lagging here at all, wether with one editor open or two in split-view.

Is it possible you are using some writing aid software that works in the background when you use Scrivener? If so try to turn it off and see if that changes anything.

Thanks for your answer. No, nothing running in the background. Everything laggs, typing, scrolling when in normal mode but runs flawlessly when in composition mode…

The only somewhat similar issue we’ve seen reported involves long hangs after doing certain things.

Nine times out of ten though these kinds of issues are too contextual to explain them in just one response. There is no one answer, and it could be anything from an out of date utility you use that doesn’t work well on the new system and is slowing programs like Scrivener down, to a specific view setting you are using (that Composition works fine might point toward that), etc.

You just have to play around a bit rather than looking at one single thing. Use the Interactive Tutorial, see if it is slow. Try running Scrivener with nothing else running but Finder, etc. Turn off the more complicated editor settings that might not be enabled in Composition, like Page View and line numbering.

I followed your suggestion and the problem seems to originate from the binder: if too many subsections are unfolded, it just laggs but if I fold them back, it works correctly.
Thanks for the help!

1 Like

Interesting! I’ll write up a note to have a look at what might be going on there that is different from older versions of macOS. Thanks for the follow-up.

It may also be worth noting that a brand spanking new Mac will always noticeably underperform for an initial period of time. This might particularly be so if you have transferred over stuff from a quite older Mac. The OS now puts up a notification telling you this (that it is optimizing things and so will be uncharacteristically slower initially). This may be at least a factor in what you are seeing.

1 Like

Thanks, it may well be the case even though I have not noticed significant issues with other apps.
Even though unfolding / folding the binder is probably not the most canonic way to fix the issue, it does the job so far and has allowed me to work efficiently today: a minor concession to get this great app to work!
Thanks for your help

Are you storing your work with a “cloud” service? And has that service been told to make Scrivener projects “available offline” (or whatever your service calls it)?

I ask because unfolding the Binder might be forcing the service to download the newly loaded documents, causing a lag while it does so.

The only way I can think that twiddling in the Binder could possibly be relevant is maybe if you had Scrivenings view mode enabled and (for some reason) had big chunks of the Binder selected. This would put the text of everything selected in the Binder into the editor pane and doing that requires the program to be tapping all the constituent text files. I use Scrivenings mode a lot and I don’t experience lag when I do things like this, but maybe your project is huge?