Latest update won't install: "destination ${installdire} resolved to an empty value."

Hi - The latest update won’t install and generates the error message:
[attachment=0]Empty Value.PNG[/attachment]

Unfortunately, I have the same problem.

I received the notice to update today and I didn’t even select the option to update (didn’t get a chance to do anything) before Scrivener 3 closed and, somehow, deleted its own .exe file.
Right before my morning writing session. Convenient!
I’m redownloading Scrivener 3, I guess, since I don’t have any other choice.

Yeah I’m having the same problem. I wonder if they’ll need to pull the update and sort whatever is wrong with it.

Me too. I can’t install

Try shutting down your AntiVirus, guys, re-install Scrivener, check that it runs, then Whitelist it in your AntiVirus.



Wasn’t my AV - but re-installing Scrivener did seem to do the trick. Hopefully not a regular occurrence… :smiley:

I am also unable to update. Deactivating my anti-virus software didn’t resolve the issue.


What worked for me. Downloaded trial V3.0.1.0 from L and L installed and everything seems to have registered itself as no indication of trial limitation showed when I launched Scrivener.

Just jumping on the bandwagon to say that I also experienced this issue - even with AV turned off.

Having the same problem

This is my installation directory if that helps C:\Program Files\Scrivener3

No way to update to version, even deactivating Antivirus (Bitdefender) :neutral_face:

I don’t know if this will help the people having issues with their anti-virus, but i had no problems updating by first uninstalling the 3.0.0 version, and then doing a fresh install of 3.0.1 version. It installed with no issues, and recognized the license.

I’d reinstalled 3.0 yesterday and was able to use it most of the day. This morning when I opened a file it closed and deleted the .exe again.
Downloaded 3.01 this morning and tried to install, with no avail. I’ll delete all other versions and try one more time.

Would love to see the issue addressed instead of a ton of work-arounds.

This shouldn’t happen. But FYI if you just download the newest file for Scriv then install, you don’t even have to uninstall first (though that’s probably smartest).

FWIW: I wasn’t able to wait yesterday. Once the update notice showed up, it closed Scrivener 3.0 and deleted the .exe file. I never selected the option to update.

Same problems here. AVG AV-software was probably guilty. I had to white-list the installer and then the scrivener.exe. All seems to be working now again.

Run Scrivener as Administrator (Right-Click the Scrivener icon and select Run As Administrator) and run Help > Check for Updates… manually.

Same error message as others cited. Downloading and running the install package instead of asking Scrivener to do it cleared the problem. Odd that running from inside the program kept the updater from recognizing the install directory. when running the installer stand-alone it found the right path.

Adding my own voice to the discussion. Will try the workaround of installing v3.01, but do think it’s an issue that needs addressing.