[LH1865|LH1866|LH846] Auto-complete only partly works in script mode

I am using in the 32 bit version. In script mode (Stage Play US format) I can add character names to the list under Project/Project Settings/Auto-complete list. If I select Script (Character) under Scope, the auto-complete works for the character name. If I make another entry for the same character but select another option under Scope, say Script (Scene Action) auto-complete doesn’t work. In fact, it doesn’t work for any choice under Scope except Script (Character), even Scope ‘General Text’ or ‘All (Text & Scripts)’.

It makes no difference if I change the settings in File/Options/Corrections, Word Auto-Completion by checking or unchecking ‘Suggest completions as you type’ or ‘In script mode only’.

In other words, I can only get auto-complete to work with the sole choice of Scope ‘Script (Character)’. Am I missing something or is this a bug?

(I originally posted this on the Bug Hunt Windows forum, but I think that was the wrong area)

Hello! Sorry for the delay in responding.

I believe this is a mixture of a bug and a missed set of options. Check under Format > Scriptwriting > Script Settings…
For each of the elements there should be a tab that says Auto Complete. In that tab there should be a box marked “Include project completions for this element”. Is that checked? It should be checked by default, but I believe that that is the bug we have found here. There’s also a bug where scope “All (Text and Scripts)” does not appear to be working.

Does this fix your issue or is there another bug I haven’t found yet?


Thanks Bryan that did overcome the problem by way of a couple of issues. First, after ticking the box for project completions a window appeared wanting me to save the project as Stage Play (U.S.) New, or something like that. I clicked okay and Scrivener then froze. I l left it for a few minutes but ultimately had to force close it. Fortunately, upon re-opening, the changes had been saved so that auto-complete worked for all the chosen elements.

The catch was that all my previous work was changed to ‘general text’. As it was a new project it didn’t take me too long to manually go back to every element (stage direction, stage action, character, dialogue) and change it but it would have been daunting for a longer project. I think there was some sort of warning of this when I was asked to save the changes to Stage Play (U.S.) New, but there was no alternative if I wanted auto-complete to apply.

[Update] As stated above, I manually went through each element to change it to the correct one and after that saved the project. Upon re-opening it all the changes were lost and every element was changed and wrong. I can’t make the changes stick, which makes the Scrivener beta unusable for me, at least using the play format.

Yes. It looks like there’s an issue with converting Script Formats. Thanks for catching that one as well. I’ve added it.

I have just tried beta 10 and the problem remains. If I open a script from Windows 1.9.x in Scrivener beta 10, the elements are a jumbled mix of scene action and general text. If I manually change the elements to the correct one and save, the changes are not kept. Script conversion appears to do nothing.

Is it planned to fix this bug for the next version?

I can’t tell you when in the beta process this will be addressed, but I can tell you that it has been filed and is on our list.

Could you please tell me if this bug has been fixed yet?

You can find a list of fixed bugs whenever a new beta version is released here: https://forum.literatureandlatte.com/t/scrivener-3-0-beta-release-candidate-10-download-links-change-list/38228/1

In this case I believe one of these has been fixed, but the other two remain unresolved for now.