[LH2411|LH2996] Moving by paragraphs doesn't work

Seems a very basic thing. Am I the only one with this issue?

The manual claims it is supposed to work as expected:

15.2 Editing Basics
15.2.1 Caret Movement and Selection
The following list shows the shortcuts for changing the current selection. To simply
instead move the current insertion caret position, omit the shift key where applicable.
§ Shift-ArrowKeys: Extend current selection in the direction of the arrow key that is
§ Ctrl-Shift-UpArrow or DownArrow: Extend the selection by paragraphs.

However, whenever I use Ctrl-Up (or Down)Arrow, it puts me at the start of the scene.

Very, VERY difficult to manage a writing flow with such a basic navigation error.

The manual, to my knowledge, is referring to Scrivener and is not updated for the beta or at least not in full. I may be wrong though.

The beta is just that - beta, so it is to be expected to have bugs. It is provided for testing purposes only, and as warned, not to be used for important projects. If you do, the responsibility is entirely yours as well as the risk of losing work. As a beta tester, you should be aware of all this.
Reporting bugs is fine, complaining, that this or that does not work is meaningless since it’s a beta and you get it free of charge.

Anyway, I appreciate that LL gives us the opportunity to get used to the new functionality of the software prior to releasing the final version.


The current behavior seems to be Ctrl-shift-up selects to the start of the scene from the current cursor position, and ctrl-shift-down selects to the start of the scene from the current cursor position. However, the keyboard options list says those two shortcuts are for “Previous Container” and “Next Container,” respectively.

Without a selection, Ctrl-up moves to start of document; ctrl-down moves to start of document. Those should be moving items up or down, according to Options | Keyboard | document.

They do that in the binder context, but not in the document editor context.

I’m not entirely sure what “Container” means in the context of document editing.

In the keyboard options, “Edit” category, there do not appear to be “Next paragraph” and “Previous paragraph” options for navigation, nor for “extend selection”.

It’s possible the overworked programmer hasn’t gotten to these navigation features.

You are confused about what complaining is. Complaining is stating, usually in an angry way, personal reaction to problems. “What a piece of junk!” is complaining. I did none of that. I’m unsure why you accused me.

I stated facts. The navigation isn’t working. It is extremely difficult to navigate without the very important and basic tool of moving by paragraphs. This isn’t complaining, this is reality.

Please be more respectful. You are unwittingly undermining my efforts to communicate something that is important to correct.

Respect is earned, not given. If you wanna be respected, learn how to be respectful first.

Food for thought: the beta release notes are quite clear that there are large chunks of functionality that are not yet present. It is simple to query if the functionality you are looking for is one of those missing chunks.

When they get to the point they say the beta is feature complete and they are focusing on bug-hunting and polish, then it’s time to worry and up the urgency a little.

Right back at you. You think you are entitled to condescendingly correct me and others, but you aren’t. Please stop.

Hi mhtritter,

From the beta release note page [url]Scrivener 3.0 Beta - Release Candidate 10 (Download Links & Change List)]

We have not yet updated the user manual, so the beta still contains the old 1.9.7 manual. We have however included an updated interactive tutorial for 3.0, which we recommend working through to familiarise yourself with the new features.” (bolding mine)

The status of the manual was already mentioned upthread, but I thought a cite would be appropriate. Your best bet on understanding intended functionality of the beta is to review the beta tutorial and release notes, and utilize the current Mac v3 manual, with the understanding that there will always be some Win vs. Mac differences.

As a data point for you, I also viewed this as a complaint.


Okay, good to know. Subtle undertones of intention in written communication are notoriously difficult to communicate or interpret flawlessly. It wasn’t meant vitriolic, only informative.

I’m surprised by the apparent need to offer a full justification for my positing a bug in the ‘post bugs here’ blog, but at the risk of offending someone unintentionally, here goes:
It is difficult to use the software currently because of the flaw I mentioned. It is probably a 10 minute coding fix, unintentional but overlooked. The flaw, or error, is not contained in a small sub-system, something that happens when a collection of various elements are all in place (not, when in a certain view and under a certain sub-menu, there is an error); rather this is highly prominent and basic bit of navigation. That is what I was trying to communicate, that it disrupts the primary function of the entire software package. The core mission of Scriviner is to provide software for writing flow, and this basic error interrupts that, and in my experience makes that flow impossible. That I would have to press the down key 50 times instead of 5 when trying to navigate 5 paragraphs. Further, that it brings me top of my work if I forget the shortcut is ‘broken’.

For this reason, btw, I disagree with the perspective that ‘major’ issues should be addressed first, and this issue only after they are done. I find version 3.0 unusable currently due to this tiny but critical flaw. Though I feel that way, I have no objection to someone stating their personal perspective on how L&L should approach their coding priorities. I only want the right to express my perspective as well.

I too love L&L and Scriviner. I didn’t say so, I simply stated the problem. I realize that. I’m not ashamed of it. I didn’t realize kissing their ass, or anyone else’s, was expected.


I suspect it was the editorializing that got up people’s nose, as it came across with a strong hint of “you dummies, how could you miss something so basic?”

Simply report the issue and impact. Carry on.

You mean in the way that responses to my post have been? People interpreted my message as hostile and insulting, though it wasn’t put down that way, and in response were openly hostile and insulting, no interpretation needed. None see the irony in castigating me for not being differential enough in their oh so humble opinion.

Interesting, nobody has commented on the actual bug, only my expression. The reason I put “Am I the only one having this problem?” is because I was wondering, well, was anyone else having the problem?! I’d looked through the thread and hadn’t seen any comments on it, and I’d looked in the manual to see if anything had changed. I worked hard not report something that was only unique to me or a lack of understanding on my part. I think I was skeptical that it was a true error for everyone because, as I said in my last post, it pretty much makes it impossible to write and revise with the software as it is.

Let me state that again, so it sinks in - the software cannot be used to write and revise due to this error.

And before you say, yes it can, ask yourself, are you writing with it? Are you writing a couple of hours a day on a novel with 3.0? If you aren’t, which is the point of the software, maybe you are unplaying the importance of the flaw rather than assuming that I am overplaying it.

The software doesn’t perform its main function because of this flaw…I don’t say this to be difficult, but helpful.

So, maybe take your own advice, if you all are so wonderful, next time say, “Hey, MHTritter, I checked it out and it did the same thing for me [or didn’t, that would be interesting too]. I’m not sure if you meant to express anger, but it came across that way.” and leave it at that. As you say – Simply report the issue and impact. Carry on.

(which is what I thought I did).

I have more time to debate my communication style if you do, btw. I visit this page as a break from my actual writing. You know, the thing we supposedly use Scriviner for.

Hello! Apologies for not stepping in sooner, as I should have.

I think everyone needs to take a breath and remember that this is the Beta forum. This is precisely where such reports and problems should be brought up. If anyone gets too persnickety in their complaining, we will respond - we don’t need others policing tone for us. It may not seem like it sometimes, but remember we’re all here to make this the best version of Scrivener it can be. So let’s all try to remain respectful, earned or not.

That all said:

Yes this a bug dealing with the shortcuts. This has been filed and is very much on our radar.

Part of the confusion in this thread (and with our shortcuts in general) is the overlap between shortcuts when the binder is active versus when the editor is active.

Move to Previous/Next Container is a binder shortcut. Container in this sense encompasses both Folders and Documents that Contain Subdocuments, so the shortcut should skip single Documents.

I hope this helps, and please do let me know if you have any more questions. If possible, I will answer them.

Thank you all.

I can’t speak for anyone else, but I have not commented on accuracy of your bug report (in fact, when I tried it, I did indeed verify it). I can say that because I am following the recommendations to not use the beta for stuff I care about, I am not spending a couple of hours a day in using it, so am not affected by it.

You are still on the jag that I was incorrect in my original communication? And your reasoning now is because I shouldn’t be trying to use the software seriously? That we should all expect it to be broken and therefore no big deal?

I never said, “I cannot meet my deadline with this beta software! I’m angry!”, which I agree would have violated their guidelines not to use it for stuff I care about. But I didn’t complain! I wasn’t upset that I couldn’t use it! Okay?

What I did do was try to highlight that the error, though seemingly minor in impact if only considered without actual fidelity of practice, is in fact a major problem if and when the software moves towards utilization. I was trying to be helpful.

And speaking of not understanding tone, a representative of Scriviner already responded, and it seems to me they imparted that I didn’t err and that it would be best if the matter was left off. If you have trouble understanding that was their message, please reread it. If you still think so, then you might be willfully misunderstanding.

I have asked respectfully and politely several time now, and will ask again – please stop using this forum as a place to voice to me that I communicated wrongly.

Hi guys, I have bumped up the priority of these tickets. I believe they will be fixed in the next update. Thank You for reporting this guys. We were busy with other high priority functionality and fixes and could not fix this earlier. Sorry about that!

In the fragment I quoted above I WAS AGREEING WITH YOU. I was merely offering my reason, as one, for why I had not seen this error until now. If you want to make more of it than that, leave me out of it.

Oh, I’m probably a tad defensive at this point.I can own that.

Sorry and thanks.