[LH3468] Font changes to Arial

I was using Segoe UI as my font in a project. I just upgraded from .11 to .12, and now the font is set to Arial, including in the Comments.

This seems to happen in any project I open.

If I change it back, here’s what the change looks like in one of the rtf files.

-{\fonttbl{\f0\fnil\fcharset0\fprq2 SegoeUI;}{\f1\fnil\fcharset0\fprq2 SegoeUI;}}
+{\fonttbl{\f0\fnil\fcharset0\fprq2 SegoeUI;}{\f1\fnil\fcharset0\fprq2 ArialMT;}{\f2\fnil\fcharset0\fprq2 SegoeUI;}}

So it looks like it’s ignoring the font specified in the rtf.

No one else had this happen to them?

From your RTF snippet I see that the Ariel font has been added to the RTF font table. It does not mean that the RTF document will use it in all the text. Inside your font table I also see that Segoe UI appears twice, which is also not expected. If you upload or email a small demo project to tiho at literatureandlatte.com I might be able to trace this further, From your initial post it is difficult to reproduce and fix the issue.

It happens occasionally.

This also happens to me. I’m also using Segoe UI, normally. It was also changing most things to Courier Prime. I changed it all back to Segoe UI, but when reopening the project the next day that everything was back to Courier Prime or Arial.

I had a fiddle to see if I could fix or reproduce this. I found that my Scrivener settings had the default font set to Courier Prime, so I changed this to Segoe UI. Since then I’m not noticing anything changing back to Courier Prime, but it’s still resetting to Arial.

When closing the project and reopening it immediately, no reset happened. However, when turning off my computer, starting it up again and reopening the project it does reset to Arial every time.

I did also notice that when changing Scrivener settings once, it reset the Segoe UI sections to Arial, but I’m not sure which setting change caused this and haven’t been able to reproduce it.

In all these cases, only the font was changed, to my knowledge, and only if the text was in Segoe UI when I closed the project.

EDIT: I’m also noticing that wherever I make a return break, regardless of what font was being used on the previous line, the new line will be in Arial.

EDIT 2: I discovered the fonts in all my styles had been changed to Arial, so I fixed this and it seems to have fixed the original two problems and created another. After shutting down my computer and starting everything up again, now all my body text is black on a black background. There isn’t even a background colour option in scrivener! I did notice that while i was making alterations before shutting down, the text in the styles dropdown for two of my styles, including the body text, was showing as white text on the usual white background. This was after I ‘fixed’ the styles.

Did you change your system font at all? Or shift to a Windows theme that changed the system font?

It sounds like things may be a little buggy or corrupted, too; I would uninstall and reinstall.

I noticed an unexpected font change, but I muck with Windows themes all the time, so it wasn’t really unexpected.

It happened to me, as you describe it. After installing update 12.

It happens with any file I create in 11 and then open in 12, or create in 12, close, then reopen.

The font keeps changing to Arial in any scrivening with text in it.

Again I can confirm that the same thing happens to me, and was not present in b11

No, I leave my system alone in that regard.

This happens to me as well - most noticeably when I’m creating a new page from a template - it seems to do it every single time regardless of what font I’m using in the Template, when I create a new page based on that template it switches it to Arial.

Glad I am not the only one. I have tried everything I can think of to keep it in Segoe UI to no avail. I’ve created new chapters, tried rewriting, everything goes to all wonky. I know its not a big deal to stop me from writing, but to go from one font to another is kinda annoying.

Do you have the proper font setup in Options->Editing->Formatting ?

As for the template: do you have some other font setup in that specific template, but Arial?

Nope, did not change it to what rest of my texts have been. Still stuck on what I showed in my previous post screenshot.

There are at least two places in Scrivener3 to change the default text style in new documents. One is globally; the other overrides the default “No Style” text with a project-specific “No Style” text.

  1. Options → Editing → formatting. Click the “Aa” graphic, and see what font you’re using.

  2. Project → Project Settings → “Use different formatting for new documents in this project:”
    Is the checkbox checked?
    Click on the “Aa” graphic, and see what font that is. If that’s Arial, click Cancel in the font dialog box; uncheck the checkbox for different formatting, and click OK at the bottom.

The second one has bitten me more than once.
If your cursor is in just the wrong place, you could type “Alt-p p click ” and reset your default font without intending to.

This was the problem when I was having an issue with an unexpected style (not Arial, though) showing up in my new Documents. That checkbox was checked.

The Arial problem I had showed up after a Windows theme change. Changed back the theme, and it went away. Uninstalled the theme; problem solved until I muck with themes again.

Speaking only for myself:, Curious what others say, as this bugs me, even if it’s not a show stopper.

Correctly set to Segoe

Not checked, but correctly set to Segoe if I do.

No changes in Theme. Same old custom scheme as I’ve used for ages.

Just a quick note to say I am experiencing this in the current beta (12) as well. Also using Segoe UI, and I have confirmed it is correctly set up in scrivener options and project settings. I’ve gone so far as to convert all of my pages to the default setting, and confirm they look as expected. However when I start up Scrivener the next day all of the fonts have reverted to Arial again.

(created an account just to comment on this!)

Which template? Is it one shipped with Scrivener Beta, or a third party template?

If you change “No Style” to some font other than Segoe UI, does that change “stick” after reboot and restart?

Hi, thanks for answering!

Just to confirm, as the “no style” field/setting you mentioned above (and referred to in an earlier post) is still not 100% clear to me, this is my setup:

File|Options|Editing|Formatting = font set to (now) Verdana (it has been Segoe UI but am trying your suggestion).

Project|Project Settings|Formatting| confirmed that “use different formatting for new documents in this project” is unticked.

Is there something else I need to set somewhere?

Just saving and rebooting to see if Scrivener likes Verdana. Will update this post in a sec.