[LH3879] Hide Markup stops hiding when moving between files, despite still being checked

Searched but couldn’t see a post about this bug so thought I’d plonk it here. (Is there a known bug list anywhere we can view, btw?)

Selecting View>Text Editing>Hide Markup works great… the first time you use it. But then if you select another document the markup shows in the editor. So… off I go to the View menu to turn it back on… Only the option is still ticked and I have to turn it off and on again to make it work.

Interesting, what mechanism are you using to select another document? I tried clicking in the binder, using the history and the next/prev document shortcuts. The setting seems to stick fine for me.

Clicking my mouse on files in the binder. Just checked the other methods too and they produce the same result. This problem seems to persist even after closing Scrivener too. Opening a project to test this and found it ticked in the menu but still showing all my highlights in the editor.

But, apologies I hadn’t realised this was only happening in Scrivenings mode, (selecting a chapter or sections files and displaying all their contents.) You are right individual files are fine.

Ah! Thanks, the devil is often in the details. :slight_smile:

I’ll make sure it’s on the list.

1 Like

V3.1.5.1 Win-10 64 bit.

FYI; not a big issue, just shedding new light on an old one.

Not the first mention of the Hide Markup setting being ignored (see e.g. this from a couple of years ago) but my experience adds a wrinkle: it only applies to scrivenings.

I noticed while reviewing the MS by scrivenings that I have to apply Hide Markup twice to actually hide what I thought already hidden. I looked at the menu and found that the item is initially checked, becomes unchecked, then is re-checked, i.e. Scrivener is remembering the setting, but is not, apparently applying it to scrivenings.

If e.g. I close and reopen Scrivener on an individual document, the display reflects the Hide Markup setting.

1 Like

I was drawn to the same conclusion.

It does work in Scrivenings, when you hide the markup for anything within a group (hierarchy, if you will). But as soon as you click outside of the hierarchy in Scrivenings mode the markup returns–basically selecting another grouping in the Binder, even a lower hierarchy grouping.

To turn it off in Scrivenings mode, you need to apply the shortcut (Alt-Shift-H) twice, for some or other reason. But then you’re still subject to what happens in my previous paragraph.

:pray: Synchronicity. Strange that I didn’t notice your post when I searched before posting, could have saved myself the effort :). (ah… hindsight… hits in relevance order rather than recency?).

1 Like

I’ve merged this with the existing bug report thread on it.

It seems to toggle fine once you are in the session and get past that first “on off” problem, but it will return whenever forming a new session as well.