Linux Beta Released (NOT LATEST)

Hi All,

We are happy to announce a new Scrivener for Linux beta with all the fixes and additions included in it from the Windows 1.5.6, 1.5.7, 1.6.0 and 1.6.1 releases. See all release notes here:

This beta expires 1.Dec.2014

Download here:
[url]http://www.literaturHi All,

We are very happy to announce a new Scrivener for Linux beta with over 500 bug fixes and all the additions included in the recent Windows 1.7.2 release, now avialble in Linux. See Windows release notes here:

Download here (now 32bit and 64bit versions available):

Scrivener is no longer able to link against glibc 2.13 (released 04 Feb 2011). We now link against glibc 2.15 (released 21 Feb 2012). When we build Qt we use gcc compiler v4.7.2 that comes with glibc 2.15. We use the default compiler provided in the oldest officially supported Ubuntu version. To continue to use the older glibc would mean using an older compiler and libraries which cause problems with the latest versions of 3rd party packages we use in Scrivener If you are using glibc 2.13, you will need to upgrade to 2.15 to use Scrivener v1.7.2.1. If you don’t wish to upgrade glibc you can continue to use Scrivener 1.6.

Also, some users might experience issues with cross-connected Qt libraries. We would suggest following link for help understanding and resolving this: … eta.tar.gz[/url]

Awesome! Does this mean it’ll support Scapple eventually, too? :slight_smile:

ETA: What should I be seeing with PDFs? I’m seeing pages, but no text. (It’ll open in an external editor just fine.)

Hi, I have just downloaded the tar file but can’t unpack it. I am using Arch and when I run makepkg, I am told the PKGBUILD does not exist. Is there one for Arch?

When I was using arch linux, I used the *.tar package, unpacked it to /opt and ran it via You’ll need the 32-bit libraries installed for it. (do ldd bin/Scrivener in the Scrivener directory, and it’ll tell you exactly which you’ll need installed.)

Thanks for the update! Software center plunked it right in there. Seems to function well–quick test at this point. Thanks again.
–Ubuntu 12.04LTS

I’m getting the following when I try to add a file (Ctrl-Sh-J , pulldown menu (from green button), or right-click --> add)
I invoked Scrivener from a terminal to catch the error. It immediately crashes when I try the above. I suspect this is a result of a recent Linux Mint update/upgrade. as it’s worked successfully before.

Cannot mix incompatible Qt library (version 0x40801) with this library (version 0x40800) Aborted (core dumped)

Pertinent info.
uname -a reports:

Linux Mint 13 (Maya) fully updated

I’ll try to “fallback” the Kernel in the meantime - it is a bit 'bleeding-edge…
If the devs. need any more files or info., pse let me know.
UPDATE: Rollig back kernel had no effect. (+ apt-get update/upgrade)
As I really need Scrivener to work to finish my project, I’m going for a full reinstall of Linux.
I did reinstall Linux - I was previously using Mint Mate 13, but found it a bit bloated for my ancient computer (when I get a job again, I’ll upgrade…). I went for Mint XFCE 15, seems more responsive.
Anyway, Scriv. Beta is in the repository, and, using that, everything works fine now.
As all my work is on Dropbox, the reinstall/recover was painless. Thanks all for the help. I can’t imagine a tool better suited to pull text, datasheets, code snippets, circuit diagrams etc. together for a hardware/software project.
(Remote ‘lab’ - Raspberry Pi-based, to stick in a forest, measure environment etc., controlled over the Internet, and hopefully snap pictures like this… )

nonono, don’t do that. Start scrivener using Scrivener/bin/ instead of the binary.

Be aware that the “incompatible Qt error” can occur when the default Qt style (which in Ubuntu is set to match the Gtk style) is only available for the 64-bit Qt library.

You can force the Qt style to “Clean Looks” (supported by 32-bit) by using the ‘-style’ argument:

  bash# bin/Scrivener -style=CleanLooks  &

Obviously, this should be set in bin/ unless you have LD_LIBRARY_PATH and such in your environment already.

The style can be set for all applications using the qtconfig tool:

 bash# qtconfig-qt4 &


Software Center warns me to install the deb package:

Lintian check results for /home/juh/Downloads/scrivener-
E: scrivener: maintainer-name-missing
Use of uninitialized value $name in pattern match (m//) at /usr/share/perl5/Lintian/ line 203.

Any hints?

Here the new version crashes reproducible when I want to make snapshots. The 1.5.x.x crashed, too.

This is the error message I got:

Cannot mix incompatible Qt library (version 0x40804) with this library (version 0x40800)

I work on Linux Mint Olivia Cinnamon.

And the package manager says the Beta expires July 2012? Will be 2014, I hope. :wink:

Package Installer - scrivener_223.png


On my system, I have noticed the “About Scrivener” window has no "X button and therefore, there’s no way to dismiss it and close Scrivener without restarting the system.

I am running Debian 7.2 amb64/GNOME 3.4.2

Jim M
About Scrivener.png

Hi Jim,

Yes, there hasn’t been an X-window close button on the “About” screen in any version of the Linux software. I’m on Ubuntu 13.10 64-bit, and I found that I can close the “about” window by right-clicking on the menu bar, which reveals a drop-down menu. At the bottom of the contextual menu, you’ll see the option “Close”. Click that and you’re golden. :smiley:


Jim M, have you tried to press the “Esc” key?

I am running Scrivener for Linux in debian sid, but with i3 as window manager. When I press Esc, the “About Scrivener” window dissapear.

I just installed this version successfully by using the quite complicated installation instruction.

So far Scrivener works fine. Even Kindle-Export, Snapshots and Spell-Checking works, all the things many people have struggled with. The only thing that does not work so far is changing the interface language. It does not change according to the settings but stays English.

For reference: I am using Ubuntu 13.04 in 64bit with KDE-Desktop in German.

I am an Linux-only user and would really like to buy a copy. Even if the Linux version is not supported in the same way as the other versions, it would be a good idea to make the Linux-Version obtainable as well. It would be great to be able to support you guys. As far as I see it, most errors reported here are due to the difficult installation instruction and possible installation errors that can occur with little linux system knowledge. This should be fixable with an updated deb package etc.

Why not make the Windows-Licence usable for Linux as well. As far as I see it, the code is the same anyway. So one can buy a copy for Windows and use the beta for Linux indefinitely as well.

I’ve tried everything. Missing library files galore if you only install ia32-libs…

I’m running CrunchBang Waldorf on a T530 64bit arch. I guess it would be a waste of my time to ask way Scrivener hasn’t been ported to a 64bit arch???

---------------------------------- other content deleted for sanity’s sake------------------------

First off: Thanks to scrandy, for the exact package name!

To get Scrivener running under CrunchBang 64bt (Waldorf), you should only have to do the following:

dpkg --add-architecture i386 sudo apt-get update sudo apt-get install ia32-libs-gtk sudo apt-get install libgstreamer-plugins-base0.10-0:i386

Then, download the Scrivener .deb package to your downloads directory. Use the FIle Manager, right click on the package under downloads, and use the “Gdebi Package Installer”.

Should be up and running at this point. Type “scrivener” at a command line prompt, or in your Run Program GUI.



I think you need gstreamer. I found this:
And then I looked in my synaptics and there was: libgstreamer-plugins-base0.10-0:i386
It is a ubuntu-package. I think you have to look if it exists. Have a look and then we go on from there.

Ah, you genius, you. LOL.

well we be right; just needed the gtstreamer for 32bit.

However, my Crunchbang Synaptic Package Manager didn’t have the package at all,
so I had to run it at the command line. Thankfully it does exist out there and the repositor was in my resources list.

So, we’re up and running. I hear, however that spellchecker and such won’t work so hot for us on our 64bit machines. I will see if that’s true over time, I suppose.

Why don’t they just port Scrivener to 64bt and 32bit? Maybe they will when they finally get all the bugs worked out??


Wonderful. Spellchecker works through the guide I linked below.

How I installed it:
(Ubuntu 13.04 64bit)

  • I simply opened the deb in the software center. But you can use any package manager to install it.
  • Then I found this:
  • I went through the extended guide and copied every script line one after the other into my shell. You have to be careful with it to get the linelength right. Especially the links are broken into several lines. Sometime you have to adapt to the correct directory. So at least look over every line if the downloaded files are there where the script line says they should be. If everything was typed in correctly you should get spelling and exports right through this. But the programm should also run basically without the guide.
  • When having library errors you need to install one missing lib after the other through synaptic. But they have to be 32bit.

So far.

I think what would be a really good start would be a list of dependencies and maybe a script that contains the script-lines of the how-to.

Hi! I would like to ask for some help!!

I want to use scrivener on my netbook, which runs on Ubuntu. I haven’t been using Ubuntu for that long, and I know very little about computers in general. I have no idea what a tar package of a deb package is, or what it means when something is in beta. I am, to but it bluntly, a computer idiot.

So far I have simply downloaded the .deb and the .tar.gz file I found in this thread. Can anyone tell me what the next step should be? Should I be downloading something else in addition? Do I need to unpack or install one of them? If anyone could give some clear instructions I would be very very grateful!!!