Linux Beta Released (NOT LATEST)

Beta usually means that there are a lot of bugs in the software. Here it means that they do not have the time to support you properly.
Its not that easy if you like to install scrivener for linux. But you cant break your system so simply tr it.

  • Open the deb file with your software center and simply install it.
  • If you have a 64bit system you need to install some libraries with synaptics. See library thread.
  • If you want to have spellchecking etc you need to follow the rather complicated guide in the middle of the guide thread in the forum.

Simply try it or wait for someone to create an install script. However if you manage to install, it works really well.

THank you for your reply!

I have downloaded the scrivener- - file mentioned on this forum , and when I click on open with software centre, the software centre opens and then shuts down due to some problem. I have also found another .deb file on the internet called (scrivener-beta_1.7beta9_all.deb) which does open in the Ubuntu software centre. However, the first time I tried to install I was informed that it was damaged and couldn’t be installed. A second time it did in fact install, but when I try to open scrivener I get a weir screen that look like it has been cut in half. The visible half sais "Beta exp … and than “THis Scri…”, with a big red cross, and When I click on ok, scrivener dissapeares again…

So so far, no novelwriting for me.
Is there a solution? Does anyone know what I should do?

That is the same problem I am having. i was using a purchased copy in Windows, but that system went to the big blue screen. I still have my Scribner files from the work I was doing. I use Mint, I never want to run Windows again. Help.

There seems to be a problem with this latest version if the Qt files included in Scrivener are not the same as the Qt files in KDE. This seems to be the case for both Arch Linux and the latest version of Mint KDE. It just wont run. It works fine in Mint Cinnamon except that there is no spell checker. That needs enough of KDE to be added to Cinnamon for the Qt file problem to occur again.
My solution was, dare I say it, to abandon Linux and go back to Win 7. Pretty Drastic. But I do want a version of Scrivener that includes a spell check in English English.

On Debian wheezy/jessie:

aptitude install libgstreamer-plugins-base0.10-0:i386 libstdc++6:i386 libfontconfig1:i386 libxext6:i386 libxrender1:i386

To install on Fedora 20 x64 (probably would work with Centos and Redhat as well.)

After enabling rpmfusion, you can run, then use yum whatprovides for each error, installing the package suggested with yum install.

After installing these below, the provided worked fine.

sudo yum install gstreamer-plugins-base-0.10.36-6.fc20.i686
sudo yum install glib2-2.38.2-2.fc20.i686
sudo yum install libXext-1.3.2-2.fc20.i686
sudo yum install fontconfig-2.11.0-1.fc20.i686
sudo yum install libstdc+±4.8.2-7.fc20.i686
sudo yum install glibc.i686
And libXrender from …


If you are having problems with KDE, you can (or used to be able to at least) switch your desktop easily with Mint. Go into the software app, install “gnome-desktop” then logout, then look for the session icon at the bottom and select gnome. Then try to run scrivener again.

Mint isn’t exactly the most stable distro to in terms of development. Don’t get me wrong, it’s very “stable”, but they are now running there own desktop manager and a number of applications do not run correctly. For compatability with scrivener and for beta testing purposes if you don’t have much experience solving dependancy errors on Linux I would stick to Ubuntu 32 bit, I have scrivener beta working fine on the latest Fedora v20 x64 which I prefer.


thanks Adam, this worked like a charm!

Thanks amorey. Dependencies are not the problem. I had the older version running Ok on KDE in Arch Linux 64. The problem lies in the fact that the latest version of Scrivener comes with its own Qt libraries. These are no the same as the versions in up to date KDE distros such as Arch or Mint. I can get it to run in Mint Cinnamon but not with a working spell checker. I gave up trying to add enough stuff to get that working.

this also works on Ubuntu “saucy”

Easy install on Linux Mint Debian Edition (LMDE), running on a 32-bit Intel Dual Core T2500 CPU laptop.

Downloaded the deb package and ran the standard installer on it. All dependencies were found and it installed without a hitch.

Scrivener runs fine. The only thing I’ve noticed so far is the font size of my text. Under Windows I have the scaling set to 130 percent. To achieve the same scale on screen in Linux I have to reduce scaling to about 100 percent.

Spell check? I think I saw mention of a solution earlier in this thread… will give it a try.

I’ll report back with an update when I have more to add :wink:

Spell check solved, thanks to a tip from TaftSinjin in this thread, [url]].

Installed libaspell-dev from the Linux Mint Software Manager.

Closed Scrivener and restarted it.

Bingo! I now have a working spell checker. :smiley:

How can I change menu language on Russian under Xubuntu 13.10-64 ?

Thanks for helping us working on this very good application, but is it possible to have it in french? It seems to have it possible in settings, but it doesn’t change anything for me.

It’s a day before this version of beta is supposed to expire, but I’m already getting a tiiiiny window that says “Beta Expi” in the title bar every time I try to open Scrivener. The body of the window reads:

“This Sc

The only option is to press “okay.” I’m assuming Expi is “expired” and that the window text is telling me to find the most recent beta edition, which I don’t see anywhere. Is it available yet?

I’ve also ran into that problem, starting yesterday.

What would be the proper way to report bugs and whatnot? :slight_smile:

I’d just a look at Scrivener. No problems at all with installation (here: Fedora 20 with KDE 4.12). But it’s not possible to change the UI language (here: to German). It sticks to English. :confused:

I’m also very interested in Scrivener for Linux. Being able to run the Linux version with the Windows-License is quite a good idea, I think.

Dear Scrivener team, are there any near-future plans for Scrivener becoming “official” on Linux?

I am using the latest version of Ubuntu, 14.04. I have been able to run previous versions of Scrivener. But when I try to run the current beta, I get the following message in the terminal:

error while loading shared libraries: cannot open shared object file: No such file or directory

I wasn’t able to find this shared library through the Ubuntu Software Center. Any recommendations on what I can do?


Steve Shaviro