Lost ability to open TexShop Source screen after compiling with Scrivener

I use TexShop v4.44 with Scrivener 3.1.5 for Mac with Catalina 10.15.6 OS.

For the longest time, whenever I compiled Scrivener, the TexShop Source screen would pop-up automatically after Scrivener finished compiling, allowing me to begin Typesetting by simply clicking on ‘Typeset’ in the upper-left corner of the TexShop Source screen. The TexShop Source screen was immediately available front-and-center with the just-compiled code from Scrivener, so no searching for the corresponding “.tex” file was needed.

That changed a short while ago, and although it is not a major issue, it would be nice to have the TexShop Source screen pop-up available front-and-center again immediately after compiling with Scrivener to avoid having to use the Finder to search for the “.tex” file.

I’ve searched the 'net and LL but have not found the Scrivener and/or TexShop setting that I need to change to get back to compiling-in-Scrivener-then-Typeset-in-TexShop directly. The answer might be obvious, but I’m puzzled.

Any thoughts or comments would be appreciated.


In the last step in the Compile command, where it asks for the file name, there’s a check box at the bottom to open the output file in the application of your choice. Is that what you’re looking for?


Hi Katherine,

That did it! Thank you … :slight_smile:

I must have blown by that checkbox a thousand times on my way to compiling. As I suspected, the answer was right in front of me the whole time. :blush:

So simple, I can’t thank you enough …
:smiley: :smiley: :smiley: :smiley:

A post was split to a new topic: TeXShop typesetting tab blanks out when used