Mac Preferences keyboard shortcuts vs Scrivener keyboard shortcuts

I’m using Scrivener to build web page copy. That requires loads of repeated formatting, hence the need for keyboard shortcuts.

While the addition of keyboard shortcuts to Scrivener is welcome, there are only nine. My most basic set of formatting shortcuts is 13. My expanded set has 8 more, for a total of 21.

The alternative is what I did using Scrivener 2: add keyboard shortcuts to Mac Preferences. That worked perfectly.

However, following the advice in the Upgrade Guide, I decided to go for a clean slate rather than import the old Preferences from v2. Of course, the old Mac shortcuts no longer worked, so I deleted them all and rebuilt them for v3.

They don’t work. Perhaps the Mac Preferences have a ghost in there that prevents the new shortcuts from accessing v3.

An additional issue is that I could get Mac Preference keyboard shortcuts to paste in characters. Scrivener keyboard shortcuts call Styles only. For example, I have a standard indented bullet used hundreds of times. On Mac, I created a shortcut that included the bullet, along with character and paragraph formatting. As far as I can determine from Scrivener, I have to choose the bullet from the menu, then apply the Style. Two steps instead of one.

So, it seems I need to go back to Mac Preferences shortcuts. But how to make them work?

NOTE: I had this as a private support ticket, but, apart from the auto-reply, got no response in a week. Now the post seems to have vanished from the forums altogether.

Thanks for the help!

For me, macOS keyboard shortcuts work fine.

Do you still have Scrivener 2 installed on your Mac, as well as Scrivener 3?

If yes, it might be that the new shortcuts are only referencing the old Scrivener 2 installation.

Slàinte mhòr.

No. I deleted Scrivener 2.

That’s why I’m wondering if there’s some plist or other phantom file left over from v2.

Okay. I did have some misnaming conflicts when I ran both versions for a short while, so good to get that possibility out of the way.

Could you share a screenshot showing a shortcut that isn’t working?

I believe 2 and 3 don’t share any plists, but hopefully someone from L&L will be able to confirm that. I wonder, as it is handled at a system level, if a reboot or a reset of PRAM might help. Do the shortcuts work in another user account?

Slàinte mhòr.

I’ve attached a screen shot of the Preferences list of Application shortcuts for Scrivener. None of them work.

I’d already done a reboot, but did it a second time to no avail. So I then zapped the PRAM. No luck there either.

As for phantom files… I don’t know where the L&L support people are. I contacted them directly 8 days ago and have not heard back except the auto-reply acknowledging that they’d received the mail.

Custom keyboard shortcuts work for existing menu items. Heading 1 and Heading 2 are in the Styles Panel. Have you created named styles for all your other items? If yes, this advice from the developer should apply in your case: … 52#p269452

I created a style called Red Font and gave it a shortcut in System Preferences. It works, showing up in the styles menu.

So long as you have (1) created the various styles and (2) not got a conflict in terms of the key combinations used, your shortcuts should work. Are your styles listed in the styles menu, as shown above?

With regard to L&L replying, do you filter your mail? Anything from them in a filtered / spam folder?

Slàinte mhòr.

Hi JoRo,

Thanks for the fast turnaround.

  1. I created named Styles for all the shortcuts and they all appear in the Styles menu.

1.1 Type 1: Using Redefine Style From Selection, I edited some existing Scrivener Styles (Heading 1, Heading 2…)
1.2 Type 2: Using New Style From Selection, I created new Styles. Some of these (Bullet 1, Bullet 2…) included a character as well as character and paragraph formats.

All the Styles appear in the menu and all of the Type 1 work when selected from there. So, it’s the shortcuts themselves that don’t work.

The Type 2 Styles that include a character DO NOT reproduce the character. However, Keith explained here how to create a Mac Preferences shortcut for a standard bullet: … hp?t=51936 … I created it, but (of course) the shortcut still doesn’t work.

  1. I don’t believe I have any shortcut conflicts. For example, the shortcut for Bullet 1 etc. are the exact same as used successfully with Scrivener 2. These were deleted from the Mac Preferences and rebuilt for Scrivener 3.

  2. I located the correspondence with L&L. Sure enough, after 8 days there’s no contributions in there except mine. I sent another message today and again got the auto-responder. I hope someone pays attention. During an intense week of composition and editing, I’ve been slowed down by manual formatting.


Hello eric.

I can see how this must be very frustrating for you. Out of curiosity, if you create a shortcut for a standard menu item (such as the one in my first post for “Show Titles in Scrivenings”) does that work? Trying to figure out if this is an issue limited to styles or to the whole of the Scrivener interface.

And do the shortcuts fail to work in all projects or in one project only? (I assume all projects.) Have you tried a different user account as a test?

Hope someone smarter than me can come up with a solution.

Slàinte mhòr.

Hi JoRo,

Good test suggestions!

I created a shortcut for the standard menu item “Corkboard Only”. It didn’t work, so it seems that the problem is with the entirety of Scrivener, not just Styles or Formats.

I tried the shortcuts on a different project. Still no result.

I don’t have another user account to try that test.

On the upside, L&L got back to me with a detailed response. The main suggestion was to try a full path in the menu ("Format->Style->Font Red. Alas… that didn’t work either.


Hi eric.

Do shortcuts for other apps work? For example, if you create a custom shortcut for a TextEdit menu command, does it work? That would help to see if the problem is with the OS or just with Scrivener.

If you wanted to, you could create another user account, test the issue, and then delete the account to recover space.

We really need KB or Ioa to look at this. Hope they read the thread.

Slàinte mhòr.

Do regular shortcuts work, such as CMD F to open the Find panel or CTRL S to open the Styles panel? (If CMD F works but CTRL S doesn’t, perhaps your CTRL key has an issue … all of your custom shortcuts use CTRL.)

Slàinte mhòr.

Hello JoRo,

Both CMD-F and CTL-S work.

I created a new shortcut for MS Word. It worked.

Styles shortcuts entered into Scrivener’s own 9 item shortcut list also work.

The problem seems to be narrowed to Mac Preferences custom shortcuts in Scrivener alone.

loa is now working on this issue too… discovered it through our thread, then found my earlier private mails. No working solution just yet.


Hello eric.

Some good, I think, diagnostic steps at least.

Ioa is super smart. Hope he can find a solution for you. Please share, if he does: good to learn.

Slàinte mhòr.

o/t but @JoRo how are you finding the Mojave beta? screenshots are gorgeous

Biggest aesthetic change is dark mode. Expected to hate it, but it has grown on me, and I now prefer it.

There have been a few niggles along the way, but the last couple of betas have been very good, save for a little stuttering with videos in Safari. The revamped screenshot tools work well, and speed and stability have been increasingly impressive: better than High Sierra. It’s an iterative OS, yet just about different enough to make High Sierra feel a little behind the times.

The ported iOS apps (News, Stocks, and Voice Memos) don’t bring a great deal to the party, particularly for me in relation to the News app as I don’t follow news events, other than picking up tidbits from family and friends. I have tried News. It was very flaky in the early builds, although it is now far more usable for those who are so inclined. A lot of content leaks back out to Safari, so it feels rather bitty to me.

Scrivener has run well throughout, and I am looking forward to seeing Scrivener cloaked in charcoal and black hues.

All in, a good step forward, with more to come.

Slàinte mhòr.

The integration of Markup with screenshots is pretty nice. I’ve noticed you’ve been getting good use out of that! That was a long time overdue and it’s good to see these two mechanisms come together finally. My main grumble with how screenshots work now is that the file doesn’t get written to the disk until you ignore the thumbnail in the corner of the screen for a while. I’m used to just immediately opening the most recent screenshot file in my image editor—and now I have to wait. I’ve found myself tending toward using the clipboard instead of files. At least that goes right to the clipboard immediately.

Dark Mode is fun, and I think I will like it more as time goes by and more tools that would work well in it adopt it. Right now I barely see it because I make very seldom use of Apple’s software, and much of what I do use from third-party developers is either still in beta or otherwise hasn’t yet addressed Dark Mode at all. So it’s a very spotty experience right now. And of course as a daily and constant Scrivener user, until that UI is done for that, 99% of what I see of Dark Mode will be the menu bar—and I’ve been using the dark menu bar option ever since they introduced it. So nothing new there. :slight_smile:

That all aside, my chief complaint with 10.14, and what will keep me from adopting the system fully until Apple gets past the teething problems with it, is the excessive granting of permissions. I make heavy use of tools that cooperate with other tools. Text expanders, macro software, device input augmentation, hand-coded scripts, command-line tools that interface with the GUI layer, etc. The level of harassment I got from just one of those tools was over the top comedic in how awful it was—it was beyond even a parody of how bad Windows was when it was at its worst in this regard. I was clicking “OK” buttons in probably close to a hundred dialogue boxes while the system was still booting up for the first time! They were stacked so thickly on the screen that the accumulated dropshadow was so black I might as well have already been in Dark Mode.

I still can’t get everything working properly (though that may be beta problems), like unzipping a file using a third-party launcher with a third-party compression tool. I’m sure somewhere I was supposed to authorise LaunchBar to System Events and System Events to Keka and Keka to Finder to get what should be a simple task of unzipping a file done… but it seems that whatever mechanism is being used, it doesn’t trigger the usual flurry of dialogue boxes and just silently fails instead. It’s not just power user stuff either. Compile PDF from Scrivener to Skim and it will throw a permissions error, because I guess having your default PDF reader load a PDF is unsafe now. I even got an error from an AppleScript trying to do what AppleScript does.

I sincerely wish there was an, “Apple, stay out of it and let me use my computer like a computer” checkbox somewhere that switched that whole level of security theatre off for good. I’d even be satisified with it being hidden, goodness knows I already have a huge checklist of hidden preferences and system daemons I shut down, that I work through on a clean install; what’s one more?

So yeah, for me I’ll be sticking to my usual policy of waiting about a year to install the latest OS, in the hope that some of that simmers down in response to negative feedback.

But to stray back on topic, the shortcuts thing has turned out to be a pretty weird problem. Haven’t figured it out yet, but somehow macOS has its wires crossed over the definition of “Scrivener”, so the shortcuts don’t end up being assigned where they should. Not your usual problem for sure.

Hey JoRo,

You’re right, Ioa knows his stuff. We jumped through a bunch of hoops trying to bottle the ghost in the machine.

In the end it was (of course) Apple’s fault. Turns out the Mac Preferences wouldn’t purge Scrivener 2, even if all traces of it were deep cleaned using Onyx “Maintenance”.

Instead, in the Mac Preferences, the v2 icon still showed. So I deleted Scrivener (the app in the shortcuts list, not just the shortcuts). Then a Restart. This time, the v3 icon showed in the Application list. I rebuilt the shortcuts and they now work.

Ioa mentioned that the new Styles method doesn’t allow inclusion of a character (such as a bullet) in the style, In v2, styles could be a text and format mashup. With the new Styles, it’s formats only. So my much-loved bullet shortcut will have to be a two-step process: Opt-8 for the bullet and the indented paragraph format on a shortcut.

Thanks for the help. It’s been a mission.


Hi eric

Very obscure. Haven’t heard of anyone else having the same issue. Glad you and Ioa managed to find a solution. Sorry if I wasted any of your time with ineffective ideas.

Slàinte mhòr.

I use macOS coloured in a delicate hue of vanilla. I don’t have the power needs you have, so I haven’t run into a permissions logjam – thankfully. I had to work on a MPB running High Sierra last night for an hour or so, and I found myself missing Mojave’s overall look and feel. I do like Stacks – forgot to mention them originally.

  1. I feel severely chastised…though a screenshot can say so much. [smile]

  2. Maybe I have misunderstood, but the thumbnail wait can be turned off using CMD SHIFT 5 > Options > Show Floating Thumbnail [remove the tick]. Pretty sure you already know this and that I have misread your post several times.

  3. Thanks for helping to resolve this issue – I was hoping you or Keith would see the thread and respond. Appears to have been a very specific glitch, given that other users haven’t seemingly run into the same brick wall, at least not on the forums.

Here’s a screenshot for you. I be brave. :wink:

Slàinte mhòr.

Here is another thread that seems to be describing the same problem. It looks like the way System Preferences works is by the name of the software alone, rather than the internal ID, so depending on how you transition to v3 it can end up getting confused (in this case, it was writing shortcuts to both the v2 and v3 plist files, even if v2 wasn’t installed—it was creating a new v2 plist file with just the shortcuts stored in it!). I’ve never run into it myself because I only keep the latest version as “Scrivener”, and keep older copies around as “Scrivener-29” or whatever.

As for the screenshot thumbnail, the main problem with that option is that turning off the thumbnail opts out of Markup integration as best I can tell. What would be nice is if that mechanism wrote to the disk as well as showing the thumbnail so that you could have both options available. I guess the problem is that Markup was always something that operated on a virtual copy of the image in memory rather than directly to the disk. Seeing as how it got started off as a way of editing images embedded in other views (like Mail), it makes sense.