Main toolbar got right aligned


I have no clue how it happened. One day it was fine another it wasn’t. Don’t know how to give it back left alignment.

This is an easy one. Go to View->Customize Toolbars… and left click
Screenshot 2022-01-12 161753

Once there, look for < GAP > and either move it back left or adjust it down to where you want it.

Click Apply and verify that is how you want it. If it is, click OK. If you need to, you can click on Restore Defaults - any customization will be lost.

2 Likes

This seems to be a relatively rare bug. It happened to me and another poster, as reported in this thread. My guess it that Scrivener’s internal preferences become corrupted. Currently my toolbar is fine, but it does occasionally still go wonky.

Yeah, that’s the problem. L&L is aware of the bug, as per the thread above, but I was never able to provide them a sequence of steps to recreate it–so it’s going to be tricky for them to fix it.

Hopefully @Jestar’s suggestion works for you. I suspect it won’t, as tweaking the toolbar by adding or removing GAPs never fixed it for me, but if it does for you–wonderful! If it doesn’t, then try the workarounds suggested below.

Workaround “Quick Fix” - If you haven’t made too many customizations to your toolbars, then try resetting your toolbars to the defaults (View > Customize Toolbars > Restore Defaults). If that fixes it–wonderful!

Workaround “Nuclear Option” - If the Quick Fix doesn’t fix it and/or you’ve made too many customizations to your toolbars to want to reimplement them manually–this is the case with me–then try the steps below:

  1. Save current preferences (File > Options > Manage > Save Options to File)
  2. Reset preferences to default (File > Options > press Defaults button)
  3. Reset toolbars to default (View > Customize Toolbars > Restore Defaults)
  4. Close and restart Scrivener program
  5. Load saved preferences from step #1 (File > Options > Manage > Load Options from File)
  6. Close and restart Scrivener program

The Nuclear Option usually fixes the toolbar spacing bug for me. My theory is that the process of resetting the preferences does away with the corruption.

Hopefully one of the workarounds in this thread helps you with this.

Best,
Jim

2 Likes

@Jestar
Thanks for sugestion. Adding gaps in middle or to the right side can help to some extent but it doesn’t really change the alignment though.

@JimRac
I had to go with “nuclear option” and it did help. Fortunately I didn’t heavily custimise anything.
Thanks!

2 Likes

I wish I knew why that happened (your initial problem). I remember it happened to me back in the beta days, but hasn’t been an issue since. I was hoping that my method first run would have corrected it, but I’m glad the full nuke correction worked for you. If you haven’t already, you may want to save the options (File->Options then Manage->Save options to file) might help if it rears its ugly head again.

2 Likes

This is great advice!

1 Like

I’ve been having this same issue basically since scrivener 3 came out, and nothing fixes it. Using your fix works temporarily, but step number 5 (loading saved preferences) makes the weird left side gap return immediately (even when it’s saved after a fresh nuclear option and it’s looking good). And after I’ve fixed it, within a couple of days, the left side gaps are back. Or as soon as I opened a new scrivener project or restart the program.

Does anyone have any ideas?