[LH5061] Toolbar spacing bug

Hi! I have two different projects opened in scrivener and the toolbar on the first project is acting all wonky. I don’t know if it’s bugged out or a button I’ve clicked that’s done it, but I want it back the way it was.

Toolbar 1 (bugged) has blank space above the search: i.imgur.com/w6EL0OF.png
Toolbar 2 (how I want it) has the options right above: i.imgur.com/O3P6zyV.png

How can I fix this?

More complete screenshots would be more useful.

I’m seeing this bug as well. There is a space like a GAP added to the left of the Binder View icon in the Main Toolbar, but there is no GAP specified in the Customize Toolbar pane.

It occurs after I modify the toolbars. Sometimes I can modify the toolbars without it happening, sometimes I can’t. Once the bug appears in one project, it eventually appears in all projects.

The only way that I’ve found to ‘fix’ it is to apply the default theme and then reapply a saved options file from prior to the toolbar changes.

I suspect that the toolbar modification process corrupts the toolbar settings, perhaps introducing a GAP where the isn’t one specified during the Customize Toolbar pane. Just a guess.

Attached is a screenshot and a Tutorial project exhibiting the bug. I’ve also attached the Options file, in case that helps.


Tutorial-bak-2021-05-24T09-36.zip (3.8 MB)

V3 Prefs Courier Prime SOLARIZED DARK v20.zip (12.7 KB)

For anyone else experiencing this, I think I’ve found a workaround.

I edited the .prefs file attached to my post above, by completely removing the very long toolbar config line at the end, that begins with Appearance\ToolBarsLayout=.

When that line is gone, the Backups\location= line is followed by the TextEditing\Colors\Annotation= line.

After loading the edited file via Manage > Load Options from File and pressing okay, the toolbar returned to normal.


The fix didn’t work. The space in the toolbar is back.

@JimRac Thanks for the sample preference file; I’m able to see the issue with that, and hopefully it will be enough for the devs to track down and fix the quirk.

If anyone happens to find reliable steps for reproducing the issue from scratch, please share!

This started happening after I added 8x or so GAPS to the end of the Formatting toolbar to get the icons properly spaced. It wasn’t an immediate thing–I added the GAPS, and then at some point afterwards, might have been days, the weird space began to appear. The GAPS may have nothing to do with it, but since it was a GAP that was added to the Main toolbar, perhaps somehow the sequence of GAPS at the end of formatting contributed?

Anyway, thanks for your help, and glad you could see the issue in the .prefs file!


1 week ago I reconfigured the toolbars from their default state–and dropped the extra gaps mentioned in my post above. When I was done, the mysterious gap in the main toolbar was gone.

I haven’t made any settings changes whatsoever since then, and today the gap is back. It just materialized all on it’s own. Weird.

Hi @MimeticMouton,

I think I’ve found a way to reliably reproduce this issue.

Open the attached project. Reset Options & Themes.scriv.zip (12.0 KB)

ETA: I realize it may be necessary to have the .prefs for the attached project. Here it is:
V3 Prefs Courier Prime DEFAULT v25.zip (13.2 KB)

The main toolbar has no gap on the left.

On the Main Toolbar, add the Collections button to the right of the Search button. Afterward, Collections should be the third button from the left. The main toolbar still has no gap on the left.

Close & reopen the project. The gap will appear. on the left side of the main toolbar.

Hopefully this is useful to the devs.


1 Like

@MimeticMouton I’ve updated my TenderApp ticket with a link to my post above.

@Vincent_Vincent Thanks for the workaround! When I have time I will play around with it, but currently the Collections button is not worth the effort. :exploding_head:


Are you sure it is just the collection button ?
Did you experiment with other buttons not present by default ?

I can’t tell (since I customized my toolbar way too long ago), but perhaps…
I myself added a bunch of buttons to it.

(Note from my screenshot that the bug chose not to this time manifest itself… – the thing is random.)

But one way or another, the fix I proposed is failproof. (I’ve been using it without a problem for quite a long while now…)
. . . . . . . .

Else: probably unrelated (or maybe perhaps?), but speaking of things not keeping their position/dimension in the toolbar, there is another issue, this time with the format toolbar, where the style dropdown list grows fantastically (and totally uselessly) wide under unspecified conditions.
I can force it to happen by creating a style with a very long name, then select it, but it happens now and then on its own. Even without long style names.

I’ve been using the same toolbar layout for around a year now. It’s reasonably stable, by which I mean it’s only about every month or so that Scrivener decides on its own to add extra spaces to the left. But it takes me less than 5 minutes to fix this. (Reset Toolbars & Options to defaults, reboot Scrivener, reload my customized Options & Themes, reboot Scrivener. ) Not a big deal.

I’ve recently rediscovered how useful “arbitrary” collections can be and have incorporated them into my workflow. (For keeping To Do lists, or for temporarily gathering docs that I refer to while working on a particular sequence.) I didn’t even know there was a Collections button until yesterday, so I thought I’d add it to the toolbar. When this consistently caused the spacing bug to arise, it seemed like a good idea to share a sample project with L&L, as Jennifer (@MimeticMouton) had requested “reliable steps” to reproduce it.

I suspect that any new button on the left would have caused the same problem. Also, maybe the problem won’t happen if I place the Collections button somewhere else on the toolbar. But I’m fine with Alt + Shift + C until I get time to play with your workaround.


I’ve added a .prefs file to my post above, in case that’s helpful to the Devs.


What might be of importance: After installing Scriv, the GROUP triple icon was crunched together, making the 3 icons overlap each other. After I bought and registered the trial, it began to widen somewhat. However, it’s still not the way it should be, a small overlap remains.

For several days, I was able to reproduce the bug by increasing the icon size (height and icon to 30px and 28px respectively) on a default install, then inserting a GAP at the very front (top left). But not anymore.

Like Vincent-Vincent says, the bug appears rather randomly. I don’t always get to see it. Even though I don’t mess with the toolbars at all anymore.

The work-around posted by JimRac has no effect in my case.
I am on Windows 11.