Misspelled Dictionary Word English (United States)

I’m using Scrivener for Windows, version 1.0.3

The word “not” is misspelled in the English (United States) dictionary. Auto-correct changes “not” to “nto.” I can undo the change by hitting CTRL + z, but that interrupts the flow of my writing. Not huge, but annoying.

Is there a way to edit the dictionary, and correct misspellings?

ETA: “not” isn’t the only word that gets mangled by the spell check. The word “state” gets changed to “satte” while I’m typing the word (!). I have turned off “Check Spelling” and “Correct Spelling errors” from the Tools --> Option menu. Yet, Scrivener continues to change the spelling of words. This is new for me. I was using the NaNoWriMo version until yesterday, and I did not encounter this issue until I began using version 1.0.3.

I tried adding the words as Substitutions. After doing this, as I type in the word “state” it changes to “satte” which then changes back to state after I’m done entering the word. Nothing I’ve done changes “nto” back into “not.”

The dictionary and such are all part of Aspell; Scrivener doesn’t handle this directly. I’m not able to produce either of the cases you’re seeing, though (not and state), using auto-correct and the English(US) dictionary. Certainly with the “Correct spelling errors” turned off, Scrivener wouldn’t be adjusting your words. Do you have any other substitutions or text-expanders turned on somewhere that might be affecting this?

It’s also possible you might you have added these accidentally to the word list by using “learn spelling”, although again this should only affect things if the “correct spelling” is turned on. Try checking your personal word list in the Auto-Correction tab of Tools > Options… just to make sure the misspellings didn’t end up there–if you see them, just delete them.

Hi Mimetic Mouton.

But, that is exactly what it is doing. I just checked my settings again. “Check spelling as you type” and “Check spelling errors as you type” are both unchecked. Scrivener is still changing “not” to “nto,” and “state” to “satte” and then back to “state” as I type. I just discovered that any word beginning with the letters s-t-a-r (stark, startle, star, etc.) is changed to “satr”. I just tried purposely misspelling another word, the word “direction” and Scrivener ignored the incorrect spelling. But, “notable” gets changed to “noatble.” I don’t know when Scrivener is going to change a correctly spelled word into something odd.

I entered “satte (to state)” and “nto (to not)” in Edit substitutions. Satte corrects to back to state although it takes three steps (state → satte → state), however nto does not correct back to “not”.

Here is a screen shot of my auto-correction tab settings.

I don’t know what this means. If it refers to Scrivener, I don’t think I have other substitutions of text-expanders someplace. If it refers to another program, I don’t have a text-expander or substitution program. I don’t know what those are.

I just checked my personal word list. “State” “not” “star” and “notable” nor their variations, are on personal word list.

I love Scrivener’s organizational abilities, however, I’m getting frustrated with this part of the word processing aspect. :neutral_face:

Soverywrite, I’m not sure what text expanders are either but I think by substitutions MM is referring to the “Enable additional substitutions” check box at the bottom left of your screen shot (I had to scroll the picture down to see it). If those words you are seeing pop up somehow found their way into your “substitutions” list, that is how the feature would function (including quirky fixes, if there are conflicts). I can’t imagine how, if not done intentionally, but maybe those words got entered into the substitutions list without you being aware. It’s worth checking. To do that you will just click on the large horizontal button at the bottom of that same window in your picture. The button is titled, “Edit Substitutions…” and once in the resulting window you can view, add and remove words to be substituted (including leaving words on the list but deactivating them with yet more check boxes). I believe the idea behind substitutions is to automate and streamline time consuming character combinations and also to catch customized, commonly misspelled words not preset to be caught by the spell check dictionary. I hope this helps.

One other thing, while that advice may or may not help you to determine what’s going on, it may not help to eliminate associated problems entirely. I have been seeking help on a similar problem in another post (here: [url]Auto-correction substitution - curious behavior]) that I am frustratingly getting no responses to. Your issue seems to have a component similar to the problem I’ve experienced.

The difference is that I have deliberately entered words to be substituted but the feature is taking things too far. Scrivener is searching for words on the substitutions list even if they are contained within other words! For example, in the substitutions list, to make up for a common typing error, I entered “id” to be substituted with “I’d,” only now when I type “hide” Scrivener changes it to “HI’de” (and so on with any word containing that combination). Other words are reacting the same way like “cant” requested to change to “can’t” altering “significant” to “significan’t.” Maddening and my end sollution (you’d have to read the post) was to deselect those words from the list and forego the feature for those words. (No, I wouldn’t care for some cheese with my whine because this is the bug hunt forum after all :mrgreen: .)

Anyway, I hope the advice leads you to an answer and I don’t mean to snuff out your problem by bringing mine up, especially if they are unrelated. I just noticed a bit of similarity so thought I would mention it.

Hi Syclone.

Thanks for the suggestion. I may not have worded it correctly, but I did mention in my second post that I checked my personal word list. None of the problem words, nor their variations, are on my personal word list. :slight_smile:

Our problems seem to have a similarity, as both involve the spelling/spell checking aspect of the program. However, I understand nothing about programming. Our issues could be apples and oranges for all I know. :wink:

The Scrivener folks have been very responsive, and helpful. So, I’m going to wait for a suggestion about clearing up the problem. Meanwhile, Scrivener’s organizational capabilities lure me in, while the problems with the spelling (word processor issue?) makes me nuts. I building up a dread of typing words onto Scrivener. For now, I’m using MS Word again, because I was losing some writing time, but more importantly, I was losing my train of thought.

Hey again, this is probably just a matter of semantics but I’m only asking again to be sure. Did you mean “personal word list” or “substitution” list? If I’m not mistaken, they serve different functions is why I’m wanting to be clear. If I understand things correctly, the personal word list is used by the spell/auto-spell check feature (which your screen shot demonstrated was turned off) while the substitutions list is used by the substitutions feature (which your screen shot demonstrated was turned on). They are different functions.

Hello syclone.

I’ve been thinking (cue ominous music).

None of the words I mentioned in my previous post are on my personal word list, nor with the exception of my attempt to correct satte and nto, on the substitution list.

I did not add the problem words to the personal, or substitution, word lists, either intentionally or unintentionally. This morning I began to look at what words are on my personal, and substitution, word lists. My personal word list contains the names of characters, and critters, from my novel. Nothing relevant. My substitution list had some interesting entries.

I did not have the word “state,” any words containing the letters s-t-a-r, nor the word “not.” What I did have on my substitution list were three words that I often transpose letters of when I’m typing – “at,” “to,” and “so.” For example, I often type “ot” instead of “to.” I put that on the substitution list, but instead of correcting only the two letter word “ot”, it was switching any occurrence of the letters “ot.” Every appearance of “ot” became “to,” meaning “not” became “nto.” Ditto for “state” becoming “satte” – “ta” to “at.” In fact, all of the “s-t-a-r” words being muddled were due to my having the “ta” to “at” substitution.

So, my issue is the same as your issue, syclone. When engaged and specific entries on the substitution list are checked, Scrivener corrects based on the sequence of letters and characters, rather than on a whole word. :slight_smile:

Thanks for your input, syclone! You got me thinking. I understand now that the problem I’m having isn’t related to the dictionary, but to the identification of letters as a sequence, rather than a whole word. The dictionary is functioning properly. Anything entered as a substitution is switched whenever that sequence of letters occurs, whether it is an entire word, or part of a word.

Soverywrite, it sounds like exactly what I’ve been reporting. While I regret that you are experiencing the trouble I am, on some level it is nice to know that I am not alone (meaning, it’s not just me or my machine). On my other related post ([url]Auto-correction substitution - curious behavior]), MM replied last night with the following:

I did respond that I’ve tried to add spaces before and after words in the list (trying to force it to find whole words only) but it did not help. For now, I’ve just had to remove words like “ot,” “hte,” “od,” “id,” etcetera from the list and catch them manuall in a spell check.

Ah, great investigatory work, both of you! Thanks, syclone, for bringing this up. So yes, it is the same issue, and as I said in the other post, I do have a bug report out with it for Lee, so we’ll just have to see what he’s able to come up with. In the meantime, Soverywrite, you could try modifying the substitutions to include a space on either side–I know syclone is having trouble with this, but I was able to get it working, so I’d be interested to see if you’re able to get success with that. It’s not a foolproof solution, since there will probably be cases where the substitution doesn’t happen when you want it to, but it should at least prevent it happening in the middle of words as it’s doing now. So for instance, try modifying your substitution of “ta” to “at” to become " ta " replaced by " at ". It should recognize the space then and not substitute “at” for “ta” when “ta” falls inside another word.

Soverywrite, I have just responded to MM under the other topic and wanted to share here as well that the space-before-and-after method indeed works. I had posted above that it was not working for me; however, having gone back and tried again, it worked. I’m not sure how it didn’t work the first time but I apologize for infusing any confusion into the conversation by sharing the flawed results of my test.

So, to be clear, adding " ot " to be replaced with " to " does work for me as well (with the understanding that there could be circumstances whereby such substitutions will do something not desired).

Thanks for the update, syclone. I think with the spaces the concern is less that the substitutions will do something undesired and more that they won’t happen in some desired cases–you won’t end up getting “ot” switched to “to” in the middle of a word, but you might end up with cases where you did want to have “ot” switched and it doesn’t. But if we make the assumption that you’ll probably proof-read before you send your manuscript off, chances are that an occasional unfixed “ot” that you can correct manually will be much less obnoxious while working than a having ever toher word wrongly switched. :slight_smile:

I understand exactly what you mean. :slight_smile:

Using a space before, and after, a word when I enter it on the substitution list limits the changes to the whole word.

Indeed. I’m glad that sotpped. It was leaving me in quite a satte. :wink:

Ha! I see whta you did there. :wink: