New paragraph, why is it double spaced?

I am having a major problem with double spacing when I hit, “Enter,” to begin a new paragraph. For some reason, the program double spaces when I desire it to single space and indent. For instance, when having a character speak, it is proper to use a new paragraph with quotes. This is very inconvenient. Also, I have a single spaced PDF document that I have tried to copy/paste onto Scriviner and it also converts every new paragraph into a double space situation. I can’t believe that there is no way to prevent this. Why should this be so complicated?

My guess is that you are doing something unusual, or trying to push the software into working like you might be accustomed to in another program you’ve used in the past, which is over-complicating things. In its default usage it is quite basic, and not complicated at all. 99% of formatting questions can be found answered by this article in the knowledge base.

Also, I have a single spaced PDF document that I have tried to copy/paste onto Scriviner…

As to that specifically though, most PDF copies as plain-text, not formatted text. PDF isn’t really a document format like RTF or DOCX. Some font settings may come over, but there is zero concept of text editing rudiments like “single spacing”. It’s pixels on a canvas with a simple text-layer you can copy from if it isn’t copy-protected.

Thank you Amber. Let’s forget copy/paste from a PDF for now. I am having a problem within the Scriviner program when I hit, “Enter,” to drop down into a new paragraph that should be indented. It drops down two spaces. Why?

It’s probably easier to describe what is a simple way of doing what you want, rather than guessing at the very large negative space that is the unknown of why X doesn’t do Y.

The link that I gave you describes how to make formatting default, so that it is used in all new documents, and to update any existing documents to use that default (the latter of which you’ll need, as once you change formatting from default it is going to of course just keep using that format forever until you change it—like any word processor would for that matter). I would suggest working through that first, and see where, if anywhere, it doesn’t work as expected. If you let us know where it breaks, and what you did up until that point, it would be easier to help.

The only additional suggestion I would make is to, when instructed to set up a sample paragraph the way you want, visit the Format ▸ Paragraph ▸ submenu, and use both the “Tabs and Indents” and “Line and Paragraph Spacing” panels to set everything up the way you need. As it sounds like these are the two main things you’d like to alter, that’s where I’d start.

Then, to test your settings:

  1. Click on anything in the Binder, “Research” will do.
  2. Press Return to create a new text item.
  3. Click into the main editor, and type in a few lines. It should look how you set things up at this point. Now it’s just a matter of following the instructions to clean up items you’ve already created. That will be a very useful trick to know of going forward, for when pasting stuff in from other sources, as that can get messy.

I got into the editor and have the text the way I want it with paragraph indent/single spacing. the “Make Formatting Default,” button will not illuminate and set it. Clicking on it does nothing.

First, make sure you ain’t wasting your time and that your project is not rather using the formatting from the project’s settings :

Then see that the “before” and “after” paragraph spacing is set to zero, no matter which of both formatting panel your project is using.


Another thing to check to determine if this is a buggy behavior, have the editor show invisibles :

Do you get an extra carriage return after your paragraphs ?

1 Like

Thanks. This example does not look like the one I pulled up from Scriviner/Preferences. I am trying to get the button allowing me to set the defaults to work, but it does not.

This is what I used: * On Windows, use the File ▸ Options... menu command and on the Mac, use Scrivener ▸ Preferences... and then within the Editing pane, click on the Formatting tab.

  • Use the ruler and formatting tools provided to set up the default look of your documents. On the Mac the Aa button on the left of the format bar opens the font options.
  • If you have formatted text in the Editor the way you want the default text to look then you can click the Use Formatting in Current Editor button. The, “Use Formatting in Current Editor” button is not active.

Changing the default formatting will only impact documents created afterwards.

I should say I am using MAC

This is grayed out ? :


Yes. So I am unable to select the formatting I want.

Try creating a blank new project, and see if the issue is still present.
(Create a file within it, type a bit of text, then have a look at the formatting options.)

If the issue is no longer, the problem is with your current project.
If it is still present, the issue is a general issue. (And not necessarily from within Scrivener.)

OK, I’ll try a test run again, but for some reason, when I hit enter to start a new paragraph, or quote, it double spaces.

Do you get an extra carriage return after your paragraphs ?

I did a quick test and it seems to be working now. Thanks for the help. I’ll start the project anew.

Might be something off with importing your PDFs.

Could be. I’ll try that again and if it doesn’t work, I guess I’ll retyping the entire novel. Yikes!

Hmmm… nope.
There are better ways to salvage stuff.

We’ll be here if it ever gets to that.

So, I just started the project over again, chapter one. After I completed the first paragraph and hit enter, it double spaced again… or extra carriage as you put it. I am at my wits end and very frustrated. Keep in mind that I was typing, not trying to copy/paste from PDF. I just don’t get it. The first time I wrote the novel, “The Longest Road, Whole Lotta Love at Live Aid,” I did not have this problem. My second novel, “Cadillac Hubie,” also worked perfectly. When trying to upload the Longest Road document to Barnes & Noble, it states that my original e-pub document has flaws which I would love to clean, but have been unsuccessful at that endeavor, so I thought I’d just do the project over by copy/paste from my PDF of the book that I have. No luck there. I’d even type the whole dang thing over, but even that won’t work with the cursed double spacing between paragraphs… So frustrating, I understand why computers get thrown through window.