No internet connection error when trying to buy or enter license

I’m using the trial version for Windows ( and want to purchase a license. When I click on “Buy Now” or “Enter License” I get a message that says “No Internet Connection.” I do have internet access. And I have tried disabling my firewall (ZoneAlarm) and antivirus software (Avast) but I still get the same message.
Any ideas? Thanks

Same problem was discussed in this post, see if the suggestions help.


Might help to put a sticky post at the top of the Windows forum regarding activation / license problems.

Thanks! I fixed the issue by manually adding the Scrivener application to the program list in my firewall software and allowing it permissions. It wasn’t showing up in the list at all before which is strange. I normally get a pop-up asking me for permission when a new program wants internet access.

We may need to raise this as a bug to be looked it when they get around to reworking the installer – the installer routine may simply not be making the request during installation time to get these rights granted.

EDIT: I’ve changed the tag on this to be Bug.