Not sure if this is a bug ...

In my editing of the long translation, I inserted annotations with questions against bits where issue still remain. I then exported the whole thing and closed down Scrivener, while I formatted the RTF export in Nisus Writer Pro.
I recently opened the Scrivener project again, but found that two of the annotations are messed up in that the code that envelops them is coming out as plain text. I think it is significant that these are the only two annotations that are following text in Chinese. All the other annotations have re-opened as normal.
I attach a screenshot of the current state of the Scrivener project document and of the same bit in the NWP-formatted version.
Has anyone else experienced anything like this? I can send you the .scriv if it would help, Keith.
annotations 2.pdf (25.1 KB)
annotations.pdf (33.4 KB)


I had a similar problem in DevonThink, which uses the same text engine like Scrivener. I think the problem is related to the RTF format which seems to be loose with the end of phrases in East Asian Scripts – or parts of Unicode.

E.g. it rarely changes back to the original font for the alphabet when returning from Chinese or Japanese to German / English.

Perhaps a hint?


Hmm … well, certainly, when I first entered the annotation, the font didn’t change, so I changed it back (Hiragino Kaku Gothic W3 --> Optima) myself; and I’ve just checked and the annotation coding is now in Optima, so I must have selected everything including the coding.
To date, my experience of mixed languages is with Nisus which uses a heavily adapted version of that same text engine. But in that, I mark each block of text according to the language that it is in — a very useful aspect of NWE/NWPro — and haven’t had that problem.
Tell you what, I’ll put a space before those annotations, having made sure that the font of the space is Optima, and then reset them. Then I’ll shut down Scrivener and re-open it later to see if that has solved the problem.
By the way, another niggle with the text engine is that in the absence of any specific font information, or if the font in the original document is not one on the system — and this happens nearly 100% of the time now, since Song, the standard Simplified Chinese font, is incompatible with OS 10.4 — it automatically selects one of the Hiragino fonts, which don’t have the simplified characters, rather than a genuine Chinese font. It then uses Kai for the simplified characters and the result looks ghastly. If I need to keep the Chinese characters in a document, I have to go through the whole thing, changing the font everywhere.
I’ll keep you posted.


your post reminds me on how long I did not use Chinese any more – Jaguar? This sounds a terrible environment to work with, and this is one of the very few cases that I still enjoy having Mellel.

I will try a bit of mixed text with TextEdit here as well and keep you updated from my side. The day is over here, so see you tomorrow,



Yes, what you can see there are the tags that Scrivener inserts into the RTFD stream to know where the annotations are stored. In this case the tags are getting messed up by the preceding Chinese characters. It seems that everywhere there should be a space, the A umlaut character is being inserted before the next character when being rendered to RTFD. This means that upon reopening the file, Scrivener does not recognise the tags and does not convert them back into annotations.


Could you please walk me through recreating this? Perhaps tell me a font that will do this? I don’t have any Chinese installed on my system, so the trouble is in how I reproduce it for testing, you see. I will certainly add it to my list to try to fix, but I may be stabbing in the dark without being able to test.

Thanks and sorry for the inconvenience.

OK, I will try my best, and I think, Mark is still the one with more experience. More via pm to support@blablabla…


Thanks Keith.

It’s late here now, and I’m very tired after a long evening out, so I’ll take this up in the morning. I’ll check the project file which I said I would redo in my earlier post, to see if putting in the space has done the trick. And I’ll have another go at reproducing it on a smaller project that I can send to you.

I’m not sure that I’m more experienced than Maria, but I’ll do what I can to help.


Does this not happen with Japanese too? I don’t think I’m more experienced than you …
I think I’ll also try this out on my old TiBook to see what happens there. Both machines are running 10.4 … this MBP 10.4.9 … I can’t remember if I have updated the TiBook from 10.4.8. But that machine is a slow old plug of a PPC, so it might behave differently.
I just wish I could like Mellel!
The day’s over here too, so I’ll come back to this in the morning.


Yes, but when I started using Modern Chinese and Traditional last night to create a test file, I realised that Chinse input has changed, some input methods just did not work. Chinese was always more difficult to input, somehow it works… I did not have the problem with Japanese fonts in Chinese script (very short sample anyway), I used ITABC and Pinyin.

Mellel is only helpful with 2 scripts, if you combine English with Modern and Traditional Chinese they don’t offer the 3rd language. So after all, no big loss not to like it.

Best, Maria

Good morning!
I always use ITABC … I often think it would be good for me to learn Wubi Hua and to learn to use the composition method on my mobile phone, but, quite simply, the time is not there; at my age, it flies by too quickly. And being here on the mainland, I use Simplified all the time, and currently don’t even have Traditional activated.
Apart from the “no Song” issue, the biggest irk for me is having to change input method to Wubi Xing in order to get Chinese punctuation like the ‘listing comma’, and then change back again to ITABC.
I’ve just reopened the project with the problem … it’s still there with an extra space before the code.
Funny, isn’t it … I feel sorry that I don’t like Mellel, but have no such feelings about disliking Word! But as you say, not liking Mellel is not a big loss …
Right … down to producing a test project I can send Keith.

Maria, and anyone else interested,
I’ve spent a bit of time today playing around with this text and annotations while preparing a small test project based on this text for Keith to have a look at.
What I’ve found is that the original problem seems to result specifically from the combination of the Hiragino Kaku Gothic font in a web-link. STSong and a web-link has a curious effect on apostrophes, but otherwise retains the annotation format; removing the web-link and/or using other standard Chinese fonts (I haven’t tried them all) like Hiragino Mincho Pro or STKaiti has no effect on the annotations.
Weird, eh?


that is interesting, I cannot really imagine how another font could affect the RTF encoding. I will check this … the day after tomorrow. Tomorrow will be the first day after 1 week of national holidays, lots of work… And thanks for reporting!



after all the only conclusion I get is that your font stores an “Ä” instead of a backslash in the RTF, so the Scrivener annotations cannot be verified by Scrivener any more. Did you try another font for the Chinese? You already observed some differences in the fonts. Maybe, STSong is not appropriate any more?

I am looking forward to hear about your ideas,


Yes, I tried various combinations of fonts — Hiragino Kaku Gothic, Hirogino Mincho Pro, STSong, STKai — together with web-link, no web-link. Hiragino Kaku Gothic + web-link throws up the problem, STSong + web-link turns apostrophes into ºØ !
Actually, something I didn’t think about is that those names with web-links to the on-line Buddhist dictionary were put there by the original translator — who will have been using some flavour of W4W and IE — so I wonder if the root of the issue is there. But on the other hand, switching the font to Hiragino Mincho Pro took away the problem. I ought to try and find time to try a text with Chinese web-links myself to see what happens, but I too am now busy as it’s the last day of our 7 day national May Day holiday and it’s back to teaching tomorrow.
I’ll email you the .scriv I sent Keith, so you can have a play with it.