Not working in Wine [ADDRESSED]

Not sure if this qualifies as a bug since I’m not using Windows proper but I thought I’d throw it in here in case anyone on the dev team was interested. Using the latest version of Wine to attempt to run the Scrivener for Windows Beta – install completes but not successfully and the application cannot be launched.

OS: Ubuntu Linux 10.04 LTS
Emulation under: Wine 1.1.42

Ran ScrivenerBeta1.exe via Wine on Ubuntu.
Installation program starts with no problem but completes with attached error.
Running Scrivener Beta from icon in folde does not completed.
Running ps -A in my term window shows that there are no active processes associated with Scrivener.

Actually, thanks for this report. I think another WINE user (on Slackware) got a bit further than you did. They at least had Scrivener running, but couldn’t load projects (so… basically useless). This is good to know. While of course WINE will remain an unsupported usage, it would be nice to be able to say “Yes, that works” to Linux users… and it appears that thus far we cannot.

First off, the current version of wine is 1.3.5. You should be running at least 1.2, if not higher, because there are some significant structural changes.

Secondly, I used winetricks to install vcrun2008 and vcrun6 with it. Also, I had to obtain and put a QtSvg4.dll in the system32 directory. Once I got those installed, I uninstalled scrivener, deleted everything relating to it out of the registry, then reinstalled.

I started a thread here, as well:

Okay, I know WINE is not supported but FYI, all those post install steps will be are as follows:

Addition to Windows PATH - [ScrivenerInstallDirectory]\ASpell
Addition to Windows PATH - [ScrivenerInstallDirectory]\ASpell\bin
Addition to Windows Registry Shared dll ASpell\bin\aspell-15.dll
Addition to Windows Registry Shared dll ASpell\bin\pspell-15.dll
Association of .scrivx extension with Windows registry

That’s it!

Whislt the file association is not critical if you’re happy to open .scrivx file from within a running instance of Scrivener, if you work out how to do the previous 4 steps in WINE - it might just work; however, I know very little about WINE?


I think I got it working. Here’s what I did:

1.) upgrade wine to 1.3.4 or 1.3.5 (1.3.5 is what i got it working on)
2.) use winetricks to install vcrun2008, vcrun6, and quartz.
3.) obtain a QtSvg4.dll and put it into ~/.wine/drive_c/windows/system32 (or wherever this is found on your distro).

Install Scrivener.

Enjoy. :smiley:

I can confirm that Scrivener installs and runs on the following setup:

Ubuntu Linux 10.04
Wine 1.3.5
The steps in winetricks outlined by garpu–seems it is very important to install native quartz
The QtSvg4.dll and QSvg4.dll (running Scrivener at the terminal showed an error indicating both .dll files were needed, so I downloaded and installed both in ~/.wine/drive_c/windows/system32)

Thanks to garpu and the other Linux users for the hints, and to the Scrivener team for releasing their amazing program for Windows!

You guys rock! Thanks for figuring all of this out.

Here’s what I’ve found so far while using Scrivener under Wine on Ubuntu Linux 10.04 (your mileage may vary):

I have been unable to add files by dragging and dropping from Nautilus (that’s not unexpected). Also, I can’t add them from file–>import or right clicking on the folder and choosing Add. This is the case for both text files and media files.

Copy and paste of text from an .rtf file in OpenOffice 3.2 does not work. Copy and paste of text from gedit (plain text editor) does work. The outliner and corkboard features work as expected.

What about you other Linux users? How are things working for you?

I’m impressed :slight_smile:

That totally makes sense that Nautilus drops fail. I’d be pleasantly surprised if they did. The File/Import not working is a little more troublesome. That probably wouldn’t be easily fixed without some focussed attention to what is going on there in that menu. Can you copy and paste from any applications that present rich text at all? gedit indicates paste at some level works, but it would be interesting to see if AbiWord or something else works.

No luck with AbiWord, or FocusWriter (distraction-free editor which will save to the .rtf format), so perhaps importing rich text isn’t working at all. Anyone else find something different?

This may be more of a Wine-related issue, since the Windows “Atlantis” word processor installs under Wine, but sometimes does not accept text to be pasted into documents. Perhaps we’re looking at a problem with the clipboard between Wine programs and Linux?

A further note here–I grabbed a copy of WordPad from my Windows install (I run XP in VirtualBox). Running WordPad under Wine, I’m able to open .rtf files and can copy and paste to and from Scrivener under Wine. So while Linux word processors don’t allow me to copy and paste, a Windows word processor under Wine does. Very strange. :unamused:

Images CAN be added to documents by using Edit–>Insert–>Image from file. This may be a good workaround if you need to keep images handy in your research folder.

File–>Import–>Webpage works, too. So this is another way Linux users can add research materials.

After a lot of experimenting, I made a discovery I’d like to share with fellow Linux users:

Install the dotnet20 package with winetricks and suddenly you CAN use File–>Import–>Files to add images and documents to your project. Imported .rtf files come complete with formatting. Imported images don’t have to be inserted into a document, and appear correctly in the research folder (they appear on an index card in corkboard mode).

Unfortunately, .pdf files don’t seem to import correctly. Neither do .mp3 files. But we’re making progress here adding access to some more usability to Scrivener under Wine, and that’s exciting. :smiley:

Also, at this point copying from an .rtf in AbiWord and using “paste” in Scrivener doesn’t work…but using “paste and match style” DOES work to paste. It doesn’t do a whole lot of “match style”, but hey. We can always format the text once it’s there. :wink:

Installing dotnet20 did fix my import problems, although I had to uninstall the samyak/oriya fonts to do it. Sucks if you need an indic language, I guess…

Just found a problem in wine - File --> Page Setup will crush Scrivener

Anyone else having this problem?

Nope…that works fine for me. What distro and version of wine are you using? Are you running CUPS? (it uses CUPS for printing on the mac version, not sure about windows natively.)

Same result here (Ubuntu 10.04, Wine 1.3.5)

Also, I am sometimes unable to open an existing project from the choices presented at program startup–but it works just fine to double click on the .scrivx files in my file manager (Nautilus). :slight_smile:

How are you faring with your install of Scrivener on Linux so far? Any other hints or issues?

ETA: catalinux, I found a possible solution to your problem. Try installing the CUPS pdf package. Worked for me–hope it will help you, too. :slight_smile:

I had the crash on selecting File–>Page Setup. I’m running CUPS 1.4.3-1ubuntu1.2 on Ubuntu 10.04 and Wine 1.3.5. I’m also running the gutenprint driver from CUPS and ghostscript.

ETA: The crash disappeared after I installed the CUPS pdf package. Maybe you already had CUPS pdf installed, garpu? :slight_smile:

Slackware does things completely differently than Ubuntu. I’m guessing it’s something Ubuntu didn’t have installed by default that Slackware does.

I’m finding that PDF imports look kind of faint, however. Here’s a screenshot of a PDF file I created by importing a PDF. (It’s a random PDF file I had lying around.) I know it was created on a mac (it’s an article of my doctoral chair’s.)

Installing cups-pdf solved the problem :d

aptosid xfce 64 bit, wine 1.3.5 from wine ppa.

Yeah, Slackware and Ubuntu are different creatures! :wink: Are you using Gnome, or KDE, or XFCE, or heck…Enlightenment? I hadn’t thought to mention that I’m using Gnome. Anyway, I have the exact same kind of pathetic rendering for pdf files in Scrivener. I tried closing the Binder and the Inspector so my pdf had the full window. Even zoomed in to 200%, text in the pdf was badly rendered. If I find anything that helps to make the pdf format work better in Scrivener, I’ll post it here–please, you do the same. :smiley: In the meantime, there’s Evince or (even nicer) Okular. Pdf support isn’t a deal-breaker for me.