Often the entire or a part of the format suddenly changes to a link format (blue and underlined) after adding text

Often the entire or a part of the format in a doc or folder suddenly changes to a link format (blue and underlined) after adding text to that folder, doc.

How could one avoid that? Why does it happen? And how could one reverse it easily (not for the real links), in a single step (especially if one does not notice it immediately but later somewhen)?

2 Likes

Could you describe, in terms of what buttons, menu commands and so forth you are using to achieve this result, and what exactly you are clicking on to get from point A to point B? The current description you’ve provided could be interpreted in too many different ways of really know what is going on.

The current description you’ve provided could be interpreted in too many different ways

What are these?

Well, I am afraid, I am not able to. I would say, just copy and paste text or write text under the other text and / or press ENTER or such. All I really know is that suddenly the format of the old text or a part of it becomes the link format. And the one of the new text sometimes or always as well (if I remember it right).

Okay, well if you can find a way to get this to happen in a new blank project that would be great. I’ve never seen such a thing happen before and it doesn’t sound intentional, so I’m not sure how to get to that point.

Are you able to right-click on the link and remove it?

Are questions not answered here generally? Or only special ones?

I’d suggest looking around, if that is a genuine question. Some do, some don’t, but if the question cannot be easily seen by others, it requires further definition in order to be understood.

And if it is bug, which it sounds like it is, then it often requires a great deal of specificity to convey the ingredients to other people.

Or if none of that makes sense: imagine how many posts there would be in this forum about this issue, if everyone who pressed Enter and typed or pasted text ended up with hyperlinks in their document. We’d never hear the end of it. So since it doesn’t seem to be something that pressing Enter all by itself can accomplish, there must be something else involved, something not many people encounter.

I’d suggest looking around, if that is a genuine question. Some do, some don’t, but if the question cannot be easily seen by others, it requires further definition in order to be understood.

Uh, what? Looking around? Genuine? Uh. Sorry, I meant the sentences with such a questionmark.

So obviously I am the only one encountering that. Yes, so it doesn’t seem to make sense to go on looking for the bug. Probably too complicated. Not so bad.

Thank you very much!

Okay. Well if you happen to come across the ingredients needed to see it, or can copy the problem into a sample project that can be shared, I’d be happy to take a look into. Sounds like something worth fixing if it can be!

I’ve seen something like this messing around with Comments. Breaking up a Comment in two left the latter half as a normal blue underlined link…

When I paste or drag & drop links to an item in Scrivener many links get the link format partially only and they do not work then. Is there a way to avoid that?

This happens to me occasionally, exactly as you describe it, but I have never been able to figure out why it happens, or what precedes it.

I think that this tends to happen when I have inserted a hyperlink as the first text in the body of the document (usually, I have a centred, bolded title, but then go into the body of the document, and insert a hyperlink).

Next, I write text, and often - at some point - maybe when I go back to the document after having accessed another document, all of the text in the body of the document (i.e., not the centred, bolded heading) is in hyperlink format (blue, and underlined).

I simply select the text that I want to remove the blue and underline from, right-click and choose ‘remove link’.

This is annoying for me, but given that it is an occasional behaviour, I can put up with it.

1 Like

I simply select the text that I want to remove the blue and underline from, right-click and choose ‘remove link’.

Yes, if there are (many) links among the (a long) text it is quite a lot of (useless) work each time to check the entire text. It happens quite often with me.

If anyone can figure out how to get this to reproduce, I’d love to see it. If you can think of any conditions that you typically use in your project’s settings that are “off standard” that might be a clue. For example, do you use Scrivenings mode all of the time, and with that do you use the option to print the binder title into the editor? Fixed width, page view, does it only happen after reloading the project, etc.?

The consistent condition that I have noticed that seems to cause, or is related, to this is the one I described above, viz., this tends to happen when I have inserted a hyperlink as the first text in the body of the document (usually, I have a centred, bolded title, but then go into the body of the document, and insert a hyperlink).

Next, I write text, and often - at some point - maybe when I go back to the document after having accessed another document, all of the text in the body of the document (i.e., not the centred, bolded heading) is in hyperlink format (blue, and underlined).

This has happened to me on so many occasions (during which I am creating documents in exactly the same way I describe above), that I am sure that - somehow - the attributes of having had a hyperlink in the computer memory somehow stay in memory, and get transferred to non-hyperlinked text.

Why that only becomes visibly apparent when returning to the document after having left it (e.g., closing the document and later re-opening it) is beyond me.

The consistent condition that I have noticed that seems to cause, or is related, to this is the one I described above, viz., this tends to happen when I have inserted a hyperlink as the first text in the body of the document (usually, I have a centred, bolded title, but then go into the body of the document, and insert a hyperlink).

What is the method being used to do so? Are you pasting the link as URL into the text editor plain, and letting the web link auto-detection code turn it into a clickable link? Are you using Edit ▸ New Link... with no text in the editor (and thus generating a link with the URL as visible text)? Is the document completely empty when doing this, or are you going back and adding a link at the top later? That could include typing in a bit of text and then only selecting the first part of the line and adding a link to it. There are other methods as well that could match that description.

Why that only becomes visibly apparent when returning to the document after having left it (e.g., closing the document and later re-opening it) is beyond me.

There are some conditions where what you see in the editor isn’t what is actually being written to the disk, which can cause formatting shifts after the editor data has been flushed from memory. That can happen either by leaving a document alone for long enough, or of course reloading the project.

Basically the text editor isn’t native RTF as you work with it. That it saves and loads RTF is something happening beneath the editor. I believe the “in memory” data is actually HTML to some degree. For the most part that isn’t something necessary to know, but it can explain some oddities on reload. If some condition, probably derived from the exact sequence of steps taken to insert the link and edit around it, causes you to actually be typing in the hyperlink continuously without realising it, because the editor isn’t showing the link adornment, it would explain what you see. It’s not that it spreads after the fact, but that it was always there to begin with.

The consistent condition that I have noticed that seems to cause, or is related, to this is the one I described above, viz., this tends to happen when I have inserted a hyperlink as the first text in the body of the document (usually, I have a centred, bolded title, but then go into the body of the document, and insert a hyperlink).

*What is the method being used to do so?
Are you pasting the link as URL into the text editor plain, and letting the web link auto-detection code turn it into a clickable link?

I copy the URL from Chrome, and right-click and paste it into the Scrivener window

Are you using Edit ▸ New Link... with no text in the editor (and thus generating a link with the URL as visible text)?

See above for the exact method I use

Is the document completely empty when doing this, or are you going back and adding a link at the top later? That could include typing in a bit of text and then only selecting the first part of the line and adding a link to it. There are other methods as well that could match that description.*

I first create a title for the document - in Scrivener. I bold, and capitalize the title.

Most often, I select and copy the title of the document from existing text - a lot of the time, that title is from Reddit posts - but not all the time.

Sometimes, I create a title myself, by typing in Scrivener.

I then, typically, copy body text from reddit messages, or from elsewhere (e.g., other documents I might have created, in Word or Scrivener).

Next, I paste that copied body text into Scrivener.

Finally, in the case of taking the title and/or text from a reddit post, I go back to my browser, and copy and paste the URL in to the Scrivener document.

So, you could say that there are quite a few variables at play, but I am quite methodical about how I go about this now.

I am also surprised that this issue seems to only happen a fraction of the time that I use the same methodology.

As an experiment, to test whether this is perhaps something coming from the source text in the browser: for a bit here try always using the Edit ▸ Paste and Match Style menu command, for all pastes, whether it be the URL, body text or titles.

If the problem vanishes, then I think I might have an idea what’s going on.

1 Like

I will do this for the body text I am posting, but it defeats the object of me copying an URL if I use paste-and-match-style, because the URL becomes non-clickable.

Okay, yeah that makes sense. For that then just follow the principle of pasting formatted text into existing bodies of text rather than into a context where the that formatting ends the document, if that makes sense. Paste the body first, and then the URL(s). I’m thinking what might be the problem is that invisible link formatting (from the site formatting) is ending up spreading into the rest of the text, much like ending a line in bold and then continuing to type off of that line would remain bold—only there the result is obvious.

In theory links should not spread, there is code in place to not allow that to happen like bold does, but like I say when it comes to this weird separation between the text editor’s attributes and the underlying RTF being different while editing, there may be conditions we haven’t factored into that code.

1 Like

Thanks very much, AmberV.

Will adopt the methodology you suggest.