Open In focus in Scrivenings a bit off

WHen I click a scene in corckboard view, with ‘automatically open selection in other window’ button turned on, as I want it, it navigates the scrivenings script to the corresponding scene in the text, as wanted (with the other editor locked, so that it doesn’t open just the scene, but instead naviagtes to the scene whilst keeping the whole script open in that locked editor, again as wanted, great feature) - BUT the slight glitch is that it navigates to the scene, but about 3 inches too far down, missing the title, scene header and first few lines. So that every time I use this, I always have to scroll up a bit to get to the start of the scene.
This seems to be a bug. Not awful, as all the functions are almost working perfecty - but would be great if we could just address that bug so that it navigates to the scene, with the scene/chapter title at the top.

The chapter/scene titles that you can turn on in scrivenings mode are great but also have a little bug: the label colour only shows if I go into options, every time I open the doc, don’t change anything, but just click ok, then the label colours for the chapter headings suddenly turn on.

Oh, and the highlight in dark mode still only visibly highlights top half of text.

Cheers.

Thanks for the report. I have not been able to reproduce what you are describing with the scroll position being off, though. I have noticed some subtle variation in where it scrolls to, mainly with editor zoom levels, and whether Scrivenings Titles are present (potentially there may be some variation there in how large the headings are), but for me this area of variation is around the top of the editor, not the bottom.

So I think I need more detailed information in order to set this up in a fashion where I can see what you are describing. Here is what I tried, so that you can follow along as well with each step, one by one, and tell me anything I should change or add to this checklist:

Bug reproduction checklist...
  1. First factory reset your settings so that we aren’t working with millions of variables. Open File ▸ Options... and click the Defaults button in the lower left area of the window, then click Save. Ignore, for the moment, the prompt to restart the software if you see it.

    Note: This can be done without losing your preferences. Refer to Appendix B.1.1 in the user manual PDF, if you are not familiar with saving and importing your settings as a backup file.

  2. As the theme might impact the sizes of different elements in the window, use the Window ▸ Themes ▸ Default setting (if you are not already). Now at this point restart the software to commit all changes.

  3. So that we have some material to work with, and are working from a common source, use the Help ▸ Reset Tutorial menu command, which will open a fresh copy of the latest tutorial once complete. If the command is greyed out, then use the main interactive tutorial command above it, and select a place to save it.

    Don’t resize or change the window layout in any way, other than what is described below. Eventually you might want to do that, and tell me exactly what you are doing (for example, opening the inspector, or maximising the window), but for this test we should be on the same page.

  4. Click on “The Basics/Get Oriented/The Inspector” in the binder, and switch the view mode to Corkboard.

  5. Click the button to split the editor, and switch the right side to Scrivenings view.

  6. Toggle the View ▸ Text Editing ▸ Show Titles in Scrivenings menu setting.

  7. Toggle the View ▸ Use Label Color In ▸ Scrivenings Titles menu setting.

  8. Click the auto-load button in the left (Corkboard) split, so that selecting index cards scrolls the right view.

    Note: it is not actually necessary to lock the right editor for this to work. The software will detect if what you have clicked on in the left editor is located somewhere in the current Scrivenings session, and scroll to it rather than loading it individually. The lock behaviour is only necessary when using the binder instead of another split.

    That said, I tried with and without locking, just to make sure that was not a necessary ingredient in the bug. I could see no difference in the behaviour.

  9. Now with everything set up using the clues you have provided, click on several different cards in the left editor. The view on the right should scroll so that the section starts at the top of the editor.

You may note, as I did, that this is indeed flawed in that it does not properly account for the height of the scrivenings title. This is the part that can vary in my experience, based on editor zoom and how large the font titles are (among other factors potentially). However it is nowhere near as off as what you describe. For me about half of the title is cropped from the top of the view, which is annoying, but it is not close to what you describe. It almost sounds like for you the text is loading at the bottom of the editor, and the section top itself, including its title, is several lines below the bottom of the editor?

Further info

  • If you are seeing what I describe at this point, then what you will need to do is think of various settings in your project, themes you use, global preferences you use, and so on, that are different from what you have here. I suggest changing things one by one, and clicking around in this setup here, before moving on to the next, and jot down each thing you change so that I can copy your settings.
  • Let me know what version of Windows and Scrivener you are using. If nothing changes and you see the same behaviour in the tutorial with default settings, this and the following factor may be the difference.
  • Whether you are using a high-res monitor or not, may make a difference. I wouldn’t imagine it would create that big of a difference, but you never know.

Other notes

  • The label setting on titles is a known bug.
  • I don’t see what you’re describing with the highlight either, but I would search the forum a bit to see if there are existing threads you can learn some clues from, or add your own to.
1 Like

Thanks for the response.

I typically have zoom set to 110% and my monitors are 2k, if that helps? Otherwise nothing atypical in setup.

Windows 10. Newest vers of Scrivener.

Cheers.

Thanks, I tried several different zoom settings and only saw a small variation in how much of the heading is cut off at the top of the editor.

It may be a high-res issue, and if so I cannot myself reproduce this. I’ll file it as an investigation for someone who has one to look at.

Okay, and since I don’t have a high-res monitor, for my notes, could you clarify the following:

  1. Does this happen when using other methods of navigation within a Scrivenings sessions?
    • Via the Scrivenings navigation button in the editor header bar (right side near split buttons).
    • With the Next/Prev buttons right beside that one.
    • When locking the editor and clicking in the binder instead of the other editor.
  • I don’t see it confirmed explicitly in your response, but you did go through the checklist I posted line by line and still saw the behaviour? I did the same, only increasing editor zoom to 110% on step 5.

That’s everything I can think of that might help someone else out.

By global settings, do you mean options? They are all mostly default, in scriptwriting mode, adjusted a few things in script settings like when italics are used etc.

I have attached my work template (in the email) with the settings hopefully baked in? I normally lock the 2nd editor and use the binder and first to navigate through a scrivenings view of the script as I work.

The issue for me is that the title is appearing HIGHER than the top of the editor off-screen, and I have to scroll the script down to reveal the title at the top – as if the editor navigates a bit too far DOWN the script, and shoots PAST the title by half a dozen lines.

Okay, I think you are seeing what I was describing earlier in that case, and what we have marked down as a bug. Thanks for the report!

2 Likes

This now seems to be worse. It is hapenning as before, but now a few chapters off.

Also, when I click in the text body in scrivenings, the text jumps up, as if I have centre typing mode on, which I don’t.

The further into my script, the more offset the corresponding selection is in scrivenings, so that when I select a scene at the end of the script, the scrivenings text is navigated to 3 or 4 scenes lower.

This is a pretty substantial bug that is affecting my workflow a lot.
AMber Test Bug.scrivx (40.3 KB)
I have included an example script here.
I work in the script by CTRL+selecting each ACT, Front Matter, Project Notes in BINDER (with ‘binder selection affects’ set to my primary editor window). This opens the desired scenes in corkboard with section lines between acts/folders, as desired.
then I CTRL+A select all items in corckboard, which loads up the desired scrivenings of all relevant scenes into 2nd text editor.
I then click around corkboard to navigate through my full scrivenings text editor, with the ‘automatically open in other editor’ button enabled at foot of primary corkboard editor.

(sometimes I change my workflow to be more focused only on single scenes, but this method described above is my main way of working, as I like to see and have the whole script open, in scrivenings, and be able to navigate through it)

Do we have an eta for when this might be fixe @AmberV ?

Have you tried turning titles off, since they seemed to be the variable condition in the earlier test?

Regarding the test project, if you could just use the File ▸ Back Up ▸ Back Up To... menu command to create a zipped copy, that would be what I need (and again that will include content so you may want to send it privately). What you posted here is just one piece of metadata from the project. I can’t do anything with it for this particular thing you are describing.