Outliner arrows missing after sorting

Just accidentally found how to reproduce this: Outliner Missing Arrows - #5 by Jestar

Open outliner, click one of the headings to sort. Result: expand/collapse arrows are missing. Have to click in binder to cause outliner to reload to get them back.

How is this bug? The Outliner is sorted on one of the headings and doesn’t have a cascading structure any more. All ‘Binder Layers’ are mixed up. What’s there to collapse?
Did you expect a grouping per metadata sorted on, like all “First Draft” and all “Revised Draft” items in one group that you can collapse or expand?

My mention was for the Binder. The only theme that properly displayed the arrow indicating subdocuments in the Binder was the default theme. There wasn’t much discussion of the Outliner to explain what was and wasn’t expected.

Because it never returns the arrows, even when you put the sorting back to default.

And yeah I didn’t mean to link to Jestar’s post, just Outliner Missing Arrows, but I didn’t notice the url automatically changes as you scroll. I switched back to the default theme so I haven’t had any trouble with the binder arrows.

The overall sort function within Outliner seems to work properly, but there is an issue with the 3rd click on a column heading, which cancels the sorting in the view.
In the standard view, when a set of items with sub-items is loaded or switched to Outliner view, there is a small right- or down-pointing triangle to the left of the title that can be clicked to expand or collapse the list of sub-items for an individual item.
However, if the view is sorted by clicking a column heading and then the 3rd click clears that sorting, the pointing triangles are no longer displayed, so I can’t simply return to my normal activity.
I have found if I select another item in the binder and then use the back-document function (not sure of the official name) to return to my previous list, the triangles reappear. I have not looked for another approach.
With the 3rd click, I don’t expect it to necessarily have the same expanded/collapsed views for each individual item as it was when I did the first click (a lot could have changed), but the triangles should still be displayed for those that have sub-items, visible or not, and allow me to interact with them.

Thanks, this is a known bug. The outliner view should refresh to its default state when turning off sort (third click).

As you note a quick Back/Forward (the Ctrl+[ and Ctrl+] shortcuts are the fastest way) to reset the outliner is actually the best way at the moment to turn off sort (which, funnily enough, it shouldn’t do until you turn it off yourself—but for the moment that is a beneficial limitation).