Page View display bug in Screenplay Mode?

Hi guys!

Not sure if this has been reported already, but when I try to view a screenplay in Page View mode and adjust the background color, the color isn’t balanced correctly. It’s a little difficult to explain, but you can see it clearly in the attached image. What I’m trying to achieve is basically the page itself is all white and the background is solid grey, very straightforward. However, I can’t seem to get it to act correctly. As you can see in the image below, white is leaking out to the right of the page border, and is also leaking between the page breaks.

Under File-> Page Setup, I’ve set the Size to different versions, none of which make any difference. Source is Rear Paper Feed (but I also tried the other) and the orientation is portrait.

Under Options -> Appearance -> Page View, I have the colors set to Background -> White (default). If i change the background color, I get the result in Image #2.

As you can see, I still have the weird imbalanced colors. There’s always color bleeding out to the right of the page itself, and white leaking into the page breaks themselves.

I’ve gone to Appearance -> Main Editor and tried to change the Fixed Width Background color, and the Editor Color, but of course none of these changes register while Page View is enabled. Adjusting the Fixed Width size has no bearing on the results either.

Hope this helps!


Yes, we are aware of this problem.
The workaround I can propose is:

  1. Adjust also Main Editor > Fixed Width Background using the same Page View background color,
  2. Check the Appearance > Main Editor > “Scrollbars next to text…” option, and restart.

I gave that a shot, but the scrollbar doesn’t change position while I’m in Page View, and with PV disabled I’m back to not having a page break, but I can live with it until the next update. I really just wanted the option of visually tracking my page breaks and I still get that option with Page View on, despite any visual quirks.

The fact that you guys are already aware of the issue gives me hope for the future. :slight_smile: Thanks for all your help!

  • SBZ