<$pageGroupTitle> and <$pageGroupParentTitle> in headers

It seems the header placeholder is not working as I expected. My binder is set up as shown in the screen capture. I have the header and footer set differently. I want the Notes from an Analyst to be on the left-hand side of the header, and the Introduction to be on the right-hand side. However, it sets the header to one level below that of the Binder, so that the Introduction shows on the left and the next level down (The Problem) shows on the right. How do I tell the placeholder to use the next higher levels? I’ve tried inserting higher level folders but nothing changes.


After Chaper 1 starts, then I want Genesis 1 on the left-hand side and Creation of the World on the right hand side.

I don’t know the answer, I had an idea that I deleted when I saw that you want your headers to change starting at your first chapter…

But… I think you are giving yourself a hard time right off the bat.
You should stick to the structure of your chapters in that case.
So, for your introduction, as you can see, you don’t have the same levels/structure. I think you should put “Introduction” inside a folder named “Notes from an Analyst” so that the structure matches the one of your subsequent chapters.
That’s not a fix, but I am pretty sure it would make it easier to find one that works.

Have you tried <$parenttitle> ?

Else : Set “Introduction” as a front matter ?

I understand that your project is called Notes from an Analyst.
Rename that folder Draft / Manuscript again.
Create a folder Notes from an Analyst.
Move Introduction and all its sub-documents into Notes from an Analyst, similar to what Creation of the World and its sub-documents are part of Genesis 1.
You now have structural consistency.

Further to that, placing <$pageGroupParentTitle> in the left field of Page Header and <$pageGroupTitle> in the right field of Page Header should give you what you’re looking for on one line.

Yours will look more busy on Mac, but you’ll get the idea:

Here’s an extract from my Binder:
image

Here’s what’s rendered on compiling.

So, it’s basically doing what you require:

  1. The parent folder title on the left.
  2. The actual folder title on the right.

The folders don’t even need to be ticked for inclusion in compile, the placeholder will still fetch it to include in your header. For example, in the sample I used, Setup (1% to 12.5%) is simply a structural guide for my own use. I’d never include it in compile, even as per my demo.

But, you’re still going to run into trouble further into your document with the sub-folders.
For instance, when you get to The Text, your prior folder header will be Creation of the World and current folder header will be The Text. To overcome this, you should allocate a different Section Type to it and define that type under Compile Formatting and assign the layout to overcome the dilemma.

Thank you for the consideration. Introduction is actually the first chapter of the book, and Genesis 1 is the second chapter where the analysis starts. I already have a Front Matter section with working headers and footers.
btw, <$parenttitle>, per the Help list of placeholders, does not work in the footer or header.

Yes, that seems reasonable, and is exactly what I did do. Unfortunately, no changes were made to the header when I added the Notes from an Analyst parent folder, which is what made me post the question originally.


I still get Introduction on the left side and Problem on the right side. I need one higher level of parent/child. I don’t know why Notes from an Analyst folder is ignored.

There are hints here.
Where getting “Introduction” on the left is the wrong thing for starters, there is absolutely no reason for you to get the document title on the right as per your description of placeholders usage.
Nowhere do you have a placeholder for the current document title in play. “The problem” ( ← your doc title) shouldn’t appear in the header at all.

So… how come ? Perhaps you are looking at the wrong set of headers/footers in your page settings ?

There is also the possibility that your project got a tad corrupted. (?) Thus messing things up as you are actually doing things right.
Perhaps create a blank new project, recreate the structure (from scratch, don’t import anything from your current project – name your test documents as per their structure relative role/position ; these documents don’t need real content) and test your compile format. (?)

. . . . .
I’m wondering if your separators’ settings could cause everything to cascade one step down your binder’s documents sequence ?

You are exactly right. “The Problem” is incorrect. It is too low level to be header data.
You mentioned the wrong set of headers/footers. Where can I see other sets? I only know of one place to set header/footer data.

Good ideas. I will give that a try. Ironically, I have another project that works exactly right, and despite comparing the options, settings, section layouts, point by point, that project works and this one doesn’t. It corroborates your corruption idea. I will also check separators settings.

In that one place (Page Settings / Headers & Footers). But perhaps you’d be looking at the setup for the wrong one. (The little list on the left)

Well it took some work, but I rebuilt the structure from scratch, from a blank template. I set section layouts, styles, etc. I got exactly the same results, structurally speaking.
Screen Shot 2023-12-24 at 12.40.07 PM
Some Intro Data and More text data popped into the right side headers. Corruption doesn’t seem to be the problem.
I would think that S3 had a bug except that I have that working file!

btw, Genesis 1 should be shifted 1 column to the right, a peer of Introduction. Doesn’t matter: I get the same result.

Not sure where I can see headers/footers except in Page Settings/Headers & Footers. Is there somewhere else?

No.
But there are a couple of sets in a list on that panel.

One for first pages.
One for new pages.
One for odd pages
One for even pages.
etc etc

… depending on your setup.

I’m not following. The only place I can see to set H/F data is in Page Settings/Header & and Footer text. There are some options in a peer panel, but I think I have those right.
Screen Shot 2023-12-24 at 12.48.54 PM

Yes, I get you now.
First Pages: all blank
New Pages: <$p> in footer only
Main body: <$pageGroupTitle> in right header; <$p> in footer
Facing pages: <$pageGroupParentTitle> in right header; <$p> in footer

The footer works fine. One side note: I found that at one time Back Matter was a H/F option, but I don’t see it (or Front Matter H/F options) when I include Front or Back Matter now. When does it offer different Front Matter or Back Matter Header/Footer options?

Here is what I would try :

(It’ll take a while to achieve, though)

That project of yours that actually works,
compile it again to confirm it still works.
If it does work, make sure you have a backup of it, safe, somewhere.

Then save as a new version of it.
Then in that new version (with a completely different name) ditch all the documents, then empty the trash.
Then with this new project side by side with the problematic one, drag the binder content of the problematic project into this empty one.
Try compiling this.

Whew! OK, out of desperation. :slight_smile:

P.S. My wife says she feels sorry for two guys working on Christmas Eve on this problem.
:slight_smile:

1 Like

I don’t know what else to tell you.
And the staff is on vacation.

Vincent,
Thanks for all your help, especially on Christmas Eve. I will give it a try and get back later.

On Mac there is a “Zap Gremlins” function.
You should try that before anything else.

I don’t know why I didn’t think of it before (Windows user), it is the very first thing I should have recommended.

Front matter is “First pages”.
Back matter is listed when you check the option to have a different H&F for it too, in the other tab.

I entered Edit->Zap Gremlins. No change (or effect). Well, for the few seconds it took, it was worth a shot.