Prevent Capitalization of "Asked" after Question in Manuscript

I have Scrivener set to capitalize at the start of a sentence. However, in certain cases, we don’t want that. For example after a question, such as:
“What do you mean?” asked Casper.
Scrivener will obey the rule and capitalize “asked.” I have to backspace twice to try to correct it. It seems that Scrivener wants me to delete it twice before it will accept lower case asked. How do I change this behavior. I’ve already tried to do it in System Text Preferences (changing Asked to asked) and that doesn’t seem to work. Same question for said to Said. (It’s not as much of a problem for “said,” because quotes in manuscripts usually end with a comma, instead of a question mark, which doesn’t end the sentence. Although it is a problem with something like “Hell!” he said. (Of course one workaround is to say “Casper said” or “Casper asked” so that capitalization is okay.)

I’m not sure there is a setting to remove this behaviour, in MacOS, at least, but rather than deleting twice, you can just use cmd-z once to undo the capitalisation, so you don’t need to move the cursor.

I’ve found this easier than doing without capitalisation altogether – it becomes second nature after a while…

1 Like

Please note my edit above, re workaround. Instead of saying “asked [Character name],” simply say, "[Character name] asked. I think I’ve been unconsciously doing that!

In the windows version, the capitalization doesn’t occur across the " " boundary.
Hey! said Paul – would capitalize Said.
“Hey!” said Paul – doesn’t.
(Note that my settings rather use French guillemets though; might play a part, I don’t know.)

So perhaps there is an OS setting somewhere that would fix that for you ?

How I would personally handle this (although I don’t rely on auto-capitalization, and prefer to do stuff such as this myself) :
If you take the habit of adding a coma : Hey!, said Paul…
You could easily later remove those comas using project replace.
Replace !, with !
Replace ?, with ?

I don’t see changing otherwise the way you prose to accommodate a software’s behavior being quite artistic. (Just my opinion.)

1 Like

That’s a great idea. Using !, and ?, and cleaning up with project replace. Thanks very much!

1 Like

But why change the rhythm of the sentence, when a simple cmd-z gives you what you want? Type 'asked[space]cmd-z] and you’re done.

It should work for any false capitalization or mistaken autocorrection anywhere in the OS, so it’s useful everywhere.

1 Like

That doesn’t happen at my Mac. See the video. The first word inside quotes is automatically capitalized, but the word after the quotes is not.

auto-capitalize after closed quote?

In the screenshots are the relevant settings here.

1 Like

I think that’s because you have disabled ‘Correct spelling errors as you type’. If you turn it on, then you’ll see the unwanted capitalisation.

Correct! And the issue reoccurred recently for me after I changed the “Correct spelling errors…” setting back. But I like the workaround above, using !, or ?, then doing project search/replace.

It should bee turnip oft. Its knot ass if a computer can tell what weird we wont too type, much less all ways get thee spelling write.

I tested it, and autocorrect made no difference for me using the Windows version.
No auto-capitalization still across the " " boundary.

Even so, I don’t think these two options are in anyway related… One doesn’t impact the other.

Perhaps not on Windows, but it seems to be standard behaviour on the Mac – you see the same effect in TextEdit.

They shouldn’t, but they do on the Mac.

Again, could be due to the fact that I use French guillemets (quote marks)…

I don’t think so: the Windows behaviour is different even with English quotation marks.

I’m sure there was another thread on this and that there was a solution but I’m buggered if I can find it.

It was asked (by the same OP) in 2019.

The answer was the same then as now: use cmd-z once, as this will undo the unwanted capitalisation, which MacOS treats as a distinct undoable step.

Any more than once and words will be deleted.


No, there was definitely another solution and it worked but I can’t remember what it was

This is dictionary dependent.

Option One

If using the British English or US English dictionaries supplied by Apple:

 → System Preferences → Keyboard → Text → deselect ‘Capitalize words automatically’

You can leave the ‘Fix capitalization of sentences’ option in Scrivener turned on. Note that that is the capitalization of sentences not words.

Option Two

If using a suitable custom dictionary (I use en_GB-ize), the OS setting above can be selected and the dictionary already knows not to capitalize words after ‘question mark & quotation mark’ combos.

Thanks, I knew there was a way. Only downside is it won’t capitalise proper nouns.

1 Like