[RC 12] Unable to save. Access Denied

After launching Scrivener today, I updated to RC 12 via the popup indicating the new version. After the update, I started RC 12 and was right where I left off. Saving my project produces the following error:

[code]The following errors occurred while saving your project.
Could not save project document ‘Escape (Long)’
Failed saving text for document with id: {484cfee1-e621-4b88-a408-b1bacab9329b}
Error: ‘Could not open file for writing.
File: ‘E:/Dropbox/Backup/Writing/Binary - Exodus.scriv/Files/Data/484CFEE1-E621-4B88-A408-B1BACAB9329B/content.rtf’
Error: ‘Access is denied.’’

To avoid losing your latest changes, make sure you have enough space and write access on your storage device.
You can create a copy of your project into another location using the menu File > Save As.
You might also try to compile and save to RTF or DOC format to avoid losing your latest changes.
[/code]

The first thing I tried was setting all files in that folder to read-only= false. Next I tried restarting. Per the popup’s suggestion, I compiled the latest version of this book. Nothing has changed between RC 11 and RC 12, and I don’t have the project open anywhere else. I have plenty of space on all drives. I’ve run Scriv as administrator to no effect.

I’m prepared to make a new copy via Save As, but figured I’d report first just in case I’m doing something dumb.

Windows 10 64bit,

I have the same problem. RC12 is unusable because you cannot save any text you enter in any scene.

I also tried to compile what I’ve written so far, and the compile fails. It goes through the motions, but it never writes the output.

We are dead in the water until there is a fix. Can we reinstall RC11?

Thanks,
Miik

Hi guys, sorry about that trouble. We cannot reproduce it, but would like to trace what is causing this issue.

  1. Do you have this problem with all projects, or only one particular.
  2. Do you have this problem with all documents inside the project, or only one.
  3. Please, make your tests after fully restarting your computer, i.e. no Sleep, Hibernate, etc.
  4. Could you please try to uninstall Scrivener and install the Non-HighDPI version of Scrivener (I assume you have auto-upgraded or downloaded the primary version of Scrivener RC12, which is the HighDPI version of Scrivener)

You can switch back to RC11, which can be used safely until 2nd Dec. Your help to trace and fix this issue is appreciated. Thanks!

Hi Tiho,

I have the same issue and followed the first three steps you suggested. The error occurs with all projects, even new ones. And all documents inside are affected.

Hi, Tiho. Here is a list of the steps I took to resolve the issue and provide you with information about it:

I rebooted (shut down and then turned on the computer) and retried saving documents. That was your #3.

The save failed on all documents as noted by Rosealacroix above. That was your #2.

Since the save failed on an existing project, I created a new project based on the Novel template. The save still failed. Here is the error:
[attachment=2]Save Fail New Novel Project.jpg[/attachment]

I created a new project based on the blank template. It also failed. Here is the error:
[attachment=1]Save Fail New Blank Project.jpg[/attachment]

These two new projects were your #1.

The new projects indicate the issue is not related to a template. The screenshots above reference the file content.new.rtf in the respective project folders. That file doesn’t exist when I look in those folders, so it either creates the file with a problem, or it fails to create it entirely, I can’t tell.

Some information: I run Windows 64 Bit. I had RC12, like all the betas, installed to Program Files\Scrivener Beta in case that folder name with the space impacts the behavior. With Scrivener 64 Bit installed, I have 26.3 GB free. I also do not sync to any cloud folders. I only use the one computer, so I don’t share any folders with anything.

I uninstalled, restarted, and reinstalled the 64 Bit version. There was no change. I got the same error messages for the two new test projects.

I uninstalled the 64 Bit version, restarted, and started to install the 32 Bit version. It warned me there is a 64 Bit version, then it flashed something that I couldn’t read fast enough. Its window then went behind the Windows File Explorer window used to launch the installer. When I accessed the installer window again, I thought maybe it switched me to the 64 Bit version, so I canceled the install via the Cancel button. My plan was to restart it with all other windows minimized to be sure it didn’t switch to the 64 Bit version, but now I cannot launch the 32 Bit version. The error doesn’t tell me what the install is trying to access, so I have no way to manually clean up whatever the install left hanging. At the very least, you now know about an install bug. The error message is here:
[attachment=0]Launch of RC12 32 Bit Installer Fail.jpg[/attachment]

You mentioned we can reinstall RC11, but with only four days left before it expires, what’s the point unless you can extend the expiration? Also, I don’t know where to find the link to download it.

You also mentioned to use the Non-HighDPI version. I took the 64 and 32 Bit Install versions from the main topic: Scrivener 3.0 Beta - Release Candidate 12 (Download Links & Change List) (https://forum.literatureandlatte.com/t/scrivener-3-0-beta-release-candidate-10-download-links-change-list/38228/1) Excuse my ignorance if I should be taking the Non-HighDPI versions from elsewhere. Would you provide the link to them if I took the wrong versions? There is no mention during the install whether the version is Non-HighDPI or not.

I hope this helps you identify what’s going wrong. I’ll perform whatever steps you direct me to take to get the program working because I normally use it daily, and right now it remains unusable.

Thanks,
Miik

One other minor issue: When I first uninstalled Scrivener 3 to try to resolve the issue, the uninstall process removed the Scrivener 1 icon from my menu, not the Scrivener 3 icon. The Scrivener 1 program still seems intact in its folder, just the icon from my menu was deleted.

Thanks,
Miik

So far I’m seeing the same results as Miik. I’ve found the download for the previous release and installed it right on top of RC 12. Back on RC 11, everything is working as before, so I guess I’m sticking with this until December.

https://www.literatureandlatte.com/scrivenerforwindows/beta/Scrivener-29911-installer_x64.exe

Here’s how I resolved my issue. My thanks to Devin on this thread: https://forum.literatureandlatte.com/t/issue-with-permissions-and-saving-with-v12/93500/1

I had my Avast set to silent mode to not deal with the pop up for the daily scan. Silent mode caused Avast to not notify me when it blocked Scrivener. I turned off Avast when reinstalling RC12 and testing whether it would save a document. It worked properly, so once I enabled Avast again, I went to the main Status page in Avast. I selected Menu, Settings, Blocked & Allowed Apps, and added Scrivener.exe to the allowed list:
[attachment=0]Avast Allow App.jpg[/attachment]

Compile still failed, so I had to add aspose.exe to the allowed list for that to work. There are other .exe files in the Scrivener folder and subfolders, so I’ll leave silent mode off to see any other blocking notices.

I don’t understand why RC12 triggers these ransomware blocks when none of the other betas or RCs did, but as long as I can get it working, that’s for someone else to figure out.

Hope this helps others,
Miik

OMG thank you Miik! It solved the issue for me too.

This is not a scrivener issue:::

Bitdefender updates often block ALL programs from saving to the docs folder. Did it to me after an update a couple of weeks ago. And update later that day seems to have been the source of the fix.

I have a few clients that use bitdefender. We had to disable the ransomeware, and “Protected Folders” crap, and the firewall, to get applications that have had no issue for years have access to program folders, and shared folders.

Too many children are in charge of these programs. MS is a prime example of seven-year-old, "look what i can do,’ behaviors.

I disagree. It is a Scrivener issue, just a different issue.

True, the protection programs like Bitdefender and Avast are preventing Scrivener from functioning, but Scrivener needs to be able to operate in an environment where protection programs are common.

Something changed with RC12, not the protection programs, to trigger the protection programs seeing Scrivener as a possible ransomware threat. I know this for a fact because before I made any changes to Avast, I uninstalled RC12 because I couldn’t get it to save, installed RC11, and it worked properly.

Imagine how many users would be confused, frustrated, and enraged if the final production release of Scrivener 3 doesn’t play nice with protection programs.

Thanks,
Miik

Since Avast and others of its ilk have a well-known history of being over-aggressive about flagging certain library versions as being malware (instead of, you know, warning the user that their program is using a vulnerable library version and they should let the developer know to update it ASAP), or just having weird heuristic or signature issues that randomly pop a false positive on innocent programs, you can be (and probably are) absolutely correct in saying that it was something that changed with RC12 and still be absolutely wrong that it’s a Scrivener problem.

When I have encountered an access denied message because of AV, i am still able to save to a different folder.

I may have missed the part where someone wrote that they could not save to a different folder.

And: two issues were described: the first about saving, the second about running the program…the error that was connected to the download folder is a clear indication of it not being a scrivener issue.

That something changed in RC12, and AV programs react badly, does not mean that scrivener is the culprit.

I ran into this problem and do not have avast or bitdefender installed. However I am running Windows 10, which as you no doubt know updates and resets many settings all the time. To solve this problem click on Windows Security, I have an icon on my toolbar others may have to go through settings to find the security section. Once there, on the left click on “Virus and Threat Protection”. Then on the right section of the screen Under the Heading “Current Threats” look down until you see “Protection History” Click on that. This should bring up a list of events." Protected folder Access Blocked" should be in your list, possibly several times, Click on the entry and one of two things will happen"

  1. a screen will appear which will have some information and near the bottom, in blue, will be a link that reads “allow on Device”, click the link and all should be well.
  2. a screen will appear showing the allowed applications and the option to browse to add and allow another application.

Some one may have already provided this information but I didn’t see it after a quick read through two threads with this topic
Regards.
Fumio

I experienced this problem for the first time today in RC13. It affected only one of my projects, but prevented me from saving anything in any document within that project, using the exact popup shown above.

As with others in this thread, the problem seems to have been tied to my antivirus software (in my case AVG) and I had to whitelist the Scrivener app in order to allow it to begin saving again. Why it only affected one project and no others, and why it started happening out of the blue today when it had been working fine before, I have no idea, but figured it might be pertinent to add my experiences here, since there’s already an open thread on this.