Request for help from Scrivener staff

This is to ask for help from Scrivener’s staff, please.

Last week I posted here under the name “Is this a virus?” It described a problem I was having with a particular project: the same text was showing in every document and folder in the project.

I invoked a backup of the project and got it back to normal, with the kind help of people here. Over the week i then manually backed up all 100 or so projects I’ve made over the years, got rid of all the com.list-type preferences in the MacOS Preferences, and did a clean install of Scrivener.

I had saved the internal preferences of Scrivener (using cmd-, in Scrivener and the Manage dialogue within that), and I added those in to the new install.

Now it’s happened again, with the (new version of) the same project, and I have to ask for official help. I’m absolutely terrified that this is going to spread through other projects - a half-completed book, seven years of research notes for it, the main document of which is over 250,000 words and includes typing-up of original historic letters which are irreplaceable.

This is what happened: I put the text of a story (“The Kitchen Sink”) sent by a student into a new document, edited it, copied it into a Mailplane form to circulate to the class, then went back and clicked into another student’s folder - and saw the same text. I know already that this means all the text in the other documents will be the “The Kitchen Sink”.

(Incidentally, this project is showing up in Finder as measuring 669.3MB, immensely larger than other projects. There’s a lot of work in there, but this is still surprising.)

How do I stop this happening? Worse, how do I stop this spreading?

Why not email them direct on – that’s the surest and quickest way to get help.

Identify the steps you’ve taken in detail, then zip up a copy of the problematic project (right-click on it in Finder and select ‘Duplicate’, then right-click on the copy and press ‘Compress’) and attach the zip file to the email. That will give them the best chance of helping and they’ll probably ask to see the file anyway, so you might as well send it in from the beginning…

Good luck!

Thanks, doing that now.

I know you are a practiced Scriv user, but to leave no stone unturned: Is there any chance you have accidentally Locked the editor pane?

The effect of that would be that no matter what you clicked on in the Binder, the editor pane would look exactly the same. This would be the simplest way to get the (apparent) phenomenon you are seeing. It would also surely be the happiest end to a terrifying story.

I find I sometimes Lock the editor pane accidentally – somehow managing to hit the keyboard shortcut without meaning to. I think (but can’t check right now) that the default key command for that is cmd-L. The title bar at the top of the Editor area gets a color tint when locked. In fact, I think I discovered that there was such a function by accidentally invoking it!


Gr, thank you, it appears that I’ve done this all right. However, there are other problems.

[]“Editor: Lock in Place” appears not to be a toggle. How do you unlock it? (My shortcut for “make all lowercase” is cmd-ctrl-L, whereas Lock in Place is cmd-alt-L…) I can’t see any icon or other GUI way of unlocking, and a Help search for “unlock” comes up empty. (Found out how to undo it - unchecking it in the View menu; odd that there’s a keyboard shortcut for putting it on, and that isn’t a toggle for putting it off!)
]This Scrivener project proves to have about a million (rough estimate) Notes files, each many megabytes and all empty. This is weird.

What’s NiaD, by the way?

I am glad there is an easy soln to this part of the weirdness!

The command & menu item do toggle – hitting that key command / menu item repeatedly would alternately check and uncheck this option. (This explains why searching for ‘unlock’ in the Help Search did not reveal the menu item, b/c is always says ‘lock’.)

The Lock in Place toggle also appears on a contexual menu in the interface: Command-click on the title/header bar at the top of the editor pane.* The resulting contextual menu has the Lock in Place menu item on it.

Hope the solution to the other mysteries with that project are as easily and happily resolved!

NiaD is the nickname for an annual “Novel-in-a-Day” writing event wherein “a group of writers from across the planet get together and write a novel – a whole novel, in a single day.” It is hosted here on the Scrivener forums. Participating is super-fun and I recommend it highly! You can read a write up by the organizer. You can also check out the books that have been written this way. NiaD 2017 will take place later this month and signup is happening now – if interested, you can signup over at this forum thread. Here is a link to the general NiaD subforum here.


  • You might have to control-click right on the document icon in the Editor’s header bar (not just anywhere on the header bar) to get the contextual menu.

Another way to navigate if the binder seems stuck is to click on the document icon in the editor’s title bar. You’ll get a “go to” function in the menu that pops up.

That will work even if the editor is locked.

Thanks, both. No, I was repeatedly hitting command-alt-L and it wasn’t toggling.

What’s the document icon?

Take a look at the image linked above.

At the top of either document, do you see the document name, “Cafe Ricardo”? Immediately to the left of the name is the document icon. It’s even got a little pull down thingy.

You can pull that down and will see the “reveal in binder”, “lock in place”, and a couple other commands.

If it is not toggling, something else is interfering. For example, if you have the same key command assigned to more that one thing that could do it. Or if you are running a macro program or some other utility that catches keystrokes before the frontmost app gets them.

My lock in place command has no assigned key command shortcut at all. Is it possible you created a key command assignment for that key combo yourself in Apple > Sys Prefs > Keyboard > Keyboard Shortcuts? (Either a general shortcut or one specific to the Scriv app.) If so, that increases the likelihood of the diagnosis above, namely that something else in Scriv (or an assigned universal shortcut) already uses that combination, so no lock toggle happening because the other action with that same key command is being invoked.

jimrac, I see the document icon, but no pull down thingy. If I ctrl-click it, I get the path of the document; otherwise it responds to no clicks, multi-clicks or other blandishments, other than to move the right-hand side of the window in by a third on a double-click.

gr, I don’t think I have anything else assigned to cmd-alt-L, other than app-specific shortcuts for other apps. And if I had, it would have disappeared along with other useful shortcuts (sob) like my cmd-ctrl-L for “convert to lower case” when I did a clean install of Scrivener this week. I do use TextExpander, which occasionally fails to play nice with other applications. (By the way, I’ve signed up, should it have me) for NID.)

In the document header you should see the following – document icon and document title. When I click on the document icon I get the following contextual menu, which shows (among other things) the option to Lock in Place. When a document is locked in place, the document header should change colour to a reddish-pink. The steps described above are in the screenshots below. I’m not aware of any preferences settings that would alter this behaviour, so it would be odd if you weren’t seeing this.
Screen Shot 2017-10-04 at 18.19.01.png
Screen Shot 2017-10-04 at 18.19.12.png
Screen Shot 2017-10-04 at 18.23.22.png

The document icon isn’t responding with any menu, the header colour isn’t changing when I invoke Lock Editor.

Very strange. Sorry I can’t be of more help.

Maelduin, could you please upload a screenshot of your full Scrivener window. It’s a longshot, but that might give one of us a clue as to what is going one.

What version of Scrivener do you have, and with which version of OS X?

Often, if you aren’t seeing commands that seem to be available to others, a version mismatch is the reason.


Katherine, in another thread, the OP downloaded and reinstalled the latest Mac version. Don’t know OSX version.


Thanks for all the help - even a negative is kind help.

Here’s a screenshot.

(This is from a different project, but the problem with the document icon, etc, is the same.)

Have you reset your preferences as suggested in that other thread?

Do you have the problem of the missing icon menu in other projects, or just this one?


Sorry if this is obvious, but let’s just make sure…

When talking about the Document Icon, you’re clicking the one that I’ve put the RED box around below?

I ask because there’s also another icon (which I’ve put a BLUE box around) which behaves as you describe when clicked. If you’ve been trying the Blue one, you need to be clicking the Red instead.