RESOLVED Jerky Scrolling

I’ve noticed recently that scrolling in Scrivener has become jerky, as if maybe there’s a sort of lag. I 'm using an Apple magic mouse but I’ve tried it with a mouse with a scroll wheel and it’s the same. Scrolling is nice and smooth elsewhere so I’m wondering why it’s only happening in Scrivener.

Perhaps try a re-start of the Mac, if not done already.

And if a wired mouse is what you are using, try a Bluetooth mouse (if you have one) and visa versa.

Yes, I’ve tried rebooting. The Magic Mouse is Bluetooth.

As I say, it’s only happening with Scrivener.

if you have a wired mouse in drawer might try that.

I haven’t got one but I’ll see if the wife has one later

What version of MacOS? What version of Scrivener?
Is this every project or just this one?
If it’s just this project:
• are you using Scrivenings mode?
• how big is it?
• does it include many images?
• does it include a lot of inspector annotations or footnotes?



1 Like

OS Monterey 12.2.1 Scrivener 3.2.3

  • No
  • 97k words, 3.6mb
  • No photos
  • No

If it’s just the one project, you might try resetting the project’s display settings.

1 Like

Sorry, meant to say, it’s all projects, regardless of size

How often do you shut down Scrivener and your computer? I ask because somewhere in the back of my mind another user had a similar problem which seemed to be caused by a build up of gremlins.

I close Scrivener every day and shut down my machines every evening. I also run Cocktail on them weekly to clean up the system. The only time I have had any scrolling issues with Scrivener was in a small project (translation editing) with literally dozens of comments.



1 Like

I don’t often shut down/reboot but have done so on a few occasions recently due to the Grammarly issue. I only have comments in one document of my main project but none in any of my others.

I’ll have a look at Cocktail

Just ran Cocktail & rebooted, no difference. :frowning:

Is Grammary, or remnants of, still installed?

As far as I know, it was fully uninstalled

Is Scrivener up to date? You can check via Scrivener > Check for Updates… . This is especially important if you’ve updated macOS recently, as we’ve made some compatibility updates for newer operating systems (Big Sur, Monterey).

The next thing I would suggest if this doesn’t help is resetting Scrivener’s preferences, as a corrupted preferences file can cause all sorts of behavioural problems → Resetting Preferences / macOS: Troubleshooting / Knowledge Base - Literature and Latte Support

1 Like

I’m on 3.2.3 which Scrivener tells me is up to date. When was the last compatibility update? I updated it to 3.2.3 quite a while ago.

That said, I did a complete reinstall a couple of weeks ago so i’d have expected that to have the most up to date version an of course, it reset preferences.

Also, did you end up trying a wired mouse? If you didn’t or if wired worked smoothly and since this is just happening in Scrivener:

In the chance that your writing environment setup is a cause, are you near an external drive (for backups, for instance) or any other type USB device (including a hub) while using Scrivener? USB can cause interference with BT.

[You can track Scrivener releases here:]

1 Like

Yes, tried a wired mouse and it’s still the same. I’ve tried wired, usb & BT now.

Last software-controlled idea. Turn off BlueTooth completely, and use wired keyboard and mouse to control.

Sorry, thought I’d answered this

Turned BT off but scrolling just as bad. As I said, it’s only recently (last few weeks), was absolutely fine before that.