Runtime error

“This application has requested the Runtime to terminate it in an unusual way.”

I’m using the trial version of scrivener and I have not been able to run it since I installed it. Each time I start it up, I get the error message shown a the top of this post.
I have tried everything I could think of, such as shutting down other programs and rebooting my computer, but nothing seems to work.

Help would be greatly appreciated.

I am experiencing the exact same thing.

I have been using the trial version on a Mac and had no problems whatsoever but this week I bought a new Windows computer and after first installing Scrivener it did start up but then suddenly it crashed soon after and gives me this error no matter what I do. I did attempt to reinstall the program two times and installed Visual C++ as I had seen it mentioned on this forum but no luck. I just can’t get Scrivener to work on my PC.

I’m have the same issue. I have been using Scrivener on my MacBook for years, but as I got a new desktop recently I decided it might be good to have the ability to write on that as well. So I got the trial a week ago, and have used it for a few days with no problem. But then I installed the latest update when it told me it was available, and now I keep getting the Runtime error and it won’t open at all.

Tried uninstalling and installing again, using the new trial available on the website, but still getting the Runtime error.

Any suggestions?

Edited to add: Oh, and I am using Win7, should be up to date and all that.

Try This and reinstal if neccessary.

Re: Windows 1.2.1 Update Released 18th June 2012

Postby Eddie Tex on Wed Jun 20, 2012 8:33 pm
For those of you seeing the “side-by-side configuration” error, the issue can be resolved by downloading the “Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)” at … px?id=5582.

Eddie Tex

Posts: 23
Joined: Mon Nov 14, 2011 2:13 pm	
Platform: Windows

And yes it is the (x86) package that is required if not installed even on a w7 64bit OS

The whole links won’t show when you copy/paste like that. Googling gave me this. The one you meant to post I assume: … px?id=5582

Still getting the Runtime error. And yes, did uninstall and reinstall Scrivener. Seems to me the problems came with the last update, cause I was running it just fine before I upgraded yesterday. It asked me to upgrade, I did, and once it restart I started getting errors.

Any chance of getting an installer to the older version? As that one at least worked? I can still write on my laptop, and it’s where I usually write anyway, but I would like to have the option to write on the desktop as well, cause sometimes going downstairs and booting the Mac seems like too much work just for a little plotting/writing :laughing:

I have tried the C++ install and it doesn’t change a thing. The program just won’t work despite me having tried everything that’s been suggested.

My guess is wait until someone comes up with a solution that actually works for everyone. The C++ worked for a lot of people, but I am guessing for the rest of us there is something else that no one seems to have thought about yet.

Until then, check your Scrivener folder in program files. It has a backup folder, and in there (possibly a few folders in) you will find a scrivener.exe file that lets you open the previous version you had installed. Someone else mentioned this and it does seem to work for me at least.

Cicilie you are my hero. I’m having a different issue after downloading v1.2.3, but I tried the backup folder you suggested and now I’m in. I thought I was going to lose my mind - I spent a boatload of money to put my son in camp this week so I could write, and then I couldn’t open Scrivener! Thank you!!

I’m glad it worked. I saw someone else mentioning it for a different problem in a different thread, so figured I may as well give it a go for this problem as well.

I had downloaded a fresh Scrivener file during the weekend as I’m on a brand new computer and there’s no backup folder for me to retreat to. I didn’t even initiate an update, I probably downloaded the new version.

Hopefully this issue will be fixed soon.

Edit: I found the older version and so far so good. Phew! At least I can use the program for now :slight_smile:

Anyone know of a way to fix this yet?

What sort of an upgrade is this one ! (The machine is Win 7, Home premium, 64) . Spending about 2 hrs. allready and installing and reinstalling scrivener and C ++ run time libraries again and again without any improvements on the problem. Checking through the posts in this forum shows no exact solution on this as well. One should not publish an upgrade without testing it sufficiently . Where’s the technical support anyway ?

The upgrade has been in public beta testing for several months. We are as confused as you are about why these problems are only appearing in the release version, and only for a relatively small number of users.

There are several variations of the “runtime configuration” bug. Many of them are fixed by installing this file: … px?id=5582

A few, however, are not, and for those users we recommend reverting to version 1.0.3, which can be downloaded from here: …


Aside from the ‘side by side’ errors mentioned - which can be fixed by installing the 2008 C++ redistributable SP1 from Microsoft, I’d be interested to know if the following resolves the:
“This application has requested the Runtime to terminate it in an unusual way.” error.

As I have not been able to duplicate this issue, I’ve been flying blind here; however, any feedback on the following would certainly help narrow things down:

Inside the Scrivener directory there are four files:

If you cut these files from within the Scrivener directory and paste them
into a backup folder on your desktop and then try running Scrivener
without these files, do you still receive the same error message?


I did remove those four files but starting Scrivener still gives me the error “This application has requested the Runtime to terminate in an unusual way”

I’m on windows 7 - 64 bit
Laptop: Samsung Chronos 7

I don’t know if this will be of any help locating the problem. But here it goes…

I downloaded the old Scrivener v1.0.3 and installed it without uninstalling the new version. When I tried to start it the same error came up (…“Runtime to terminate it in an unusual way”) . Then I uninstalled it and removed the scrivener folder and installed the old one again and then it worked.

I Don’t know if the installer of the old version skips installing files already in the scrivener folder. But if it doesn’t maybe this can be of help.

Right now, I do not really care about “locating the problem”, I only care about getting access to my files again. In Scrivener.
And your solution works great. Thanks!!

“This application has requested the Runtime to terminate it in an unusual way.”

Any news about this problem? Is it just me and my computer?

I guess this is a bump for the developers!


I have the same issue: “This application has requested the Runtime to terminate in an unusual way”.
I tried to remove a file: aspell-15.dll (size: 1.333 KB) in folder C:\Program Files\Scrivener\Aspell\bin, and replace with this one (different size): and it worked for me. I think that file related to spelling checker feature of scrivener.
Sorry for my English… :smiley: