Scrivener Linux beta released 22nd July 2014

Hi All, is a hotfix for in which there were PDF issues under Linux which are now fixed in the release. Also, there have been some optimizations to the project loading speed.

Download here (now 32bit and 64bit versions available):

For the release post on Linux see here: [url]]

Lee & Tiho

Thanks guys! :slight_smile: Installed on Ubuntu 14.04 without trouble.

Installed on Mint-17 Cinnamon 64 without a hitch and as near as i can tell it fixed the issues I was having. It is a joy to use this new Scrivener release. Thank you for not only giving us the new release, but also for quickly giving us the hotfix


Now that’s a curious little addition to the import tab under options… :smiley:

As always, you guys are the greatest! Can’t wait for the retail version!

:smiley: :mrgreen:

Thanks for supporting Linux! Just installed on Mint 17 and it’s working great.

Hi! Brand-new user here; thanks for making a Linux version available!

I ran through the tutorial today and encountered a couple of issues (some minor, one that consistently produced segfaults). I also tested against the Windows version to see if the same behavior was present there. If these have already been reported, sorry for the duplication.

  • Part 1, Step 4: Full Screen - on my dual-monitor Linux system, the full-screen window always appears on the primary monitor, even if the main Scrivener window is on the secondary monitor. (Under Windows, the full-screen window appears on the same monitor as the main window.)

  • Part 11: Scrivenings - multi-document select doesn’t seem to work; the editor shows only a portion of the most recently shift-clicked document, cutting it off on the right as well (screenshot); if one scrolls up with the mouse wheel, all the selected documents are shown (screenshot), but then the mouse wheel only scrolls the particular document under the pointer. If your mouse has a horizontal scroll wheel, it will also scroll the document under the pointer left or right within the visible area. (This issue does not occur under Windows.) Scrivenings mode for a folder (e.g. “Part 2: Organisation”) does not produce this behavior, and works as described in the tutorial.

  • Part 12 - Project Search: The empty search box shows “All (Exact Phrase)” regardless of what options are selected in the dropdown menu. (This also occurs in the Windows version.)

Also, unrelated to a specific tutorial step, clicking and dragging a document within the binder always gives me a segfault if I wait too long before releasing the mouse button. The amount of time before the segfault varies; sometimes it’s only a few seconds, sometimes it’s thirty seconds or more. (I have not been able to make this happen in the Windows version.)

I was using the 64-bit version under Ubuntu 12.04.4, and under 64-bit Windows 7 Professional SP1.

Anyway, just from going through the tutorial, this seems to be a fantastic piece of software. I’ve just purchased a Windows license (order ST[…]1178) to support further development of Scrivener, but if anyone’s keeping track of your potential Linux customer base, please let him or her know it would have been a Linux license had they been available.

Thanks for the update. Updated my 32 bit version to the 64 bit version on Ubuntu
sudo dpkg --remove scrivener:i386 uninstalls the old version
sudo dpkg -i scrivener- then installs the 64 bit version

Opened it up and all the projects worked just fine.
Thanks for supporting Linux - (I bought a windows version - even though I dont do windows - just to show some support)



I installed Scrivener on Fedora 20, default gnome UI, on a old HP TC4200 laptop, 2Ghz Intel Pentium M with 1.5G of RAM with the following steps:

   downloaded the 32-bit tarball (tar.gz)
   locally unziped the file using the default 'Files' manager into /home/<username>/LiteratureAndLatt
   added these to my user  .bashrc file:
             export LD_LIBRARY_PATH=/home/<username>/LiteratureAndLatt/lib:$LD_LIBRARY_PATH
  sudo yum install  (ran as super user)
  Scrivener  [ both command line and through Files]

I’ve brought up the tutorial, but not too much farther. Hope this helps.

This old laptop is my “travel” laptop for more challanging environments and temporary writing. Normally, I use my Scrivener Windows version on my “real” laptop.

Thanks to the developers making Linux possible!

Just downloaded and installed on Mint with no problems. Opens and saves scriv files. More testing to come.
Excellent, thank you.

Have been running through the tutorial. Looks good! I really like the approach.

Spotted these problems:
a) downloading dictionaries does not work out of the box. Got it working, but I’m not sure what the trick was: either:

  1. permissions problem when saving the downloaded stuff in the default installation location which is /usr/share/scrivener (owned by root)
  2. installing libaspell-dev
    or both perhaps…

b) scrivener crash in ubuntu 14.04 when dragging items in the binder, and the unity launcher comes out from the left side (also reacting to the drag event). But not every time - maybe it is not related to the unity panel? Confirms the report from another user above this post.

c) problem opening help->scrivener manual. Starting scrivener from the command line (as a normal user) prints this error message: evince: error while loading shared libraries: failed to map segment from shared object: Permission denied
I have libfreetype6 and libfreetype6-dev installed (but scrivener comes with own versions of these libs in /usr/share/scrivener/lib ?)

d) adding links to external (filesystem) files in the text of a document: you cannot open the links:
gvfs-open: file%3A%2F%2F%2Fhome%2Fsune%2FDropbox%2FHistorie%2FSpeciale%2Fcase%2Fevalueringsbeskrivelse.pdf%0D: error opening location: Error when getting information for file ‘/home/sune/file%3A%2F%2F%2Fhome%2Fsune%2FDropbox%2FHistorie%2FSpeciale%2Fcase%2Fevalueringsbeskrivelse.pdf%0D’: No such file or directory

The file exists, I double checked.

e) adding a link to a pdf in document references works, and you can view it in scrivener, but when choosing “open in default editor” same problem as c) occurs:
evince: error while loading shared libraries: failed to map segment from shared object: Permission denied

f) to zoom a pdf: maybe there is a problem with non-english keyboard: using ctrl± works fine for zooming out, I’m not able to make ctrl+= work (not quite sure what key combination I need to use).

Regards, and thanks for a brilliant piece of software.

Successfully installed on Debian 7 amd64!

I ran into some issues with the installation. Debian 7’s stable ‘libc6’ package (basically decodes, runs, the application once it’s installed) is set at version 2.13. Scrivener requires at least version 2.15. To upgrade the libc6 package to 2.19:

reinstalled Scrivener… happy writing time! :smiley:

Ubuntu 12.04 runs libc6 2.15 as stable. I’m wondering if that distro was used to configure this Scrivener package. Thanks for doing what you do so well!


Hi All,
I’m brand new to Scrivener but have been wanting to try it for a while… The release of a Linux version means that I finally can - hooray!!
It looks like an amazingly useful tool that will help me make some sense of my chaotic thought process while writing technical documents…

This is a really impressive beta but there are a few problems I’ve found and I hope reporting them here is helpful.

I’ve been through the tutorial and made a few notes on stuff that doesn’t quite work:

  • I’d like to confirm that I expeirenced the exact same behaviour as JohnSmallBerries on Part 11: Scrivenings … I found that Scrivenings is fine if selecting a whole folder, but if I select an arbitrary list documents then it shows them in a column that’s about a quarter of the screen width of the document screen.

  • Fullscreen Mode - Background fade has no effect. BG is Black

  • No asterisk on References button in Step 5 (Adding a reference doesn’t change the icon either) - Oddly this started working after restarting scrivener so maybe it’s intermittent.

  • 5e Keywords and in other places the tutorial says to click on the “triangle” to expand things like folders but in the Linux version at least it’s not a triangle - it’s a + or - in a box.

  • Part 3 Step 16 Compiling - Compile dialog blocks the main document dialog. Cannot scroll through tutorial steps while using Compile.

General Notes

  • Cannot access text colour or highlighting colour options. Clicking the “A” or Highlighter Pen buttons shows a very brief flash of the palette but no possibility to choose a colour. (Highlighter has default colour of yellow which can be set by single clicking the icon, but changing the colour is impossible).

  • Unable to import DOCX / ODT (and probably others)… “Error: Format Converter not found”

  • Scrivener has crashed on me several times - Notably when dragging items around in the binder as reported by another user, but also when I clicked on ‘Research’ in a new,empty project after deleting some blank documents from failed imports.

If a developer would like me to capture and submit crash dumps and/or backtraces when it crashes please let me know

I’m running Scrivener Linux beta (64 bit) under Linux MINT 17 using the MATE Desktop (a fork of the now defunct GNOME2 desktop)

A big Thank You to the Scrivener team for this refershingly unique piece of software :smiley: (Which I’ll be happy to pay for as soon as a Linux license becomes available)

I discovered Scrivener yesterday and feel like I’ve found a new world. I can’t remember being this excited about a computer since I borrowed the use of my flatmate’s machine to write my dissertation and he explained copy and paste to me.

I want to say thank you, but I’m so happy with it I would also like to pay. :open_mouth: I feel it deserves money and chocolates and flowers and a warm man hug to really labour the point of how happy I am. When is it likely that Scrivener for Linux will go commercial? I want to support it. Failing that, could you set up a donations fund?

I’d offer to help if I could, but I’ve ground to a halt on the Edx Linux for technophobes course, so I can only cheer you on.

Installed perfectly on Kubuntu 14.04. I would like to ask for some help or an insight for an inconvenience that I am having with Scrivener

When I use Scrivener with English (US) keyboard layout, all keyboard shortcuts work fine.

When I use Scrivener with Bulgarian (BG, Cyrillic, BDS) keyboard layout, some keyboard shortcuts either work, or do not work:

Things like Ctrl+C,X,P,Z (also Ctrl+Shift+Z) do work as expected.

Ctrl+I,B,S (Italic, Bold, Save), Ctrl+Shift+B,I,R (Toggle Binder, Inspector, Ruler) do not work.

These are only the ones I’ve tested.

Some of the non-working keyboard shortcuts could be reassigned easily. Things like Ctrl+S,I though are almost hard-coded in my muscle memory and I am having a hard time writing, Does anyone have the same problem? I tried different settings in KDE’s System Settings without any luck. Scrivener is the only application in which I seem to have this problem.

cellfourteen - I’m nothing to do with the scriviner team and am in fact very new to scrivener but I’ve tried looking at your problem and unfortunately not found any solution :frowning:

I can agree that if I apply a Bulgarian keymap to my UK keyboard (in my case it’s MATE desktop) then keystrokes such as CTRL+I and CTRL+S stop working in Scriviner.

What is particularly weird is that if I go into Tools->Options->Keyboard and try to reconfigure the keystroke for something like Italic formatting then when I press CTRL+I wich the bulgarian layout enabled it still recognises it as a CTRL+I sequence, but then in the general editor CTRL+I appears to insert a TAB character rather than set Italic.

I haven’t used Scrivener for a year, and at first sight this is a massive improvement, tons of work must have gone into this, so thanks so much all involved.

And thanks sunew for the above tip, dictionaries had always driven me crazy in Scrivener and the above appears to have fixed it.


ovation1357, thanks for confirming that. I tried ver. (the download link appears to be dead) and changing the application language to “Bulgarian”, but I still encounter the same problem. By the way, I am using the 32-bit download.

Ver. works great for me and I am tempted to use it until it expires on December 1 this year. But I’ll do my best to use because Ctrl+S isn’t such a big deal as it’s more of a compulsory thing while there’s the auto save functionality which I really like. I’ve changed it to F2 just to be on the save side :slight_smile: And there’s the Italic problem. It’s just a silly inconvenience. I shouldn’t be overemphasizing every third word I write anyways. Changed to another function key until (hopefully) the developers release a fixed version.

I just wanted to say “thank you” for the Linux port of Scrivener. This is my first chance to try the beta since I heard of it. I use Scrivener on my Mac at my home office, but wanted to use it on my Linux laptop (Chromebook with Ubuntu) when I’m at coffee shops.

For some reason I thought the Linux version was an outdated version of Scrivener, since the Mac version is 2.5. But apparently 1.7.x is also the Windows version.

So I’m going to give it a try, switching back and forth between the Linux and Mac versions on the same data files.


Fred :smiley:

Just installed the (actually after I had got the 1.6.something crashing when I tried to import an .rtf file).

New test with importing. This time .odt (and a lot of other formats, at least Word’s ones, just glanced) appeared on a list, and hopeful I clicked my file as .odt (I’ve seen enough broken .rtf to wiev that format with suspicion and disgust…)

Result: “converter not found”. But the .rtf opened neatly (a clear improvement to my former copypaste workaround for text I’ve stared with a word processor).