Scrivener 3.3.6 keeps crashing mid-typing on MacOS Venture 14.3

Hi all. I’m new here but recently started excitedly using Scrivener a few months ago, on my first book.

Everything started well, but in the past few weeks, I often have trepidation and tons of saving, sometimes after each word I type, in fear of the dreaded crash.

A search through these forums found others experiencing crashes upon load, or startup, or other situations. Mine happens while typing; most often editing a line that’s not the furthest line in the chapter/section.

Someone else a few days ago posted about a similar issue, which appeared to be when the line grows past the line and begins to continue on the next line. My issue doesn’t seem to be that. My issue is that it crashes at seemingly-random times, always while in the middle of typing. (How frustrating).

Sometimes it’s like this:

  1. Eagerly open Scrivener
  2. Find where I want to edit
  3. Start typing, even just typing one or two letters
  4. Bam! Crash

It just happened for the fourth time in the past fifteen minutes, and I thought these two stack traces from Apple’s own diagnostics might help an engineer here.

One appears to be the main app stack trace, and the other is the trace of Thread 0, which looks like the one that crashed.

App Trace

Exception Type:        EXC_BREAKPOINT (SIGTRAP)
Exception Codes:       0x0000000000000001, 0x000000018be2733c

Termination Reason:    Namespace SIGNAL, Code 5 Trace/BPT trap: 5
Terminating Process:   exc handler [12327]

Application Specific Backtrace 0:
0   CoreFoundation                      0x00000001883e4540 __exceptionPreprocess + 176
1   libobjc.A.dylib                     0x0000000187ed5eb4 objc_exception_throw + 60
2   CoreFoundation                      0x0000000188496124 -[NSObject(NSObject) __retain_OA] + 0
3   CoreFoundation                      0x000000018834e764 ___forwarding___ + 1572
4   CoreFoundation                      0x000000018834e080 _CF_forwarding_prep_0 + 96
5   ScrAppKit                           0x00000001051e1ce8 -[KBLineNumberingRulerView drawHashMarksAndLabelsInRect:] + 508
6   ScrAppKit                           0x00000001051e1a94 -[KBLineNumberingRulerView drawRect:] + 808
7   AppKit                              0x000000018bc65910 _NSViewDrawRect + 124
8   AppKit                              0x000000018c5ed67c -[NSView _recursive:displayRectIgnoringOpacity:inContext:stopAtLayerBackedViews:] + 1088
9   AppKit                              0x000000018bc65314 -[NSView(NSLayerKitGlue) _drawViewBackingLayer:inContext:drawingHandler:] + 556
10  AppKit                              0x000000018c191114 -[NSViewBackingLayer drawInContext:] + 56

Thread 0 Trace

Thread 0 Crashed::  Dispatch queue:
0   AppKit                        	       0x18be2733c -[NSApplication _crashOnException:] + 240
1   AppKit                        	       0x18bc74c8c __62+[CATransaction(NSCATransaction) NS_setFlushesWithDisplayLink]_block_invoke + 644
2   AppKit                        	       0x18c62af04 ___NSRunLoopObserverCreateWithHandler_block_invoke + 64
3   CoreFoundation                	       0x18836ed80 __CFRUNLOOP_IS_CALLING_OUT_TO_AN_OBSERVER_CALLBACK_FUNCTION__ + 36
4   CoreFoundation                	       0x18836ec6c __CFRunLoopDoObservers + 532
5   CoreFoundation                	       0x18836e29c __CFRunLoopRun + 776
6   CoreFoundation                	       0x18836d93c CFRunLoopRunSpecific + 608
7   HIToolbox                     	       0x192936448 RunCurrentEventLoopInMode + 292
8   HIToolbox                     	       0x1929360d8 ReceiveNextEventCommon + 220
9   HIToolbox                     	       0x192935fdc _BlockUntilNextEventMatchingListInModeWithFilter + 76
10  AppKit                        	       0x18bb4ced0 _DPSNextEvent + 660
11  AppKit                        	       0x18c337eec -[NSApplication(NSEventRouting) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 716
12  AppKit                        	       0x18c7f3be4 -[NSCorrectionPanel _interceptEvents] + 212
13  AppKit                        	       0x18c7f44a8 -[NSCorrectionPanel showPanelAtRect:inView:primaryString:alternativeStrings:forType:completionHandler:] + 812
14  AppKit                        	       0x18c31628c -[NSSpellChecker showCorrectionIndicatorOfType:primaryString:alternativeStrings:forStringInRect:view:completionHandler:] + 508
15  AppKit                        	       0x18c316f50 -[NSSpellChecker _showInlinePredictionForReplacingRange:markedRange:string:withString:view:client:lastReplacementRange:completeWordIndexes:resultDictionary:completionHandler:] + 620
16  AppKit                        	       0x18c318038 -[NSSpellChecker showCompletionForCandidate:selectedRange:offset:inString:rect:view:client:completionHandler:] + 1124
17  AppKit                        	       0x18c66f238 -[NSTextCheckingController handleCompletionFromCandidates:forSelectedRange:offset:inAnnotatedString:rect:view:] + 492
18  AppKit                        	       0x18c664edc -[NSTextCheckingController viewForRange:completionHandler:] + 156
19  AppKit                        	       0x18c66f98c __60-[NSTextCheckingController handleCandidates:sequenceNumber:]_block_invoke + 124
20  AppKit                        	       0x18bc93c08 -[NSTextCheckingController annotatedSubstringForProposedRange:wrap:completionHandler:failureHandler:] + 692
21  AppKit                        	       0x18bc93948 -[NSTextCheckingController annotatedSubstringForProposedRange:completionHandler:] + 108
22  AppKit                        	       0x18bc953cc -[NSTextCheckingController annotatedSubstringForSelectedRangeWithCompletionHandler:] + 96
23  AppKit                        	       0x18c66f8f0 -[NSTextCheckingController handleCandidates:sequenceNumber:] + 208

I should add: the person who posted a few days ago about the crashes related to text going past one line, said they have an M3 processor for their Macbook.

Mine is an M2 Max.

I wish I could edit my post or comments so as to not have to keep adding more, but I should also add:

The font in my document is EB Garamound. Not sure if font type might make a difference in how the letters get drawn under the hood…which may be a cause of the crashes.


I am not a Mac user, but, did you try the “Zap Gremlins” function?

(It is not a joke.)
Must be somewhere under the Edit menu.

Ah! What a neat name. I just found and tried that. It didn’t appear to do anything, when I compare the latest to the previous saved snapshot.


The stack traces above look like they’re related to spelling and/or autocomplete…and it looks like Apple has its own version of this, that somehow works with Scrivener’s own, or Scrivener uses Apple’s features of this. And the crash looks like it may be coming from there.

I’m testing out turning off all spellcheck and autocomplete features to see if it happens again.

Have you pasted content from the web into your documents ?

I think I have. My memory is a little fuzzy on it, but a few weeks ago I think I may have copied and pasted text from another doc, or webpage, into my manuscript. I remember having to fiddle with the font to get it matching afterwards.

When the crash happens, can you tell whether or not you had the editor display that content first?

I mean since your last restart of the app or crash.

also: have you rebooted lately?

can you tell whether or not you had the editor display that content first?

I’m 90% sure no, the content wasn’t displayed first. And since I had changed its font to match my manuscript, I don’t remember which sections possibly came from an outside source. I think it may actually be earlier chapters, rather than the chapter I’ve been writing in. (But this crash happened in earlier chapters too, some weeks ago).

And yes, I have rebooted earlier this week and tend to weekly. The crashes have been happening for weeks.

One thing I did start a few weeks ago, is dividing the screen into upper and lower frames/windows, so I can read one a PDF in my Notes folder while typing in manuscript. That sounds sort of related to outside sources, so maybe it has some kind of impact.

But the stack traces are telling in that it appears to be in a spellcheck or autocompletion module.

You should create a blank new project and see if it crashes too.

That’s the end of the help I may provide as a Windows user.

Thanks for your help Vincent! I just noticed you were helping some other people out in other threads too. I’m learning the lay of the land here.

You are welcome.
Good “luck” with your issue.

1 Like

So far, since turning off the Scrivener spelling and auto formatting and suggestion options, there’s not been a crash in a few paragraphs. Which is a big deal, as this was crashing every few words when I posted this.

This looks promising as the diagnosis area…though I really do want to use these features when or if they get fixed.

I have an M2Max 14" MBP that is overloaded with apps/browser tabs etc and typically also running Win 11 under Parallels

I experience none to the issue you’re describing.

Do you have other apps in the background? Tried closing them all and opening 1 at a time to see if/when it kicks back in?

As for the spell, that is an Apple component.

1 Like

@RuffPub to summarize:

  • the crashing has not been dependent on app usage. most of the time, Scrivener is the only app that was open
  • Scrivener has spelling and autocorrecting, autosuggesting features in the Settings > Corrections tab
  • since turning off all of those checkboxes in that tab, crashing has not happened again today, after many paragraphs. Which is a big win, as it had been happening every few words beforehand.

I’ve submitted a bug report to L&L.

I think this is some interaction between Scrivener’s corrections, and Apple’s. Or something in this domain.

One thing I want to try, like @Vincent_Vincent suggested, is creating a new blank project, turning all of the corrections on, and seeing if it ever happens again.

Before I turned them all of, every single checkbox was checked.

Meanwhile, I am thinking that perhaps your antivirus doesn’t like Scrivener solicitating system operations/files.

It be kind of a first (context-wise), but I wonder if maybe that’s possible.
You could whitelist Scrivener in your antivirus and run a few tests with the spellcheck and all turned on. (It’s far fetched, but who knows…)

(Usually when the issue is an antivirus, it doesn’t work, and that’s pretty much that. Nothing that specific.)

The latest version of Mac OS is 14.4.1. I’d recommend upgrading before you embark on extensive troubleshooting.


Yes. I’m aware it’s in Settings, but it uses the Apple spelling component.

Given almost all of us have been using Scrivener with the Spelling component for a number of years without issue, I’m picking it’s unlikely to be a Scrivener bug. Bugs will normally have a wider occurrence.

I’d certainly try all Vincent’s suggestions.