Scrivener 3 Crashing After macOS 10.15.4 Update

After updating to macOS 10.15.4 a couple days ago, Scrivener 3 will randomly crash on me while typing. I’ve had to set my auto update to every 3 seconds just to make sure I don’t lose much of what I’m writing. It doesn’t happen all the time, maybe a couple times per day. Today, I got it to crash consistently just by deleting a carriage return. Anyone else having this issue?

It’s been very stable up until this update.

My iMac running Catalina is the most flaky iMac I’ve ever had (about 30 years!). It also does weird things while I’m editing in Scrivener, and crashes if Scrivener shuts down automatically if I leave it running while I’m away doing something like having lunch! I’m almost at the point of downgrading the OS to Mojave!

My 2011 17" MBP running Mojave—which people say was one of the worst versions of MacOS—is solid as a rock.


I haven’t specifically had problems with Scrivener, but I held off upgrading to Catalina for a long time, then when I did I pretty soon rolled back to Mojave. I think this is the first time I have rolled back an OS upgrade since I started using Macs in about 1993. I found iCloud was pretty bad (slow to update, or sometimes got stuck) and there was other unpleasantness. Using Mojave again has been a relief.

Hi Martin,

I think I might have to do the same; this is my only experience of Catalina and it’s terrible. It just crashed on me in the middle of a video editing session with Final Cut Pro X, and it crashes regularly with iMovie … both mainstream Apple apps, on a 2015 5K iMac with 24GB RAM and an SSID!!

I’m just working up the courage to set about doing it.


Thank you. Thank you. I downloaded Catalina, and checked compatibility prior to install. Scrivener was not flagged, but several other apps were, and I thought to double check this forum. Thank goodness I have Mojave.

As a matter of interest, did you all upgrade from Mojave to Catalina, or do a fresh install?

I did a fresh install (on day 1) and I haven’t had a single crash with Scrivener in Catalina, and I use the iMac for several hours a day with a number of programs. (The only one I’ve had problems with is Tinderbox, but that’s been the case with every OS since Snow Leopard at least.) Catalina has been as stable as any other Mac OS I’ve run.

I know people do seem to be able to upgrade over the top successfully but it seems to be unnecessarily risky to me, and doing a fresh install allows you to clear out any clutter that you’ve accumulated since the last time. (This is for major releases only – I do upgrade from 10.15.1 to .2, say.)

Not that this helps you in any way… I just wondered whether a clash with old settings may be a common factor. (I know that this doesn’t excuse Apple’s failure to program the upgrade properly, if that’s the case…)

I can’t remember, to be honest. I think I did a standard upgrade rather than wiping the HD. But I did wipe the HD when I rolled back to Mojave. Apart from anything else, I just didn’t like Catalina all that much. I didn’t have a compelling reason to upgrade, and can’t see that it brings any useful improvements (for me). Plus, I have a few 32bit applications that I still like, and having to use a VM for them would have been inconvenient. Certainly not Apple’s finest hour.

The only complaint I have is that the second monitor stopped being recognised a few weeks ago. Itks not the cable because I replaced it, and I’ve tried all the available fixes (resettting nvram etc) but it’s just not working, after being fine under Catalina for several months. The same thing happened under Mojave, but I managed to fix it. It maybe something to do with the monitor, but itks annoying, whatever it is…

I tried to re-install Catalina on the iMac from the internet and it crashed so completely that I can’t even reboot it from my bootable external … not even the chime on pressing the power button! So it’s going back to the people I bought it from in the hope that they can recover it. It came with Catalina already installed.

Apparently, Final Cut Pro X and iMovie, two of the apps I use most, are amongst those which cause Catalina to crash! Also, the new version of FCPX, which won’t run on Mojave, uses a different library format from the previous version, so all the work I did on colour correction is lost, until and if Phil can restore the iMac. Well done Apple!

I just hope I haven’t now got an extremely large and expensive door-stop!



God, Mark. That sounds bad. And at this time in the history of the world. Hope it gets sorted out.

From what I read on MacRumors, it seems that Apple have realised that the autumn updates to their system software were a car crash and they have taken steps to make sure they manage things better. I gather iCloud “improvements” were pulled at the last moment, and I certainly find that iCloud is not at all reliable at the moment. It also seems that Catalina messed up Apple Mail for a lot of people. Not good.

Thanks Martin. Fortunately, my 17" MBP is pretty much solid as a rock. Trouble is, I need a computer with at least 2GB of VRAM to run other important (for me!) software, and although this has a separate graphics processor, it only has 1.5 GB of VRAM. The iMac had 2GB, as well as a 5K screen.

I can’t find the £2,400+ for a 16" MBP, which would solve that problem!


That doesn’t good at all, Mark. Hope it’s sorted soon.

Thanks @brookter. It’s going in tomorrow morning. They’re running a system whereby you drive up, knock on the door, which is locked, open the boot of your car and stand back, and someone comes out to take it into the shop, so no one comes close to anyone else.


Sounds very sensible – hope it works.

Thanks @brookter and some very good news and some less good.

An hour or so after I took the iMac in to “intensive care”, Phil rang me up and said I could come and collect it … he’d (obviously removed and) repaired the SSID and force installed Catalina anew and it’s running again and all my apps and the little data on it are all intact. That’s the very good news.

The less good news is that it’s still running Catalina, FF•Works still crashes it, and although it hasn’t crashed while. working on iMovie and Final cut Pro, I finished my colour correction, set it to export (share!) the resulting video and went to get my excercise walking round the garden. When I came back, the iMac was asleep, but when I logged in it had crashed again and I had to force shutdown and restart (it doesn’t respond to either keyboard or mouse at those times) though the export had completed ok, it turned out.

It seems it crashes with any video application when they finish writing to disk; that and/or going to sleep. Sadly, those video applications are what I most need it for!

I’ll see if I’m still getting Scrivener strangenesses!


1 Edit for a typo!

Don’t know if this will help, but for walk-away processes (video processing, backups, big uploads), I always set my mac to Prevent sleep when the monitor sleeps (Energy Saver) before I walk away. Saves a lot of heartache.

My original post seems to have inspired some therapeutic venting about macOS Catalina. In my experience, issues with any and all OS software stem from with the overall tech world philosophy, “Move fast and break things.” The product is directly correlated to the philosophy that builds it… much like people in general, actually. But, moving on…

@GR, this has been my strategy for many years as it seems allowing a computer to sleep introduces corruption in the saved state code. The more often you wake/sleep the device, the more corrupted the state becomes. Best practice is to set your screen to turn off without sleeping when not using it, then shut down the computer completely at the end of the day. Older devices have more trouble with this than newer.

For my own issue, Catalina has been fine with Scrivener, save for a few hiccups from the initial release (common). The sole problem I had came from the minor update from macOS 10.15.3 to 10.15.4. Only then is when the crashing began.

Unlike most people in this thread, I’ve really enjoyed the stability and features of Catalina. But, that could likely be because my hardware is a more recent iteration.

Venting aside, have you opened a support ticket? The responses to this thread suggest it’s not a common issue, so we’ll probably need to dig into your specific configuration to find the problem.



Not so good, indeed…

I saw this on MacRumors after I read your initial post: looks like there’s several people suffering from what may be a connected bug?

Thanks @brookter, that is somewhat reassuring that there are people who do understand what’s going on at a low level, and that they are working with Apple. I haven’t yet checked the sleep options on the iMac, as I haven’t booted up since before I read that post.

Anyway, I’m sorry to have somewhat hijacked the OP’s thread. At least now I’m back up and running, I can see if the oddities I had with Scrivener are still happening. One was when highlighting and changing a word immediately followed by a quotation mark with the cursor jumping to after the quotation mark after typing the first letter of the new word. But I’ll have to do some experimenting to check that it wasn’t something I was doing!