Scrivener crashed, now says project is incompatible[NOTED]

So, I have Scrivener close properly, but Windows would not shut down last night. I had to force it to hard reset.

Upon starting back up, Scrivener is saying that my project is not compatible with this version.

In addition, the RTF files that I edited last night contain no text, but 5 pages of spaces. In other words, all the work is gone (as far as I can tell).

Now, when you say you had to do a “hard reset” do you mean you had to disconnect power to shut down your computer?

This is genuinely the first time I’ve heard this one, I posted on your post on the Nano Technology forums that you should open the folders to get your files out. If you had saved scrivener the RTF files should contain your data.

Unfortunately I think this is something to do with your computer, and not with Scrivener.

Yes, I had to hold down power to make the reset happen. Before I shut down all the text was there. Now the RTF files are just blank (well, filled with spaces instead of text).

In the Windows Forum here, I see another person with the same issue.

I have not had the shutdown problem before the Scrivener install, and this was a fresh Windows 7 install that is about a month old and running minimal software. I would assume it was a Windows problem if the only files affected wern’t Scrivener files, but alas, they are the only ones that seem to have any issue. All of my other documents are fine, and any RTF file that I did not edit through Scrivener last night are still there and fine.

My best guess would be that when I shut Scrivener down some process continued to run. So it looked like it shut down fine, but really never had. When when I forced the shut down it was if it had crashed.

Can you point me to the thread where the other person had the same problem? I’m wondering if this is a Windows 7 exclusive issue.

Their’s reported a crash though.

They are also running windows 7 though. So if we combine the data we can surmise a few things.

  1. If Windows 7 is not shut down properly, Scrivener files become corrupt.

If we go with your theory about Scrivener having not shut down all the way before you had to to your shut down perhaps we can also assume:

  1. If Scrivener is not shut down properly, Scrivener files become corrupt.

After the data loss, are you still using Scrivener or have you switched to something else?

If you are using Scrivener, the next time you save and then your computer will not shut down, open up your task manager and look to see if it’s still running a process. I’m curious to know. If you aren’t using Scrivener anymore though, I understand.

I am not using it for this anymore.

I may in the future, but I cannot risk the word count for NaNoWriMo right now. At least until the next Beta at least.

I have also been able to roll back and open my project from 2 days ago (still losing the 2 days work in the middle), and that opens fine, so there is something weird about the project file itself.

I had the same problem. Last night, Scrivener crashed when I tried to shut it down. My computer (Windows 7) wouldn’t shut down either, so I had to use the button on the computer itself, rather than going through the start menu. When I tried to open up Scrivener this morning, it said that my files were “incompatible with this version of Scrivener”.

That was before I updated Scrivener to the latest beta version available. I was able to access what I had lost (just a day’s worth of work, thank God) through RTF files and the backed up version I had saved a few days prior. Now I’ve updated Scrivener to the latest beta version, and everything seems to be working fine, except when I go into fullscreen mode. Sometimes a window will pop up as soon as I open the fullscreen version saying that Scrivener.exe has ceased functioning and that Windows is searching for a solution. This always results in Scrivener being shut down.

This has happened twice in the last hour, but it doesn’t happen every time I go into the fullscreen mode. Scrivener would also only crash after I had it open for long periods of time; it had crashed twice before last night.

Is anyone else having these problems?

Check out my “fix” at the end of the “Scrivener has encountered an error” thread. I think the same process might fix this kind of corruption too.

I was having the same trouble initially; my version of Scrivener wasn’t even opening after creating the project file, just crashed straight out with the same error message, “not compatible with this version”.

My computer’s also Windows 7 and also is having trouble shutting down, namely it crashes to a blue screen every time, just as it’s shutting down or restarting, and then it restarts. I posted here on the bug forum fairly early on, about the 29th.

Small update.

I still cannot open the RTF files. Or rather, Scrivener cannot open them. Opening them in Wordpad is still all spaces.

However, I have a file that does not work. I tried copying the Docs folder into a new project to see if they would work. Scrivener then failed to boot up. So then I copied all the files EXCEPT the odd man out: docs.checksum. If that file is copied over, Scrivener never even shows up when clicked.

Just some more info.

My fix for corrupted projects:

1.) Open your corrupted “Project” file by right clicking the project file Scrivener icon and selecting to open with —> wordpad or notepad.

2.) In word pad, “cut” or “copy” everything between and .

3.) Open Scrivener from a non-corrupted tutorial or other project file. Create a dummy project.

4.) Open the dummy project file in wordpad or notepad. Delete everything between and .

5.) Paste in the stuff between and that was in your old, corrupted project file. Save and close.

6.) Move the dummy project file to your corrupted project folder. Replace your old project file, or back this project file up in a separate folder before replacing.

7.) Your corrupted file is now replaced and your binder should open as it used to.

The project file is also blank/full of spaces for me.

Hmmm. What version of WIndows are you working from? I’m in XP and I can see the code for all the scrivx files. Is the font set to a visible color (ie black?)

If you attach the project file to one of these emails I can try to see if I have better luck. :slight_smile:

I had a similar problem, and trying StarTigress’ solution did not fix the problem.

Eventually what worked for me was to open the file “[project].scriv \ Files \ version.txt” and delete the two space characters and type the number “16” (no quotes). I don’t know why 16, but that’s the number in that file in a new, blank project, so that’s what I used—and it worked!

YMMV, but good luck!

I… ended up running it through my wife’s Macbook. She was able to see the text in the files that had been replaced by a single strange symbol, or spaces.

Not a fix, but useful to know.