After many months of beta testing, we are very proud to announce that Scrivener for Windows and Linux version 1.5.x is now available as a free update on Windows and remains in beta on Linux with an expiry of end of Jan 2014.

This update adds some great features that were previously only available in the Mac 2.0 upgrade. We hope you are as excited as we are with the new features and improvements all round.

Here is a list of new features:
-Scrivener is much faster and more robust
-Additional supported languages now include:- Traditional Chinese, German, Italian, Turkish and Dutch
-OPML Import
-OPML export
-Mind map import (Freemind .mm format)
-Mind map export (Freemind .mm format)
-CSV export
-Import and Split functionality
-Import Scrivener Project functionality
-Image background (texture) in full screen
-Comprehensive Print preview functionality
-Print index cards
-Print outliner
-Inspector comments and footnotes
-Revised annotation, footnote and comments options
-Ability to set your own user interface font
-Added multi-language smart quotes functionality including:- Japanese, Korean, Chinese, German and more.
-Implemented Cancel within Compile dialog i.e. changes are no longer saved when Cancel is clicked
-Project and Preset Replacements added to Compile dialog
-Deleting Scrivener project files within the directory of an open Scrivener project is now prevented
-Options->General - added checkbox to show full project path in title bar
-Added “Take Snapshot” menu item in header bar i.e. right click document icon to see sub menu and added ability to sort snapshots
-Improved debug and incorporated minidump crash reporting
-Improved tables and font handling throughout
-Improved eBook handling throughout including CSS support
-Image import improvements - WMF still remains unsupported like Mac, but we will get it soon
-Windows 8 compliant

Bug fixes
Over a 100 smaller bug fixes

Work in Progress
Our community of wonderful translators are now working on translations to: Simplified Chinese, Slovenian, Hungarian, Swedish, Greek, Spanish, Danish, French, Norwegian, and Korean. We have also made very good progress with Scrivener for Android - phone and tablet, and are progressing well towards Scrivener 2.0.


Lee & Tiho

6th Feb 2013 Scrivener Linux tar Package here - > … .5.3.1.tar Scrivener Linux deb Package here - > … 1-beta.deb

I tried both the tar and the deb, and they look like win 95 on ubuntu. The tar integrates perfect with gnome on fedora, but not on ubuntu. I removed the settings with uninstall --purge before installing this new version.

Any idea why this is?

It’s something on your system, I think. I’ve never had problems with it integrating with whatever theme I’m using.

A big thak you for this new release and that you are still developing Scriviner for Linux. If there would be a pay license in the future I would definetely buy it.

This is great, thanks for making Scrivener available for Linux!

However, is there any chance that you will make a 64bit (AMD64) version available?

%sudo dpkg -i ./scrivener- dpkg: error processing ./scrivener- (--install): package architecture (i386) does not match system (amd64) Errors were encountered while processing: ./scrivener-

Ok, already installed on fedora.
Just one problem, blocking problem.

When I type with my spanihs keyboard “áéíóú” what I get is all right for any fedora application, but with scrinener I ge “'a’e’i’o’u”. I tried hard, using different keyboard, changing system-config-keyboard, loadkey es, setxkbmap -layout es… and yes, the keyboard is changed for all the applications but scrivener is unable to treat correctly those strokes, and, with the same configuration, any other application does it right.

Any idea?

Thanks in advance!


‘Paste and match style’ doesn’t work.
It always pastes the html version of the clipboard, not a plain text version, which is what I want. This is a blocker issue for me too.

sudo dpkg --force-architecture -i scrivener-

I’ve been using an earlier beta on Ubuntu 12.04 32 bit.

I installed the latest beta beta from link above in this thread … but Scrivener does not now launch …

I see the old message which I’ve seen on earlier versions …

How can I get this latest beta to work?

Any crash logs you would you like to peruse?

[Later edit]

I ran this command to check if was installed in scrivener/lib … (it was missing in earlier beta versions) …

$ locate

[and a later edit … ]

I manually removed scrivener installation files from /usr/share/scrivener …

Next I tried installing with GDebi Package Installer instead of through Ubuntu Software Centre

Again I get this error …

The crash report gives this clue … Stacktrace Top

There is a fuller crash report available in …

As a last resort I tried copying the entire set of libQt… library files
from: /usr/lib/i386-linux-gnu/
into: /usr/share/scrivener/lib/
overwriting scrivener library files …

but that doesn’t work and scrivener does not launch.

So I’m stuck and I’ll have to wait for a response on getting working on Ubuntu 12.04 32 bit.

In troubleshooting it might be useful to have a list of dependencies.

I am using Linux Mint 14 Cinnamon

I had to install ia32libs, or else it wouldn’t launch.

And it looks like wndows 95.

Maybe it is because of Cinnamon?

This might help the linux developer to debug why scrivener does not run on ubuntu 12.04.
After installing … I ran this command …

sudo strace scrivener

and the strace output shows many cases of “no such file or directory”


"cannot mix incompatible Qt library … "

Is there a list of linux distro versions this beta been tested on?

I can post or email the fuller crash report if required.

$ sudo dpkg --force-architecture -i scrivener- (Reading database ... 350659 files and directories currently installed.) Preparing to replace scrivener:i386 (using scrivener- ... Unpacking replacement scrivener:i386 ... Setting up scrivener:i386 ( ... Processing triggers for desktop-file-utils ... Processing triggers for menu ... In file "/usr/share/menu/outrec", at (or in the definition that ends at) line 4: ?package(outrec):needs="X11" section "Applications/Sound" title="outRec" command="/usr/bin/outrec.gambas" icon="/usr/share/pixmaps/outrec.png" ^ Expected: "=" Skipping file because of errors... $

I get a different error, also on 12.04 (ubuntu-studio) - previous beta installed fine…however despite the error message Scrivener works! Thanks, great software - now you have me hooked I’ll have to (happily) buy a license once the Linux beta expires…

I tried installing with --force-architecture flag set …

sudo dpkg --force-architecture -i ~/Desktop/scrivener-

but still see this annoying incompatibility error …

To compare our Ubuntu 12.04 libraries can I ask you to run this command …

sudo locate /usr/lib/*4.8.1

to search for installed Qt libraries which are incompatible with scrivener-

Here is my output … which clashes with scrivener’s local library in /usr/share/scrivener/lib … (which are all version 4.8.0)

/usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/

It may be that I’ve got a later version of Qt libraries due to installing Qt Designer as an experiment.

I may have to revert to an earlier copy of /usr/lib/ in Ubuntu 12.04.

Just installed on a crappy old laptop running Ubuntu 12.04 long term release.

I’ve not run the software through a large number of tests but the installation was fast and problem free, I was able to navigate around in and mess with the tutorial file, and compile it into various outputs.

I’ve only just started using Scrivener (on an iMac). For long term commitment to the software in a wide range of uses for me, Linux support is pretty important. Clearly, this release is an excellent proof of concept.

What I’m probably really going to do is to hook up certain projects to text files that will reside in a dropbox folder and use the usual method of editing them (emacs) when using my Linux system. (I think I can do that.)

In any event, rarely does one see a piece of software this complex appear across platform this way and work this well. For those of you who have had trouble with the installs, I wish you the best of luck. If you are using Ubuntu, but not the most current long term release (i.e. if you are using an old version or a bleeding edge version) you may want to change that.

I’m running Ubuntu 12.04 LTS 32 bit … the most stable release … and experiencing Qt library incompatibility

I suggest that Scrivener should show any library dependencies before installation.
The Scrivener windows version does runs in Wine (although not offering a pleasing GUI).

For those having issues on Ubuntu, make sure you have the latest wine installed.

Open a terminal and enter the following command Sudo apt-get install wine let it run through the install. Now follow the next few simple steps to get Scrivener working.

  1. Download the Scrivener.tar file NOT the .deb file.
  2. Open the Downloads (or wherever you have downloaded it to) folder and right click the Scrivener.tar file and select EXTRACT HERE. You should now have a folder called SCRIVENER.
  3. Open the SCRIVENER folder and then click into the BIN folder, inside here you will find the Scrivener.exe It might just say Scrivener it is a purple diamond shaped Icon. :wink:
  4. Right click on the Scrivener icon and select MAKE LINK. A link to Scrivener icon will appear.
  5. Now copy this link to the desktop. Double click on link and it opens Scrivener.

Enjoy 8)

Just FYI, you do need the 2010 C++ redistributable. It’s easily available via winetricks. (Corefonts and font smoothing will also make things look better.)

Can anyone tell me how can I remove Scrivener from my Ubuntu 12.10 system?

I installed the program on Kubuntu 12.10. There is a bouncing icon indicating the program is starting, then a new entry on the taskbar showing running programs. After about a minute, this entry disappears. I never get a splash screen or any error message. The program simply won’t start.