Scrivener for Windows qt6 libraries?

Hi, I’m trying to get Scrivener 3 running on Linux Mint, and I’d like to get a list of the qt6 libraries used by Scrivener to run on Windows. I got it running on LMDE6 by “accident”, and I don’t have a record of the files that happened to work. Unfortunately that installation is gone.


Thank you for that. I’ve seen that in my search but was not sure about the optional files.

Have you tried this installation and setup guide yet? It’s quite good, and should go over everything you’d need. I don’t recall ever having to mess with .dll files, save for a bit there when I was removing some text to speech DLLs to avoid a crash on launch.

No I haven’t seen that but I’ll look at it. My problem stems from the June change from the qt5 base to the qt6 base. Most debian systems are so stable that they haven’t moved to qt6 yet, so I’m having to fill in the gaps.
Thank you!

Hmm, interesting, I’m running Debian 11 (still), which is even older than the stable current version. However I have added Wine-Unstable to apt, so that I’m running 8.x at this point rather than whatever ancient version Deb11 still uses stock (5 I think?). If you aren’t doing that, this might be more fruitful than trying to figure out things from the Qt angle, because in theory Scrivener itself has everything it needs along those lines in the installer. After all, no Windows user has any of that stuff preinstalled.

My troubles aren’t with wine. Scrivener loads and starts just fine. But that first window where the templates display is totally black on qt5. It’s not a dead box. Things happen if you click in there; you just can’t tell what you’re clicking. In my previous install which was LMDE6, I added in the qt6 files and everything worked correctly.

I believe I’ve found the site where I downloaded a particular qt creator package that facilitated that good installation but I didn’t have time last night to try it before sleepy time. Believe me, I’m documenting EVERYTHING I do this time around lol.

I did run wine 8.x at one time in installations unremembered, but I found that the stable version has never been (my) problem. Thank you for your time.

1 Like

Ha ha I took a look at that guide and yes I used it on my last good install. He has a good sense of humor.

Okay, to clear the air and put this to bed, the site I found was indeed the one I used to successfully set up Scrivener on LMDE6, but it didn’t help one bit with Linux Mint. I mulled over everything today at work, and knowing that I had installed up to .net 4.6.2 (because that’s always worked before), I decided to go on to 4.8. That fixed things, and Scrivener is working and registered.

Side note: I did not know until you mentioned it that Scrivener contains the needed qt files. I was under the impression that they had to be supplied by the system. Oh, well.

Thank you all for your suggestions. Happy writing.

1 Like