Scrivener Licensing Fails on Linux Mint 21.3 Virginia - Cinnamon 6.0.4

Scrivener Licensing Fails on Linux Linux Mint 21.3 Virginia - Cinnamon 6.0.4

Please help. I am a long time Scrivener user who recently converted to Linux-Cinnamon and upgraded to the latest Windows version of Scrivener with the understanding it will work under Linux.

Though new to Linux I am comfortable with command line instructions.

The program is running well, but I am unable to activate the license for Scrivener.

I have read and followed the instructions from these pages:

System Information:

Kernel: 5.15.0-106-generic x86_64 bits: 64 compiler: gcc v: 11.4.0 Desktop: Cinnamon 6.0.4
tk: GTK 3.24.33 wm: muffin vt: 7 dm: LightDM 1.30.0 Distro: Linux Mint 21.3 Virginia
base: Ubuntu 22.04 jammy

dotnet-host is, version (6.0.128-0ubuntu1~22.04.2).

From the Install Log:
wine64 is already the newest version (6.0.3~repack-1).
winetricks is already the newest version (0.0+20210206-2).
wine32:i386 is already the newest version (6.0.3~repack-1).
winbind is already the newest version (2:4.15.13+dfsg-0ubuntu1.6).

There are no errors, but was warned twice with :
warning: You are using a 64-bit WINEPREFIX. Note that many verbs only install 32-bit versions of packages. If you encounter problems, please retest in a clean 32-bit WINEPREFIX before reporting a bug.

Since I don’t know anything about WINEPREFIX and what I saw on one of the solution pages didn’t seem applicable, it seems best to stop and ask for help.

What did I miss, or mess up ?

Thanks in advance,

  • Jeff

I don’t know if this will fix things or not, but I’d definitely try upgrading to the latest stable version of Wine, as v6 is several years old at this point. It will upgrade your prefix automatically when you try to launch Scrivener, so back up ~/.wine (or wherever Scrivener is) before doing so, should you need to downgrade. As I recall I uninstalled everything related first before adding their apt repository, but I don’t know if that is strictly speaking necessary.

Another thing to check, as it wasn’t clear to me, but you have dotnet installed in the prefix with winetricks, right? You’ll definitely know if you have done that, because the process is a whole mess of MS installers that run one after the other.

The warning message about 32-bit verbs can be ignored. I’ve never run into any issues running Scapple or Scrivener with those warnings.

Thank you Amber. My system is already at Ubuntu 22.04 (Jammy Jellyfish.) I believe this is the latest version. though I do see from the install log Scrivener reports version 6.03. Should I try reinstalling 22.04 ?

dotnet 40 and dotnet 48 are selected. I will continue researching to see if other versions need to be added. I remember reading something about that.


I’ve tried to change to dotnet 4.62 as one page suggests. After all is said and done the defaults revert back to dotnet 40 and dotnet 48.

Sorry, to clarify I meant upgrading Wine itself, not the whole OS. If you follow the instructions on that page (and there are some troubleshooting notes from 22.04 I noticed), it will show you how to subscribe to Wine’s own repository that is designed to work on your system, and upgrade you to version 9, rather than the version 6 that comes with 22.04. Hopefully that makes more sense.

The good news is :
"$ wine --version
Scrivener still won’t activate the license.
I apologize we’re still having trouble, Amber, and appreciate your help. I’ll stop for the day. Please keep the suggestions coming and I’ll keep reading and testing.

  • Jeff

FYI for ALL:
I asked ChatGPT a question about why wine shows a 22.04 version and 9.0 version. Here’s its answer:

The discrepancy you’re seeing likely arises from the way Wine versions are labeled and how they relate to the actual release version.

The version reported by wine --version refers to the compatibility layer itself, which is currently at version 9.0. This version number indicates the development stage and compatibility level of Wine. The 9.0 version signifies that it is a development release, likely from the 9.x series.

On the other hand, the version number you mentioned (22.04) may refer to the year and month of the Wine project, indicating that it was last updated or maintained in April 2022. This is not the same as the version of Wine itself.

To clarify, Wine’s versioning scheme often uses two different numbers to signify its version: one for the development stage (e.g., 9.0 for a development release) and another for the actual release (e.g., 22.04 for an April 2022 release).

I’ve performed a clean install on a fresh version of Linux on a different computer. The end result when attempting to activate the license is the same. The module fails and sometimes crashes. There are errors such as “The License manager ended unexpectedly. Installing .NET v4.6.2 or higher and the latest critical and recommended Windows Updates will most likely resolve this issue.” And an “Activation Failed” message.

I’d like to delete the registry keys for Scrivener. Does anyone know what they are named. I can’t find the ones listed on the Internet.

Alternatively - If they are missing I’d like to try and import them or manually enter them

I don’t know about that ChatGPT answer; it may have produced inaccuracies from the question itself, as 22.04 refers to the Ubunto version that Mint is based off of.

As for the probem itself though, have you tried this solution:

The registry keys are located here:


To perform a full reset of settings, delete that group. You can back it up first via the File menu, with Export.

Thanks Amber. I do understand and appreciate your comment about ChatGPT.

I did work into the evening on this and located the registry location as well as several file locations, all of these were deleted and another install performed. The result is the same. The license activation fails.

I did perform the winetricks dotnet48 – force and today verified it is still selected in winetricks.

There is time to dedicate to this, but hope we’ll see a resolution soon as my migration to Linux is a non-trivial decision and while I have a Windows 10 desktop , it’s not where I want to install Scrivener.

Also I recognize that I might be doing something wrong and not yet having an intimate relationship with Linux, I could have either done something out of order or otherwise not understood the process. That said, I performed the instructions in the posts you shared and the also the ones listed at the top of the post. I think I can now post the full list of URLs where when the original post was made there was a max of two. Write if you would like the full URLs re-posted in a reply.

Should we not have an easy solution, would it be possible to activate my license on a literatureandlatte computer then send that part of the registry so an import could be of the encrypted portion of the registry be tried ? I know it’s not guaranteed and may not be desirable from the literatureandlatte perspective, so it’s OK if that can’t be done.


  • Jeff

Okay, if I’m reading their post correctly, they seem to be specifically saying that does not work, whereas winetricks --force dotnet48 does work. It could be the force flag is meant to be a modifier for the package or action that follows it, so it fails in the second position (that’s just a wild guess though).

I did not have to do that myself, but I set this up on a Debian machine (which is kind of the super vanilla OS that Ubuntu forks from, and Mint then forks from it, so who knows what elements of surprise that adds), and frankly it was a long time ago as well, back when Wine 5 was still the latest.

Should we not have an easy solution, would it be possible to activate my license on a literatureandlatte computer then send that part of the registry so an import could be of the encrypted portion of the registry be tried ? I know it’s not guaranteed and may not be desirable from the literatureandlatte perspective, so it’s OK if that can’t be done.

Alas that will not work. Like most activation modules, our vendor’s checks for conditions where the hardware appears to have changed underneath the activation, and will deactivate upon attempt to do so.

You might consider another alternative: use the free VirtualBox, and install your copy of Windows 10 into it. Win10 + Scrivener is pretty economical, and of course Linux itself does not demand a lot of resources, so even though you’d then be running an OS on top of an OS, it is something even a moderately capable laptop can handle comfortably. When I use this setup, I set it to about 2.7GB of RAM (yeah, that’s all you need!) and allocate only one CPU core to it. I do not feel the impact on the host machine, and Scrivener itself runs well, for even large projects. VirtualBox lets you map Linux folders directly into the Windows instance as drive mappings, so you can work straight out of your primary working areas at full speed, keeping the virtual machine itself clean of anything but the OS and the software.

It’s certainly a bit bulkier than Wine, but it’s not a terrible approach. Hopefully just flipping the order of flags on the command-line gets you up and running though. :slight_smile:

Virtualization has been running through my mind. I’ll begin to look at it and see if I can image my old Windows 10 on in to it.

I ran the winetricks --force dotnet48 both ways and neither did work, so unless you uncover a new hack I’ll see if the virtualization can be finished in the next few days. Look for an update early next week.


  • Jeff


I’m going to have to put this aside due to other commitments.

Virtualbox is running. My Windows licence is old and though it’s certain to be filed away somewhere, it’s not been seen in years. It may be easier to install Scrivener on an existing Windows computer for now.

Thank you for working with me. I’ll leave a note if I ever get it working on this computer.

Kind Regards,

  • Jeff
1 Like