Scrivener No Longer Recognizes That I Have a Cover Photo!

I emailed tech support with this, but I’m anxious about it.

My name is Ann and I have a full version of Scrivener for windows. The other day I compiled my second novel for preview on my kindle to make sure it looked good. There were no problems, everything showed up fine, including the cover. Last night I tried to compile the final file for publication and scrivener refuses to even recognize I have a front matter folder with the cover .jpg file. Nothing has changed in the structure of the project. I haven’t done anything to it outside of pressing the composite button. So, basically, I can’t get it to load my cover in the compile, or recognize the front matter folder. It’s not just this project, though. It’s doing it across all of my projects now (I even tried creating a new one and it did it) which are set up the same way as the project in question (which compiled perfectly just a few days ago). I don’t know if I’m having a giant brain fart or what, but I’m super frustrated.

The only thing I can think of is that it started doing it after I imported a project from another computer.

The official version of Scrivener for Windows (version 1.6.1) doesn’t have an option for using a front matter folder in the Contents pane of the Compile window. The Beta version ( beta) does, however. Is it possible that you have a separate installation for the beta version that you were using previously, but now you’ve opened your projects using the official (1.6.1) version?

I have a full version on my main computer that recognized the front matter folder just fine, but the other pc is a trial version. I did import a project from that and the full version no longer recognizes that I have a cover/front matter folder.

If it won’t recognize that I have a front matter folder, how do I get it to let me choose my cover?

In the expanded compile window, there’s a “Cover” section if the output selected (Compile For:) supports it. Mostly that is for epub/kindle formats. Otherwise, for PDF, html, rtf, etc… you have to create a document and add the graphic to that document, then included that document in your draft.

Yeah, that’s the problem. I’m compiling for .mobi & .epub and when I bring up the compile menu/box and click cover, it doesn’t recognize that there are any .jpgs in scrivener at all
It was recognizing it fine on my current project the other day until I imported another project from the other computer that has the trial version

Ah, sorry; Have you tried importing another copy of the cover image to your project? Does it show up in the list of available images then? If it’s not available, then maybe export the ones you have in your projects and then re-import them.

One last ditch effort would be to try the beta version (look for the sub-forum under the Scrivener For Windows section), installing it in an alternative folder from the official one, and then seeing if that version will recognize the image files in your projects.

I have tried importing multiple copies of the .jpg into the project. It shows up in the project fine, but the composite box won’t recognize it’s there. I’ll try your suggestion of installing the trial version in a separate folder.

Do other images imported into the binder appear in the menu for the cover image?

Just to be clear, there’s no difference between the “trial” version and the “full” version other than that you’ve entered your licence information. It’s the version number that counts, which you can find under Help > About Scrivener. The current official release is 1.6.1, but you may have an older version on one of your machines.

The beta version that Robert referred to is newer,, and is in-progress, not ready for official release yet. It is available for testing from the Windows beta forum. It has new features such as the “Front Matter” feature Robert mentions, which allows you during compile to select a document or folder outside of the Draft folder and add it to the top of the compile contents. This has no effect on choosing a cover image for ebook formats, however–the menu in the cover section should be listing all images imported into the binder, wherever they are, so it doesn’t matter whether it’s in a “Front Matter” folder or not.

Ugh, now Scrivener isn’t even letting me import pictures! I go to import from the file menu, add files… and all it brings up is my word docs. bangs head on desk repeatedly
Yes, I’m in the folder where the photo is kept. All it sees is every other file except the picture. I’ve tried other folders I had copies saved to as well. And yes I tried changing the “all supported files” drop down menu to see if there was a .jpg option, but there isn’t.

Would completely uninstalling & reinstalling scriv fix this? Would I have to purchase it again or can I use my registration code? I’m getting close to tears here because it was working fine until that import from the other pc!

It sounds like you just have the Draft folder (or a subdocument of the Draft) selected in the binder. The Draft folder only supports text documents, since it’s intended for compile. Try selecting the Research folder and then importing the image.

I don’t know if this will help me explain further or not, but I thought I’d try. Right now it’s set to the default epub, but it doesn’t matter what extension I change it to. It’s not recognizing any folders or any .jpgs

Thanks, that did help. The problem is that you’ve dragged your “Front Matter” folder into the Draft folder–which here is renamed “MOONLIGHT” (it’s the top one in the screenshot, with the special icon). This is a bug (fixed for the next release), because the Draft folder only supports text files, as I said, and you shouldn’t be able to drag in a container that has non-text subdocuments. Now that the folder is there, its image file isn’t being recognised, because the Draft isn’t supposed to be able to contain images, so no images are getting pulled from it for the Cover list.

Moving your Front Matter folder outside of the Draft folder will let it be recognised again properly. Just select the folder and then use Ctrl+LeftArrrow twice to move the folder out a level so it becomes a root folder rather than a child of the Draft. (You could also drag with the mouse, but in this case you might find the keyboard shortcut easier.)

Okay, the ctrl left left was nifty (thanks for that tip), but it didn’t fix it.

Oh and for reference here is the one imported from the other PC that is making me equally frustrated. The only folder it recognizes is character sketch. I don’t even SEE character sketch on there! (and I looked in sub folders for it even)

According to the path in the menu, the Character Sketch is in the Trash folder, which isn’t expanded in the screen shot. You could try using the project search in the main toolbar to look for “character sketch” and see if it comes up. (Then just click the “X” in the project search field to return to the regular binder.)

What format are the images you’re importing for the cover? The “TSBcover” file in the binder, which I assume is what you’re trying to use, doesn’t have the usual image icon, so I’m wondering if you’ve just imported a type that Scrivener doesn’t recognise as an image file and doesn’t support for the cover image. You did mention JPG earlier for the other project, but it looks like you’ve got something different here.

Did you check Help > About Scrivener and ensure the version number is 1.6.1? If you’ve got something earlier, that could be part of the problem.

The pictures changed to blue icons when I imported the other project, and I don’t know how to change them back. They are still .jpgs but open with the windows 8 “photos” app. I’ve told it to stop doing it multiple times (the whole “do you want to make this your default program” yadda yadda) but it doesn’t seem to want to listen.

I’m running windows 8 on my main computer, and the other one runs xp.

I did manage to find that hidden folder and move the picture I used to the “front matter” folder, but it’s still not showing up.

The current version is

So I downloaded the 1.7 beta of Scriv and it fixed everything, but I think I forgot to save it to a separate drive. What will happen on March 1st when the beta expires? Will it go back to my regular scrivener or will I need to reinstall scrivener altogether?

Curiouser and curiouser. I’m glad you’ve at least got it working though!

The beta stops working after March first; it doesn’t change anything else on your computer, so you’ll need to uninstall it at that point. If you installed over your 1.6.1 version, as it sounds, then after the uninstall you’ll have no Scrivener on the computer and will need to download and install the current release (or the new beta). None of this should affect your registration settings, if you’ve already entered your licence info on this computer, so although the download is the same as for the trial, once you run it Scrivener should find your registration details and you’ll be good to go. If you do need to activate again or re-enter your licence info, just copy and paste from your order confirmation email as before–you’re allowed multiple registrations with the same licence, so this won’t be a problem at all.

Thank you so much for your help and patience!

One last question. The fonts I use in Scriv never translate over to my kindle. My copy of Scrivener has the Castellar font and I really like it for chapter headings, but when I compile to .mobi it just comes across as the default kindle font.
Any way to convince it to use castellar?

Ebook formatting is limited to what the different devices support, and the intention is to let the reader choose how to display the text. One person might choose Baskerville at 14pt and another will pick Courier at 12pt. (Not actually sure on the specific sizes–it’s “Bigger” or “Smaller” for user-friendliness I suppose.) In general it’s not a good idea to try to force a particular font or size on the reader, although there can be exceptions–check the KDP guidelines (and guidelines for any other formats you’re using). In the case of font, you’d need to embed the font in the book if it’s not one supported on all devices by default–and there are only a few options that all of them do, especially older Kindles–and that brings up file size and distribution licencing issues. Scrivener doesn’t provide a way itself to embed a font, so if you were going to do this, you’d need to use another tool after compiling.

That said, in small doses special formatting is usually fine, and a common method of embellishing chapter titles is to use an image. For this you’d insert the image directly into the document in Scrivener. If you’re going to replace the text with this, though, I’d do a little google searching and experimentation to see if there are concerns about scaling and the text not reading well in that case. I’m a little fuzzy on the details for this these days, although this is a good reminder that I should go check into that.